summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2005-11-24 22:01:26 +0000
committerLuca Longinotti <chtekk@gentoo.org>2005-11-24 22:01:26 +0000
commitbde02b3995310a31f90a3316bab1086e1be6608a (patch)
treeffb29a99df0c1b4134bf586aefc47e42eea54767 /dev-php4
parentFix some var ordering. (diff)
downloadhistorical-bde02b3995310a31f90a3316bab1086e1be6608a.tar.gz
historical-bde02b3995310a31f90a3316bab1086e1be6608a.tar.bz2
historical-bde02b3995310a31f90a3316bab1086e1be6608a.zip
Sync with overlay.
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'dev-php4')
-rw-r--r--dev-php4/pecl-apd/ChangeLog6
-rw-r--r--dev-php4/pecl-apd/Manifest5
-rw-r--r--dev-php4/pecl-apd/files/fix-version-string-0.9.2.patch11
-rw-r--r--dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild36
4 files changed, 45 insertions, 13 deletions
diff --git a/dev-php4/pecl-apd/ChangeLog b/dev-php4/pecl-apd/ChangeLog
index f22545d091b6..9ed48bdd703f 100644
--- a/dev-php4/pecl-apd/ChangeLog
+++ b/dev-php4/pecl-apd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php4/pecl-apd
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apd/ChangeLog,v 1.2 2005/10/15 21:49:14 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apd/ChangeLog,v 1.3 2005/11/24 22:01:26 chtekk Exp $
+
+ 24 Nov 2005; Luca Longinotti <chtekk@gentoo.org>
+ +files/fix-version-string-0.9.2.patch, pecl-apd-0.9.2.ebuild:
+ Sync with PHP overlay, fix displayed version string.
15 Oct 2005; Jason Wever <weeve@gentoo.org> pecl-apd-0.9.2.ebuild:
Added ~sparc keyword.
diff --git a/dev-php4/pecl-apd/Manifest b/dev-php4/pecl-apd/Manifest
index dbbe7fc4d4cd..d61d90e71ffd 100644
--- a/dev-php4/pecl-apd/Manifest
+++ b/dev-php4/pecl-apd/Manifest
@@ -1,4 +1,5 @@
-MD5 273fd509d89f0dcf456702d35a21d3ec ChangeLog 441
+MD5 fec4d7cbc101b10bdf4f8da9846c99cf ChangeLog 613
MD5 ab22b4ee784597a319c8c74368918d1c files/digest-pecl-apd-0.9.2 57
+MD5 bf92949b02d0103cf353ceef2371189d files/fix-version-string-0.9.2.patch 280
MD5 c58d07ca1c1235bbad9bccaec96fc062 metadata.xml 157
-MD5 fd1131d373b39d03a254cc46edf5fb31 pecl-apd-0.9.2.ebuild 608
+MD5 e523db6f8bfef04adb6b77d5a59d1c61 pecl-apd-0.9.2.ebuild 958
diff --git a/dev-php4/pecl-apd/files/fix-version-string-0.9.2.patch b/dev-php4/pecl-apd/files/fix-version-string-0.9.2.patch
new file mode 100644
index 000000000000..d48affc08018
--- /dev/null
+++ b/dev-php4/pecl-apd/files/fix-version-string-0.9.2.patch
@@ -0,0 +1,11 @@
+--- php_apd.h 2004/03/10 16:40:55
++++ php_apd.h 2004/10/20 14:17:02
+@@ -89,7 +89,7 @@
+ extern zend_module_entry apd_module_entry;
+ #define apd_module_ptr &apd_module_entry
+
+-#define APD_VERSION "0.9.1"
++#define APD_VERSION "0.9.2"
+
+ #define FUNCTION_TRACE 1
+ #define ARGS_TRACE 2
diff --git a/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild b/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild
index 6f5f63121d87..f006c95ebd6b 100644
--- a/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild
+++ b/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild
@@ -1,25 +1,41 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild,v 1.2 2005/10/15 21:49:14 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php4/pecl-apd/pecl-apd-0.9.2.ebuild,v 1.3 2005/11/24 22:01:26 chtekk Exp $
-PHP_EXT_ZENDEXT="yes"
-PHP_EXT_PECL_PKG="apd"
PHP_EXT_NAME="apd"
PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="yes"
inherit php-ext-pecl-r1
-IUSE=""
+KEYWORDS="~sparc ~x86"
DESCRIPTION="A full-featured engine-level profiler/debugger."
-SLOT="0"
LICENSE="PHP"
-KEYWORDS="~sparc ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="${RDEPEND} >=dev-php/PEAR-Console_Getopt-1.2-r1 !dev-php4/ZendOptimizer"
need_php_by_category
-src_install () {
- sed -i 's:/usr/local:/usr:g' ${S}/pprofp || die #83612
+pkg_setup() {
+ has_php
+
+ require_php_cli
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+
+ epatch "${FILESDIR}/fix-version-string-0.9.2.patch"
+}
+
+src_install() {
+ sed -i 's:/usr/local/bin/php:/usr/lib/php4/bin/php:g' "${S}/pprofp" || die "Unable to replace PHP path"
+ sed -i 's:pprofp:pprofp-php4:g' "${S}/pprofp" || die "Unable to replace PHP path"
php-ext-pecl-r1_src_install
- dobin pprofp
- dodoc LICENSE README
+ newbin pprofp pprofp-php4
+ dodoc-php LICENSE README
}