summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-03-08 23:49:23 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-03-08 23:49:23 +0000
commitf743d384768a4ade2a7274a5012b34921e5125d6 (patch)
treedfcaca8913bedda7387936534942f6d2412de39b /dev-ml
parentFixed minorsyn errors in the new ebuild. (diff)
downloadhistorical-f743d384768a4ade2a7274a5012b34921e5125d6.tar.gz
historical-f743d384768a4ade2a7274a5012b34921e5125d6.tar.bz2
historical-f743d384768a4ade2a7274a5012b34921e5125d6.zip
curl binding for OCaml.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocurl/ChangeLog10
-rw-r--r--dev-ml/ocurl/Manifest4
-rw-r--r--dev-ml/ocurl/files/0.1.6-curl-helper.patch18
-rw-r--r--dev-ml/ocurl/files/digest-ocurl-0.1.61
-rw-r--r--dev-ml/ocurl/metadata.xml5
-rw-r--r--dev-ml/ocurl/ocurl-0.1.6.ebuild32
6 files changed, 70 insertions, 0 deletions
diff --git a/dev-ml/ocurl/ChangeLog b/dev-ml/ocurl/ChangeLog
new file mode 100644
index 000000000000..25ee9742722d
--- /dev/null
+++ b/dev-ml/ocurl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/ocurl
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ChangeLog,v 1.1 2005/03/08 23:49:23 mattam Exp $
+
+*ocurl-0.1.6 (09 Mar 2005)
+
+ 09 Mar 2005; Matthieu Sozeau <mattam@gentoo.org>
+ +files/0.1.6-curl-helper.patch, +ocurl-0.1.6.ebuild:
+ curl binding for ocaml.
+
diff --git a/dev-ml/ocurl/Manifest b/dev-ml/ocurl/Manifest
new file mode 100644
index 000000000000..851bcbdf3363
--- /dev/null
+++ b/dev-ml/ocurl/Manifest
@@ -0,0 +1,4 @@
+MD5 060cf5a184892f3f3188ad1597d989a9 ocurl-0.1.6.ebuild 582
+MD5 648a541494aceee26dbcfd76164f37ea metadata.xml 157
+MD5 b3ad04549e513bda899ad2c0b85bd1c1 files/digest-ocurl-0.1.6 59
+MD5 e5efa2a77ab5e531258715d1254fb7f5 files/0.1.6-curl-helper.patch 750
diff --git a/dev-ml/ocurl/files/0.1.6-curl-helper.patch b/dev-ml/ocurl/files/0.1.6-curl-helper.patch
new file mode 100644
index 000000000000..a007ce325bbf
--- /dev/null
+++ b/dev-ml/ocurl/files/0.1.6-curl-helper.patch
@@ -0,0 +1,18 @@
+--- curl-helper.c~ 2003-12-03 19:48:31.000000000 +0100
++++ curl-helper.c 2004-05-04 21:23:07.917507520 +0200
+@@ -2249,13 +2249,13 @@
+ case 0: /* TIMECOND_IFMODSINCE */
+ result = curl_easy_setopt(conn->connection,
+ CURLOPT_TIMECONDITION,
+- TIMECOND_IFMODSINCE);
++ CURL_TIMECOND_IFMODSINCE);
+ break;
+
+ case 1: /* TIMECOND_IFUNMODSINCE */
+ result = curl_easy_setopt(conn->connection,
+ CURLOPT_TIMECONDITION,
+- TIMECOND_IFUNMODSINCE);
++ CURL_TIMECOND_IFUNMODSINCE);
+ break;
+
+ default:
diff --git a/dev-ml/ocurl/files/digest-ocurl-0.1.6 b/dev-ml/ocurl/files/digest-ocurl-0.1.6
new file mode 100644
index 000000000000..ced08399cde7
--- /dev/null
+++ b/dev-ml/ocurl/files/digest-ocurl-0.1.6
@@ -0,0 +1 @@
+MD5 d48751541e9b54fccb7bc21589b26907 ocurl-0.1.6.tgz 50082
diff --git a/dev-ml/ocurl/metadata.xml b/dev-ml/ocurl/metadata.xml
new file mode 100644
index 000000000000..849ed8ebf13d
--- /dev/null
+++ b/dev-ml/ocurl/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocurl/ocurl-0.1.6.ebuild b/dev-ml/ocurl/ocurl-0.1.6.ebuild
new file mode 100644
index 000000000000..6f8d57c0d4e3
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocurl/ocurl-0.1.6.ebuild,v 1.1 2005/03/08 23:49:23 mattam Exp $
+
+inherit eutils findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://sourceforge.net/projects/ocurl"
+LICENSE="MIT"
+SRC_URI="mirror://sourceforge/ocurl/${P}.tgz"
+
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=net-misc/curl-7.9.8
+dev-libs/openssl"
+RDEPEND="$DEPEND"
+KEYWORDS="x86 ppc"
+
+src_compile()
+{
+ epatch ${FILESDIR}/${PV}-curl-helper.patch
+ econf --with-findlib || die
+ make all || die
+}
+
+src_install()
+{
+ findlib_src_install
+ dodoc COPYING
+ use doc && dodoc examples/*.ml
+}