summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-03-08 23:13:27 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-03-08 23:13:27 +0000
commit98874c0167f2b0fd234886e94c90472a7a8baade (patch)
treeffa734c77cd9474813e47407bb6e260061ee800b /dev-ml
parentAdded new hmake version (diff)
downloadhistorical-98874c0167f2b0fd234886e94c90472a7a8baade.tar.gz
historical-98874c0167f2b0fd234886e94c90472a7a8baade.tar.bz2
historical-98874c0167f2b0fd234886e94c90472a7a8baade.zip
Fix data files installation path and add pop library.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog5
-rw-r--r--dev-ml/ocamlnet/Manifest6
-rw-r--r--dev-ml/ocamlnet/ocamlnet-0.98.ebuild10
3 files changed, 13 insertions, 8 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 9ae67f803e4d..e1502fd1ecd7 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.10 2005/02/18 17:37:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.11 2005/03/08 23:13:27 mattam Exp $
+
+ 09 Mar 2005; Matthieu Sozeau <mattam@gentoo.org> ocamlnet-0.98.ebuild:
+ Fix data files installation, add pop library.
18 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> ocamlnet-0.98.ebuild:
fix repoman issues; tidy
diff --git a/dev-ml/ocamlnet/Manifest b/dev-ml/ocamlnet/Manifest
index c09828881713..cc94dc0d25d9 100644
--- a/dev-ml/ocamlnet/Manifest
+++ b/dev-ml/ocamlnet/Manifest
@@ -1,8 +1,8 @@
-MD5 d14e540327baba8c0e2024b1a3bfd7db ChangeLog 1190
-MD5 e03f9a8a89002763dcd26416f218a62a ocamlnet-0.95.ebuild 831
+MD5 f55a5b8ce32758d734203bc6753bea46 ChangeLog 1309
MD5 845dbbef4eb685e1bfd5f9e13a03f2b8 metadata.xml 225
+MD5 e03f9a8a89002763dcd26416f218a62a ocamlnet-0.95.ebuild 831
MD5 fa0a4de161ccb100f1199d850b18121e ocamlnet-0.97.1.ebuild 740
-MD5 af512e67d4729d384f5d63063392efca ocamlnet-0.98.ebuild 760
+MD5 dfdeff530b6048b95cd7c0146ae7c7c8 ocamlnet-0.98.ebuild 798
MD5 b3137a19a01b130d78ec709fd500acfc files/digest-ocamlnet-0.95 65
MD5 b216ee5c5e591dcc4ebde2b7d8ed2d01 files/digest-ocamlnet-0.97.1 67
MD5 425492e930c801900aa5493bbe7647c4 files/digest-ocamlnet-0.98 65
diff --git a/dev-ml/ocamlnet/ocamlnet-0.98.ebuild b/dev-ml/ocamlnet/ocamlnet-0.98.ebuild
index 3990f502f430..387e85156e18 100644
--- a/dev-ml/ocamlnet/ocamlnet-0.98.ebuild
+++ b/dev-ml/ocamlnet/ocamlnet-0.98.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-0.98.ebuild,v 1.2 2005/02/18 17:37:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-0.98.ebuild,v 1.3 2005/03/08 23:13:27 mattam Exp $
inherit findlib
@@ -10,20 +10,22 @@ SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
LICENSE="as-is"
KEYWORDS="~ppc ~x86"
-SLOT=")"
+SLOT="0"
IUSE=""
DEPEND=">=dev-ml/pcre-ocaml-4.31.0"
S="${WORKDIR}/${P}/src"
+DATADIR=/usr/share/${PN}
+
src_compile() {
- ./configure || die "configure failed"
+ ./configure -with-pop -datadir ${DATADIR} || die "configure failed"
make all opt || die "make failed"
}
src_install() {
- findlib_src_install NET_DB_DIR="${D}${OCAML_SITELIB}/netstring"
+ findlib_src_install NET_DB_DIR="${D}${DATADIR}"
cd "${WORKDIR}/${P}"
dodoc README