summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-21 13:13:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-21 13:13:50 +0000
commit81a7ac44b1952e92e7955793c4c375e78fcdc33e (patch)
tree3ac4a154864fe325391ea84df94afdeb86330212 /dev-ml
parentadd latest postgresql-ocaml to ocaml 3.11 mask and update reason for masking (diff)
downloadhistorical-81a7ac44b1952e92e7955793c4c375e78fcdc33e.tar.gz
historical-81a7ac44b1952e92e7955793c4c375e78fcdc33e.tar.bz2
historical-81a7ac44b1952e92e7955793c4c375e78fcdc33e.zip
version bump
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog8
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 40c4d5a7c880..dec60598a9b3 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.9 2009/06/21 12:59:02 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.10 2009/06/21 13:13:50 aballier Exp $
+
+*postgresql-ocaml-1.11.1 (21 Jun 2009)
+
+ 21 Jun 2009; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.11.1.ebuild:
+ version bump
21 Jun 2009; Alexis Ballier <aballier@gentoo.org>
postgresql-ocaml-1.8.2.ebuild:
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild
new file mode 100644
index 000000000000..cbe431814eed
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.11.1.ebuild,v 1.1 2009/06/21 13:13:50 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=virtual/postgresql-base-7.3
+ >=virtual/postgresql-server-7.3"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}