summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-25 12:44:43 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-25 12:44:43 +0000
commit7dda071e188528d401d43cad464fbd3cc68d6c7a (patch)
tree2e1206117f9a7e8e05a9b68df75bd7e660109882 /dev-ml
parentAdded ~sparc keyword. (diff)
downloadhistorical-7dda071e188528d401d43cad464fbd3cc68d6c7a.tar.gz
historical-7dda071e188528d401d43cad464fbd3cc68d6c7a.tar.bz2
historical-7dda071e188528d401d43cad464fbd3cc68d6c7a.zip
New revision using findlib eclass.
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlzip/ChangeLog8
-rw-r--r--dev-ml/camlzip/Manifest9
-rw-r--r--dev-ml/camlzip/camlzip-1.01-r1.ebuild36
-rw-r--r--dev-ml/camlzip/files/META2
-rw-r--r--dev-ml/camlzip/files/camlzip-1.01-Makefile-findlib.patch23
-rw-r--r--dev-ml/camlzip/files/digest-camlzip-1.01-r11
-rw-r--r--dev-ml/pomap/Manifest4
7 files changed, 76 insertions, 7 deletions
diff --git a/dev-ml/camlzip/ChangeLog b/dev-ml/camlzip/ChangeLog
index 644f905da063..a86e946bf8b6 100644
--- a/dev-ml/camlzip/ChangeLog
+++ b/dev-ml/camlzip/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/camlzip
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.1 2004/08/18 12:01:52 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/ChangeLog,v 1.2 2004/08/25 12:44:43 mattam Exp $
+
+*camlzip-1.01-r1 (25 Aug 2004)
+
+ 25 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> files/META,
+ +files/camlzip-1.01-Makefile-findlib.patch, +camlzip-1.01-r1.ebuild:
+ Move to findlib eclass, ebuild cleanup.
*camlzip-1.01 (18 Aug 2004)
diff --git a/dev-ml/camlzip/Manifest b/dev-ml/camlzip/Manifest
index 525c7c402a9f..d98fb66222d0 100644
--- a/dev-ml/camlzip/Manifest
+++ b/dev-ml/camlzip/Manifest
@@ -1,5 +1,8 @@
-MD5 a737327021264edfcf9fcdb572849338 camlzip-1.01.ebuild 1996
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
-MD5 e24ee6e6e31c30d81f700d3362c28b21 ChangeLog 485
-MD5 144d02af76045780262191bff2b44b62 files/META 104
+MD5 ae411a1aa39717e0a644e2f623eaebf0 ChangeLog 694
+MD5 a737327021264edfcf9fcdb572849338 camlzip-1.01.ebuild 1996
+MD5 45e018ef2fd7c3840afd3f263f675f8b camlzip-1.01-r1.ebuild 877
+MD5 357f403e3152810089ea2f7bb86bf77d files/META 107
MD5 247ab601d786744715f10b4952872f98 files/digest-camlzip-1.01 63
+MD5 34f19ca145eb89c455a8767467331619 files/camlzip-1.01-Makefile-findlib.patch 801
+MD5 247ab601d786744715f10b4952872f98 files/digest-camlzip-1.01-r1 63
diff --git a/dev-ml/camlzip/camlzip-1.01-r1.ebuild b/dev-ml/camlzip/camlzip-1.01-r1.ebuild
new file mode 100644
index 000000000000..9b8930ff974a
--- /dev/null
+++ b/dev-ml/camlzip/camlzip-1.01-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlzip/camlzip-1.01-r1.ebuild,v 1.1 2004/08/25 12:44:43 mattam Exp $
+
+inherit findlib eutils
+
+IUSE=""
+
+DESCRIPTION="Compressed file access ML library (ZIP, GZIP and JAR)"
+HOMEPAGE="http://cristal.inria.fr/~xleroy/software.html#camlzip"
+SRC_URI="http://caml.inria.fr/distrib/bazar-ocaml/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=dev-lang/ocaml-3.04 \
+ >=sys-libs/zlib-1.1.3"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-Makefile-findlib.patch
+ sed -e "s/VERSION/${PV}/" ${FILESDIR}/META >> META
+}
+
+src_compile() {
+ make all || die "Failed at compilation step !!!"
+ make allopt || die "Failed at ML compilation step !!!"
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README
+}
diff --git a/dev-ml/camlzip/files/META b/dev-ml/camlzip/files/META
index c852fa144a55..988a4fc1185d 100644
--- a/dev-ml/camlzip/files/META
+++ b/dev-ml/camlzip/files/META
@@ -1,4 +1,4 @@
-version="1.01"
+version="VERSION"
requires="unix"
linkopts="-cclib -lz"
archive(byte)="zip.cma"
diff --git a/dev-ml/camlzip/files/camlzip-1.01-Makefile-findlib.patch b/dev-ml/camlzip/files/camlzip-1.01-Makefile-findlib.patch
new file mode 100644
index 000000000000..e7c4014d3c82
--- /dev/null
+++ b/dev-ml/camlzip/files/camlzip-1.01-Makefile-findlib.patch
@@ -0,0 +1,23 @@
+--- Makefile.orig 2004-08-25 14:34:02.963205056 +0200
++++ Makefile 2004-08-25 14:35:28.916138224 +0200
+@@ -55,18 +55,8 @@
+ rm -f *.o *.a
+
+ install:
+- mkdir -p $(INSTALLDIR)
+- cp zip.cma zip.cmi gzip.cmi zip.mli gzip.mli libcamlzip.a $(INSTALLDIR)
+- if test -f dllcamlzip.so; then \
+- cp dllcamlzip.so $(INSTALLDIR); \
+- ldconf=`$(OCAMLC) -where`/ld.conf; \
+- installdir=$(INSTALLDIR); \
+- if test `grep -s -c $$installdir'$$' $$ldconf || :` = 0; \
+- then echo $$installdir >> $$ldconf; fi \
+- fi
+-
+-installopt:
+- cp zip.cmxa zip.a zip.cmx gzip.cmx $(INSTALLDIR)
++ ocamlfind install camlzip META zip.cma zip.cmi gzip.cmi zip.mli gzip.mli libcamlzip.a dllcamlzip.so \
++ zip.cmxa zip.a zip.cmx gzip.cmx
+
+ depend:
+ gcc -MM -I$(ZLIB_INCLUDE) *.c > .depend
diff --git a/dev-ml/camlzip/files/digest-camlzip-1.01-r1 b/dev-ml/camlzip/files/digest-camlzip-1.01-r1
new file mode 100644
index 000000000000..0d0e36c33ebe
--- /dev/null
+++ b/dev-ml/camlzip/files/digest-camlzip-1.01-r1
@@ -0,0 +1 @@
+MD5 728940dc0958493274314d576c16ef68 camlzip-1.01.tar.gz 15113
diff --git a/dev-ml/pomap/Manifest b/dev-ml/pomap/Manifest
index 74dfacfdafda..a9e23ac377dc 100644
--- a/dev-ml/pomap/Manifest
+++ b/dev-ml/pomap/Manifest
@@ -1,6 +1,6 @@
-MD5 4ce4d15bd92c1e4f4bd629cfbc4b2446 ChangeLog 599
+MD5 d0d3d4c09768c7c9dd113e0611842349 ChangeLog 693
MD5 6a17b6dc4c2a9dcda92081783b410707 pomap-2.9.1.ebuild 899
-MD5 ac6104cd26f9edce9f685bd40a8ca522 pomap-2.9.4.ebuild 897
+MD5 d21588c49a669cee36a19808d3423d4b pomap-2.9.4.ebuild 708
MD5 648a541494aceee26dbcfd76164f37ea metadata.xml 157
MD5 da15a8448db16af8731eae5adfc70f59 files/digest-pomap-2.9.1 63
MD5 a42b972a131cab66fd85e3dc56619657 files/digest-pomap-2.9.4 63