summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-06-30 14:35:38 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-06-30 14:35:38 +0000
commit58021d3413d6eef54dbff6c7eeeca4071139e514 (patch)
tree1d666ce735866bc915d661544575ee73d7efecdf /dev-ml/pa_ounit
parentmask pa_ounit (diff)
downloadhistorical-58021d3413d6eef54dbff6c7eeeca4071139e514.tar.gz
historical-58021d3413d6eef54dbff6c7eeeca4071139e514.tar.bz2
historical-58021d3413d6eef54dbff6c7eeeca4071139e514.zip
initial import, ebuild by me
Package-Manager: portage-2.2.0_alpha114/cvs/Linux x86_64
Diffstat (limited to 'dev-ml/pa_ounit')
-rw-r--r--dev-ml/pa_ounit/ChangeLog10
-rw-r--r--dev-ml/pa_ounit/Manifest14
-rw-r--r--dev-ml/pa_ounit/metadata.xml11
-rw-r--r--dev-ml/pa_ounit/pa_ounit-108.00.01.ebuild21
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ml/pa_ounit/ChangeLog b/dev-ml/pa_ounit/ChangeLog
new file mode 100644
index 000000000000..cb9d0661e7d3
--- /dev/null
+++ b/dev-ml/pa_ounit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/pa_ounit
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pa_ounit/ChangeLog,v 1.1 2012/06/30 14:35:38 aballier Exp $
+
+*pa_ounit-108.00.01 (30 Jun 2012)
+
+ 30 Jun 2012; Alexis Ballier <aballier@gentoo.org> +pa_ounit-108.00.01.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/pa_ounit/Manifest b/dev-ml/pa_ounit/Manifest
new file mode 100644
index 000000000000..4129b0df52c6
--- /dev/null
+++ b/dev-ml/pa_ounit/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+DIST pa_ounit-108.00.01.tar.gz 47843 RMD160 83cdb96d142b655e321cad54c3a1cfb547598875 SHA1 0aaf7904490bd3e7115dfbcc0228d6be41f75303 SHA256 e53246a676211b9fb06f6ea650d35407ce46872ffd5a29d8464480bde0e6d16e
+EBUILD pa_ounit-108.00.01.ebuild 590 RMD160 ff03b594ebb70e14e4ebb1fd50ad082e3ad038ed SHA1 beae28b4bcbe15d8e6a78346b9c55ea977e1d554 SHA256 475a79240950614c2b81a13c192b89f25c31ead164e9d4f54f351f5684dbafd4
+MISC ChangeLog 369 RMD160 91f28146846e77c36643ce3729381ce3fcc32a5d SHA1 3c72bcef8162b72a65856ae9082dd2b28430c0aa SHA256 497a724c216ab7989b03a441621aed711d50a37d464606016af3e13a0a4224e3
+MISC metadata.xml 470 RMD160 cfbcbf94260e43289d708ddfd39814df9345047e SHA1 73e2b323cb5a8d9160a7a519a12bc1535921bdfc SHA256 5b93cd5b49747a9da8e95b0dd97605a9bd189ad5584a215ab225ac4d5d5cd9b8
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.19 (GNU/Linux)
+
+iEYEARECAAYFAk/vDsAACgkQvFcC4BYPU0qwXwCeMzeI4upyG0SzqAMFevC9WJnS
+01MAniG91dWk221rt/e6/xbpDh3DWr40
+=dBq/
+-----END PGP SIGNATURE-----
diff --git a/dev-ml/pa_ounit/metadata.xml b/dev-ml/pa_ounit/metadata.xml
new file mode 100644
index 000000000000..9d7a410b7f37
--- /dev/null
+++ b/dev-ml/pa_ounit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+ <longdescription lang="en">
+Pa_ounit is a syntax extension that helps writing in-line test in ocaml
+code. It allows user to register tests with a new `TEST` top-level expressions
+and automatically collects all the tests in a module (in a function
+`ounit_tests` of type `unit -> OUnit.test`).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/pa_ounit/pa_ounit-108.00.01.ebuild b/dev-ml/pa_ounit/pa_ounit-108.00.01.ebuild
new file mode 100644
index 000000000000..54b91b5abe42
--- /dev/null
+++ b/dev-ml/pa_ounit/pa_ounit-108.00.01.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pa_ounit/pa_ounit-108.00.01.ebuild,v 1.1 2012/06/30 14:35:38 aballier Exp $
+
+EAPI="4"
+
+inherit oasis
+
+DESCRIPTION="Syntax extension that helps writing in-line test in ocaml"
+HOMEPAGE="http://bitbucket.org/yminsky/ocaml-core/wiki/Home"
+SRC_URI="http://bitbucket.org/yminsky/ocaml-core/downloads/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/type-conv-3.0.5"
+RDEPEND="${DEPEND}"
+
+DOCS=( "readme.md" )