summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-24 08:34:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-24 08:34:12 +0000
commit59d369967a922b4536c6a886cd8fdfe497eb0bf9 (patch)
tree16b21b364ac1c5aae5b49f5342ef7a4e3c3ee18e /dev-ml/cudf/cudf-0.7.ebuild
parentkeyword ~arm (diff)
downloadhistorical-59d369967a922b4536c6a886cd8fdfe497eb0bf9.tar.gz
historical-59d369967a922b4536c6a886cd8fdfe497eb0bf9.tar.bz2
historical-59d369967a922b4536c6a886cd8fdfe497eb0bf9.zip
initial import, ebuild by me
Signed-off-by: aballier@gentoo.org Package-Manager: portage-2.2.14/cvs/Linux x86_64 Manifest-Sign-Key: 0x160F534A
Diffstat (limited to 'dev-ml/cudf/cudf-0.7.ebuild')
-rw-r--r--dev-ml/cudf/cudf-0.7.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/cudf/cudf-0.7.ebuild b/dev-ml/cudf/cudf-0.7.ebuild
new file mode 100644
index 000000000000..c43f2d039800
--- /dev/null
+++ b/dev-ml/cudf/cudf-0.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cudf/cudf-0.7.ebuild,v 1.1 2014/10/24 08:34:07 aballier Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Library to parse, pretty print, and evaluate CUDF documents"
+HOMEPAGE="http://www.mancoosi.org/cudf/"
+SRC_URI="https://gforge.inria.fr/frs/download.php/file/33593/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+RDEPEND="
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/extlib:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+ dev-ml/findlib
+ dev-lang/perl
+"
+
+src_compile() {
+ emake -j1 all
+ emake c-lib
+ if use ocamlopt ; then
+ emake -j1 opt
+ emake c-lib-opt
+ fi
+}
+
+src_test() {
+ emake test
+ emake c-lib-test
+}
+
+src_install() {
+ emake DESTDIR="${ED}" LIBDIR="/usr/$(get_libdir)" install
+ dodoc BUGS ChangeLog README TODO
+}