summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-09-28 23:31:41 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-09-28 23:31:41 +0000
commit55807aa4ae26c7ed7b4d18bdd647adb88bf4ad8b (patch)
treebbf42d3ffaafc8fdcf4ecfa0e165f86d7a4fb3ab /dev-lisp
parentinitial imoprt (diff)
downloadhistorical-55807aa4ae26c7ed7b4d18bdd647adb88bf4ad8b.tar.gz
historical-55807aa4ae26c7ed7b4d18bdd647adb88bf4ad8b.tar.bz2
historical-55807aa4ae26c7ed7b4d18bdd647adb88bf4ad8b.zip
initial imoprt
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-sha1/Manifest6
-rw-r--r--dev-lisp/cl-sha1/cl-sha1-1.0.ebuild31
-rw-r--r--dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch39
-rw-r--r--dev-lisp/cl-sha1/files/digest-cl-sha1-1.01
4 files changed, 74 insertions, 3 deletions
diff --git a/dev-lisp/cl-sha1/Manifest b/dev-lisp/cl-sha1/Manifest
index b1161916f2aa..93eec8ddf820 100644
--- a/dev-lisp/cl-sha1/Manifest
+++ b/dev-lisp/cl-sha1/Manifest
@@ -1,4 +1,4 @@
-MD5 698bd00178f26e04bf7cb5e6285c75e7 cl-sha1-1.0.ebuild 756
-MD5 b1a4fca8216b97940c9c886ccc06110a cl-sha1-1.0.ebuild~ 689
-MD5 da7ef33cbf5bb7dd7fe2f1fa486b26fe files/digest-cl-sha1-20030911 66
+MD5 6e5dd72538b044152a5795803de02d59 ChangeLog 317
+MD5 0b7958344bbfca550351218e8624e771 cl-sha1-1.0.ebuild 751
MD5 8e9b4e113e34b8bd29e9198b7ca943bf files/digest-cl-sha1-1.0 61
+MD5 65f390555f7727b1d879b088df6adb4e files/cl-sha1-gentoo.patch 1309
diff --git a/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild b/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild
new file mode 100644
index 000000000000..4389ed19c8fe
--- /dev/null
+++ b/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-sha1/cl-sha1-1.0.ebuild,v 1.1 2003/09/28 23:31:38 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package for SHA1 Message Digests"
+HOMEPAGE="http://www.cs.rice.edu/~froydnj/lisp/
+ http://www.cliki.net/sb-sha1"
+SRC_URI="mirror://gentoo/sb-sha1-${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=sb-sha1
+
+S=${WORKDIR}/sb-sha1
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/cl-sha1-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install *.asd *.lisp
+ common-lisp-system-symlink
+ dodoc README
+}
diff --git a/dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch b/dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch
new file mode 100644
index 000000000000..f87dc0ae064c
--- /dev/null
+++ b/dev-lisp/cl-sha1/files/cl-sha1-gentoo.patch
@@ -0,0 +1,39 @@
+diff -ur sb-sha1/sb-sha1.asd sb-sha1-1.0/sb-sha1.asd
+--- sb-sha1/sb-sha1.asd 2003-08-08 02:28:18.000000000 -0500
++++ sb-sha1-1.0/sb-sha1.asd 2003-09-28 17:40:58.254138000 -0500
+@@ -6,7 +6,6 @@
+ (in-package #:sb-sha1-system)
+
+ (defsystem sb-sha1
+- :depends-on (sb-rotate-byte)
+ :version "1.0"
+ :components ((:file "sha1")))
+
+@@ -18,11 +17,9 @@
+ (operate 'test-op 'sb-sha1-tests))
+
+ (defsystem sb-sha1-tests
+- :depends-on (sb-sha1 sb-rt)
+ :version "1.0"
+ :components ((:file "sha1-tests")))
+
+ (defmethod perform ((o test-op) (c (eql (find-system :sb-sha1-tests))))
+ (or (funcall (intern "DO-TESTS" (find-package "SB-RT")))
+ (error "test-op failed")))
+-
+\ No newline at end of file
+Only in sb-sha1-1.0/: sb-sha1.asd~
+diff -ur sb-sha1/sha1.lisp sb-sha1-1.0/sha1.lisp
+--- sb-sha1/sha1.lisp 2003-09-11 02:40:20.000000000 -0500
++++ sb-sha1-1.0/sha1.lisp 2003-09-28 18:05:03.615409688 -0500
+@@ -125,9 +125,6 @@
+ (kernel:32bit-logical-or #+little-endian (kernel:shift-towards-end a s)
+ #+big-endian (kernel:shift-towards-start a s)
+ (ash a (- s 32)))
+- #+sbcl
+- (sb-rotate-byte:rotate-byte s (byte 32 0) a)
+- #-(or sbcl cmu)
+ (logior (ldb (byte 32 0) (ash a s)) (ash a (- s 32))))
+
+ ;;; helper macro for rounds, with variable capture
+Only in sb-sha1-1.0/: sha1.lisp~
diff --git a/dev-lisp/cl-sha1/files/digest-cl-sha1-1.0 b/dev-lisp/cl-sha1/files/digest-cl-sha1-1.0
new file mode 100644
index 000000000000..c3832497f541
--- /dev/null
+++ b/dev-lisp/cl-sha1/files/digest-cl-sha1-1.0
@@ -0,0 +1 @@
+MD5 8091dbee1611da0d794b4f779c07bc91 sb-sha1-1.0.tar.gz 8757