summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-05-19 14:57:35 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-05-19 14:57:35 +0000
commit0c4222e70dbc1891609c261051705b923e80d367 (patch)
tree8821d4872112d696de81c47b26fc7d79014bbebf /dev-lisp
parentMarked stable on hppa. (diff)
downloadhistorical-0c4222e70dbc1891609c261051705b923e80d367.tar.gz
historical-0c4222e70dbc1891609c261051705b923e80d367.tar.bz2
historical-0c4222e70dbc1891609c261051705b923e80d367.zip
new port
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-lisp2wish/ChangeLog10
-rw-r--r--dev-lisp/cl-lisp2wish/Manifest4
-rw-r--r--dev-lisp/cl-lisp2wish/cl-lisp2wish-20040131.ebuild28
-rw-r--r--dev-lisp/cl-lisp2wish/files/digest-cl-lisp2wish-200401311
-rw-r--r--dev-lisp/cl-lisp2wish/metadata.xml11
5 files changed, 54 insertions, 0 deletions
diff --git a/dev-lisp/cl-lisp2wish/ChangeLog b/dev-lisp/cl-lisp2wish/ChangeLog
new file mode 100644
index 000000000000..043332f57a0b
--- /dev/null
+++ b/dev-lisp/cl-lisp2wish/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/cl-lisp2wish
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lisp2wish/ChangeLog,v 1.1 2004/05/19 14:57:35 mkennedy Exp $
+
+*cl-lisp2wish-20040131 (19 May 2004)
+
+ 19 May 2004; <mkennedy@gentoo.org> +metadata.xml,
+ +cl-lisp2wish-20040131.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/cl-lisp2wish/Manifest b/dev-lisp/cl-lisp2wish/Manifest
new file mode 100644
index 000000000000..a0e09145cbeb
--- /dev/null
+++ b/dev-lisp/cl-lisp2wish/Manifest
@@ -0,0 +1,4 @@
+MD5 da0d6d19d88ba87dc419129c8af0f13d cl-lisp2wish-20040131.ebuild 757
+MD5 32d414e5342287fcf202b3ef9328aa22 ChangeLog 427
+MD5 adbb077106b6066cfbeae73a672bafc7 metadata.xml 428
+MD5 4acfe1debf50e27cfd7911043ee3444f files/digest-cl-lisp2wish-20040131 67
diff --git a/dev-lisp/cl-lisp2wish/cl-lisp2wish-20040131.ebuild b/dev-lisp/cl-lisp2wish/cl-lisp2wish-20040131.ebuild
new file mode 100644
index 000000000000..0fea4af7c23d
--- /dev/null
+++ b/dev-lisp/cl-lisp2wish/cl-lisp2wish-20040131.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-lisp2wish/cl-lisp2wish-20040131.ebuild,v 1.1 2004/05/19 14:57:35 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PV=${PV:0:4}-${PV:4:2}-${PV:6:2}
+
+DESCRIPTION="lisp2wish is a simple interface to the Tk Graphics Toolkit."
+HOMEPAGE="http://www.cliki.net/lisp2wish"
+SRC_URI="http://www.riise-data.net/lisp2wish-${MY_PV}.tgz"
+LICENSE="lisp2wish"
+SLOT="0"
+KEYWORDS="~x86"
+DEPEND="virtual/commonlisp
+ dev-lisp/common-lisp-controller"
+RDEPEND="${DEPEND}
+ dev-lang/tk"
+
+CLPACKAGE=lisp2wish
+
+S=${WORKDIR}/lisp2wish
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc README*
+}
diff --git a/dev-lisp/cl-lisp2wish/files/digest-cl-lisp2wish-20040131 b/dev-lisp/cl-lisp2wish/files/digest-cl-lisp2wish-20040131
new file mode 100644
index 000000000000..df7cdb1f6359
--- /dev/null
+++ b/dev-lisp/cl-lisp2wish/files/digest-cl-lisp2wish-20040131
@@ -0,0 +1 @@
+MD5 8c3b9d8f0e739a13acb793e9d2819d96 lisp2wish-2004-01-31.tgz 5824
diff --git a/dev-lisp/cl-lisp2wish/metadata.xml b/dev-lisp/cl-lisp2wish/metadata.xml
new file mode 100644
index 000000000000..af726cf33685
--- /dev/null
+++ b/dev-lisp/cl-lisp2wish/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+lisp2wish is a simple interface to the Tk Graphics Toolkit. The
+interface starts the Tcl/Tk interpreter wish from Lisp as a
+subprocess, with which it communicates asynchronously by sending Tcl
+commands and receiving responses.
+</longdescription>
+</pkgmetadata>