summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2010-01-04 13:31:29 +0000
committerChristian Faulhammer <fauli@gentoo.org>2010-01-04 13:31:29 +0000
commit9fe2b88e9d19ced485ce43f535cfd7c4509a46dc (patch)
treebcf0624116116c5734d23528be2024e24e6860ce /dev-libs/qof/qof-0.8.1.ebuild
parentstable x86, bug 299480 (diff)
downloadhistorical-9fe2b88e9d19ced485ce43f535cfd7c4509a46dc.tar.gz
historical-9fe2b88e9d19ced485ce43f535cfd7c4509a46dc.tar.bz2
historical-9fe2b88e9d19ced485ce43f535cfd7c4509a46dc.zip
version bump
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'dev-libs/qof/qof-0.8.1.ebuild')
-rw-r--r--dev-libs/qof/qof-0.8.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/qof/qof-0.8.1.ebuild b/dev-libs/qof/qof-0.8.1.ebuild
new file mode 100644
index 000000000000..1dd53154fa5c
--- /dev/null
+++ b/dev-libs/qof/qof-0.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/qof/qof-0.8.1.ebuild,v 1.1 2010/01/04 13:31:29 fauli Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="A Query Object Framework"
+HOMEPAGE="http://qof.alioth.debian.org/"
+SRC_URI="https://alioth.debian.org/frs/download.php/3059/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc nls"
+
+RDEPEND="gnome-extra/libgda:3
+ dev-libs/libxml2
+ >=dev-db/sqlite-2.8.0:0"
+DEPEND="${DEPEND}
+ dev-util/pkgconfig
+ !dev-libs/qof:0
+ doc? ( app-doc/doxygen
+ dev-texlive/texlive-latex )"
+
+src_prepare() {
+ # Upstream not willing to remove those stupid flags...
+ epatch "${FILESDIR}/${PN}-0.8.0-remove_spurious_CFLAGS.patch"
+}
+
+src_configure() {
+ econf $(use_enable doc html-docs) --disable-error-on-warning \
+ $(use_enable nls) --enable-sqlite $(use_enable doc doxygen) \
+ $(use_enable doc latex-docs) --enable-gdabackend --enable-gdasql \
+ --disable-deprecated-glib --disable-dot \
+ || die
+}
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+}