summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-07-30 01:48:32 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-07-30 01:48:32 +0000
commitd14cf01a40d8cfc07ac6b7b7ebbb61ed45b69bee (patch)
tree2b7b5702fc67ce68e782304e2d53d08d64aeb75e /dev-libs/memcached-api-php
parentInitial commit here from split apis (diff)
downloadhistorical-d14cf01a40d8cfc07ac6b7b7ebbb61ed45b69bee.tar.gz
historical-d14cf01a40d8cfc07ac6b7b7ebbb61ed45b69bee.tar.bz2
historical-d14cf01a40d8cfc07ac6b7b7ebbb61ed45b69bee.zip
Initial commit here from split apis
Diffstat (limited to 'dev-libs/memcached-api-php')
-rw-r--r--dev-libs/memcached-api-php/Manifest3
-rw-r--r--dev-libs/memcached-api-php/files/digest-memcached-api-php-1.0.61
-rw-r--r--dev-libs/memcached-api-php/memcached-api-php-1.0.6.ebuild37
3 files changed, 40 insertions, 1 deletions
diff --git a/dev-libs/memcached-api-php/Manifest b/dev-libs/memcached-api-php/Manifest
index 7a5aa706d374..81f883598813 100644
--- a/dev-libs/memcached-api-php/Manifest
+++ b/dev-libs/memcached-api-php/Manifest
@@ -1,2 +1,3 @@
-MD5 04862bc5f8a9e3d5825d0fd453f371f4 memcached-api-php-1.0.6.ebuild 917
+MD5 2f019d4d14aa0e7e3082f003cdc772f5 memcached-api-php-1.0.6.ebuild 1037
+MD5 ef16effd503d36e4383f01fec5b52866 ChangeLog 356
MD5 86ef06379987a2a46a33ae5718762644 files/digest-memcached-api-php-1.0.6 69
diff --git a/dev-libs/memcached-api-php/files/digest-memcached-api-php-1.0.6 b/dev-libs/memcached-api-php/files/digest-memcached-api-php-1.0.6
new file mode 100644
index 000000000000..69781e63198e
--- /dev/null
+++ b/dev-libs/memcached-api-php/files/digest-memcached-api-php-1.0.6
@@ -0,0 +1 @@
+MD5 f58be515ff014ca1b6778cfe821f77c4 php-memcached-1.0.6.tar.gz 5882
diff --git a/dev-libs/memcached-api-php/memcached-api-php-1.0.6.ebuild b/dev-libs/memcached-api-php/memcached-api-php-1.0.6.ebuild
new file mode 100644
index 000000000000..e065b78e9a6c
--- /dev/null
+++ b/dev-libs/memcached-api-php/memcached-api-php-1.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/memcached-api-php/memcached-api-php-1.0.6.ebuild,v 1.1 2003/07/30 01:46:51 lisa Exp $
+
+DESCRIPTION="PHP API for memcached"
+
+HOMEPAGE="http://www.danga.com/memcached/"
+SRC_URI="http://www.danga.com/memcached/dist/php-memcached-${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=">=net-www/memcached-1.1.7"
+
+#This RDEPEND is debatable. It might not even be necessary or wanted
+#But to *run* this you need a PHP interpretter. -lisa (29 jul 03)
+RDEPEND="virtual/php"
+
+S=${WORKDIR}/${P}
+
+
+#where we're sending the API
+APIDEST="/usr/lib/php/memcached"
+
+
+src_compile() {
+ #there's nothing to compile
+ return
+}
+
+src_install() {
+ #Just a file to mv. cool, huh?
+ insinto ${APIDEST}
+ doins ${S}/MemCachedClient.inc.php
+ einfo "The PHP API is installed to ${APIDEST}/MemCachedClient.inc.php"
+ einfo "You may want to edit your php.ini to include_path that directory"
+}