summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 11:24:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-02-01 11:24:29 +0000
commitd38277358f58e3314afe55be33a28682ef464c05 (patch)
tree1b8f0e0a4e823efa23e52bee55dff8dc672ccec4 /dev-libs/fcgi
parentVersion bump libnfc to 1.3.2. (diff)
downloadhistorical-d38277358f58e3314afe55be33a28682ef464c05.tar.gz
historical-d38277358f58e3314afe55be33a28682ef464c05.tar.bz2
historical-d38277358f58e3314afe55be33a28682ef464c05.zip
Properly link and install libfcgi++. Closes bug #157821 after over three years. Rejoice.
Package-Manager: portage-2.2_rc62/cvs/Linux x86_64
Diffstat (limited to 'dev-libs/fcgi')
-rw-r--r--dev-libs/fcgi/ChangeLog8
-rw-r--r--dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild3
-rw-r--r--dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-link.patch21
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-libs/fcgi/ChangeLog b/dev-libs/fcgi/ChangeLog
index 57d8097c0140..02030d3e44f1 100644
--- a/dev-libs/fcgi/ChangeLog
+++ b/dev-libs/fcgi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/fcgi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.40 2010/01/30 08:29:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.41 2010/02/01 11:24:28 flameeyes Exp $
+
+ 01 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ fcgi-2.4.1_pre0910052249.ebuild,
+ +files/fcgi-2.4.1_pre0910052249-link.patch:
+ Properly link and install libfcgi++. Closes bug #157821 after over three
+ years. Rejoice.
*fcgi-2.4.1_pre0910052249 (30 Jan 2010)
diff --git a/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild b/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild
index d56b649875c6..721f2ac5cf0b 100644
--- a/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild
+++ b/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild,v 1.1 2010/01/30 08:29:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/fcgi-2.4.1_pre0910052249.ebuild,v 1.2 2010/02/01 11:24:28 flameeyes Exp $
EAPI="2"
@@ -25,6 +25,7 @@ src_prepare() {
epatch "${FILESDIR}/fcgi-2.4.0-clientdata-pointer.patch"
epatch "${FILESDIR}/fcgi-2.4.0-html-updates.patch"
epatch "${FILESDIR}"/fcgi-2.4.1_pre0311112127-gcc44.patch
+ epatch "${FILESDIR}"/${P}-link.patch
eautoreconf
}
diff --git a/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-link.patch b/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-link.patch
new file mode 100644
index 000000000000..e53c7e9d550b
--- /dev/null
+++ b/dev-libs/fcgi/files/fcgi-2.4.1_pre0910052249-link.patch
@@ -0,0 +1,21 @@
+Index: fcgi-2.4.1-SNAP-0910052249/libfcgi/Makefile.am
+===================================================================
+--- fcgi-2.4.1-SNAP-0910052249.orig/libfcgi/Makefile.am
++++ fcgi-2.4.1-SNAP-0910052249/libfcgi/Makefile.am
+@@ -9,8 +9,7 @@ INCLUDE_FILES = $(INCLUDEDIR)/fastcgi.h
+ $(INCLUDEDIR)/fcgi_stdio.h \
+ $(INCLUDEDIR)/fcgios.h
+
+-lib_LTLIBRARIES = libfcgi.la @LIBFCGIXX@
+-EXTRA_LTLIBRARIES = libfcgi++.la
++lib_LTLIBRARIES = libfcgi.la libfcgi++.la
+
+ libfcgi_la_SOURCES = $(INCLUDE_FILES) \
+ fcgiapp.c \
+@@ -23,5 +22,5 @@ libfcgi___la_SOURCES = $(INCLUDE_FILES)
+ $(INCLUDEDIR)/fcgio.h \
+ fcgio.cpp
+ libfcgi___la_CFLAGS = @PTHREAD_CFLAGS@
+-libfcgi___la_LDFLAGS = -lfcgi -rpath @libdir@
++libfcgi___la_LIBADD = libfcgi.la
+