summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-16 14:56:57 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-16 14:56:57 +0000
commit5417c6909c8264e7972a9f02c27ff3eb03f159c2 (patch)
tree797f8328574dc47350660cf3369183d88094cfd2 /dev-libs/DirectFB
parentalpha/sparc/x86 stable wrt #231553 (diff)
downloadhistorical-5417c6909c8264e7972a9f02c27ff3eb03f159c2.tar.gz
historical-5417c6909c8264e7972a9f02c27ff3eb03f159c2.tar.bz2
historical-5417c6909c8264e7972a9f02c27ff3eb03f159c2.zip
old
Package-Manager: portage-2.2_rc6/cvs/Linux 2.6.26.1 x86_64
Diffstat (limited to 'dev-libs/DirectFB')
-rw-r--r--dev-libs/DirectFB/DirectFB-0.9.24.ebuild120
-rw-r--r--dev-libs/DirectFB/DirectFB-1.0.0.ebuild118
-rw-r--r--dev-libs/DirectFB/Manifest13
-rw-r--r--dev-libs/DirectFB/files/DirectFB-1.0.0-headers.patch30
4 files changed, 4 insertions, 277 deletions
diff --git a/dev-libs/DirectFB/DirectFB-0.9.24.ebuild b/dev-libs/DirectFB/DirectFB-0.9.24.ebuild
deleted file mode 100644
index 4514ec19bde7..000000000000
--- a/dev-libs/DirectFB/DirectFB-0.9.24.ebuild
+++ /dev/null
@@ -1,120 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-0.9.24.ebuild,v 1.11 2007/03/03 22:25:43 genone Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 i830 mach64 matrox neomagic nsc nvidia radeon r200 savage sis315 tdfx unichrome"
-IUSE_INPUT_DEVICES="dbox2remote elo-input h3600_ts joystick keyboard dreamboxremote linuxinput lirc mutouch ps2mouse serialmouse sonypijogdial wm97xx"
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha ~amd64 arm hppa ia64 -mips ppc sh -sparc x86"
-IUSE="debug fbcon fusion gif jpeg mmx mpeg png sdl sse static sysfs truetype zlib"
-
-DEPEND="sdl? ( media-libs/libsdl )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- mpeg? ( media-libs/libmpeg3 )
- sysfs? ( sys-fs/sysfsutils )
- zlib? ( sys-libs/zlib )
- truetype? ( >=media-libs/freetype-2.0.1 )"
-
-pkg_setup() {
- if [[ -z ${VIDEO_CARDS} ]] ; then
- ewarn "All video drivers will be built since you did not specify"
- ewarn "via the VIDEO_CARDS variable what video card you use."
- ewarn "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
- echo
- fi
- if [[ -z ${INPUT_DEVICES} ]] ; then
- ewarn "All input drivers will be built since you did not specify"
- ewarn "via the INPUT_DEVICES variable which input drivers to use."
- ewarn "DirectFB supports: ${IUSE_INPUT_DEVICES} all none"
- echo
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-CFLAGS.patch
-}
-
-src_compile() {
- # force disable wm97xx #36924
-# export ac_cv_header_linux_wm97xx_h=no
- # force disable of sis315 #77391
-# export ac_cv_header_linux_sisfb_h=no
-
- local vidcards card input inputdrivers
- for card in ${VIDEO_CARDS} ; do
- has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
- done
- [[ -z ${vidcards} ]] \
- && vidcards="all" \
- || vidcards=${vidcards:1}
- for input in ${INPUT_DEVICES} ; do
- has ${input} ${IUSE_INPUT_DEVICES} && inputdrivers="${inputdrivers},${input}"
- done
- [[ -z ${inputdrivers} ]] \
- && inputdrivers="all" \
- || inputdrivers=${inputdrivers:1}
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- use mpeg && export CPPFLAGS="${CPPFLAGS} -I/usr/include/libmpeg3"
- econf \
- $(use_enable fbcon fbdev) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable mpeg libmpeg3) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable gif) \
- $(use_enable truetype freetype) \
- $(use_enable fusion multi) \
- $(use_enable debug) \
- $(use_enable static) \
- $(use_enable sysfs) \
- $(use_enable zlib) \
- ${sdlconf} \
- --with-gfxdrivers="${vidcards}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc \
- || die
- emake || die
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
- dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update in the 0.9.xx series"
- ewarn "breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might"
- ewarn "get your mouse unexpectedly set in absolute"
- ewarn "mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from"
- ewarn "INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/DirectFB-1.0.0.ebuild b/dev-libs/DirectFB/DirectFB-1.0.0.ebuild
deleted file mode 100644
index 4732e1d74f73..000000000000
--- a/dev-libs/DirectFB/DirectFB-1.0.0.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DirectFB/DirectFB-1.0.0.ebuild,v 1.2 2007/04/19 06:27:10 corsair Exp $
-
-inherit eutils toolchain-funcs
-
-IUSE_VIDEO_CARDS="ati128 cle266 cyber5k i810 i830 mach64 matrox neomagic nsc nvidia radeon savage sis315 tdfx unichrome"
-IUSE_INPUT_DEVICES="dbox2remote elo-input gunze h3600_ts joystick keyboard dreamboxremote linuxinput lirc mutouch none permount ps2mouse serialmouse sonypijogdial wm97xx"
-
-DESCRIPTION="Thin library on top of the Linux framebuffer devices"
-HOMEPAGE="http://www.directfb.org/"
-SRC_URI="http://www.directfb.org/download/DirectFB/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 -mips ~ppc ~ppc64 ~sh -sparc ~x86"
-IUSE="debug fbcon fusion gif jpeg mmx png sdl sse sysfs truetype v4l v4l2 zlib"
-
-# fusion? ( dev-libs/linux-fusion )
-DEPEND="sdl? ( media-libs/libsdl )
- gif? ( media-libs/giflib )
- png? ( media-libs/libpng )
- jpeg? ( media-libs/jpeg )
- sysfs? ( sys-fs/sysfsutils )
- zlib? ( sys-libs/zlib )
- truetype? ( >=media-libs/freetype-2.0.1 )"
-
-pkg_setup() {
- if [[ -z ${VIDEO_CARDS} ]] ; then
- ewarn "All video drivers will be built since you did not specify"
- ewarn "via the VIDEO_CARDS variable what video card you use."
- ewarn "DirectFB supports: ${IUSE_VIDEO_CARDS} all none"
- echo
- fi
- if [[ -z ${INPUT_DEVICES} ]] ; then
- ewarn "All input drivers will be built since you did not specify"
- ewarn "via the INPUT_DEVICES variable which input drivers to use."
- ewarn "DirectFB supports: ${IUSE_INPUT_DEVICES} all none"
- echo
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-0.9.24-CFLAGS.patch
- epatch "${FILESDIR}"/${P}-headers.patch
-}
-
-src_compile() {
- local vidcards card input inputdrivers
- for card in ${VIDEO_CARDS} ; do
- has ${card} ${IUSE_VIDEO_CARDS} && vidcards="${vidcards},${card}"
- #use video_cards_${card} && vidcards="${vidcards},${card}"
- done
- [[ -z ${vidcards} ]] \
- && vidcards="all" \
- || vidcards=${vidcards:1}
- for input in ${INPUT_DEVICES} ; do
- has ${input} ${IUSE_INPUT_DEVICES} && inputdrivers="${inputdrivers},${input}"
- #use input_devics_${input} && inputdrivers="${inputdrivers},${input}"
- done
- [[ -z ${inputdrivers} ]] \
- && inputdrivers="all" \
- || inputdrivers=${inputdrivers:1}
-
- local sdlconf="--disable-sdl"
- if use sdl ; then
- # since SDL can link against DirectFB and trigger a
- # dependency loop, only link against SDL if it isn't
- # broken #61592
- echo 'int main(){}' > sdl-test.c
- $(tc-getCC) sdl-test.c -lSDL 2>/dev/null \
- && sdlconf="--enable-sdl" \
- || ewarn "Disabling SDL since libSDL.so is broken"
- fi
-
- econf \
- --enable-static \
- $(use_enable fbcon fbdev) \
- $(use_enable mmx) \
- $(use_enable sse) \
- $(use_enable jpeg) \
- $(use_enable png) \
- $(use_enable gif) \
- $(use_enable truetype freetype) \
- $(use_enable fusion multi) \
- $(use_enable debug) \
- $(use_enable sysfs) \
- $(use_enable zlib) \
- $(use_enable v4l video4linux) \
- $(use_enable v4l2 video4linux2) \
- ${sdlconf} \
- --with-gfxdrivers="${vidcards}" \
- --with-inputdrivers="${inputdrivers}" \
- --disable-vnc \
- || die
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc fb.modes AUTHORS ChangeLog NEWS README* TODO
- dohtml -r docs/html/*
-}
-
-pkg_postinst() {
- ewarn "Each DirectFB update in the 0.9.xx series"
- ewarn "breaks DirectFB related applications."
- ewarn "Please run \"revdep-rebuild\" which can be"
- ewarn "found by emerging the package 'gentoolkit'."
- ewarn
- ewarn "If you have an ALPS touchpad, then you might"
- ewarn "get your mouse unexpectedly set in absolute"
- ewarn "mode in all DirectFB applications."
- ewarn "This can be fixed by removing linuxinput from"
- ewarn "INPUT_DEVICES."
-}
diff --git a/dev-libs/DirectFB/Manifest b/dev-libs/DirectFB/Manifest
index 232f8f95c6fc..c7be31d460b3 100644
--- a/dev-libs/DirectFB/Manifest
+++ b/dev-libs/DirectFB/Manifest
@@ -3,23 +3,18 @@ Hash: SHA1
AUX DirectFB-0.9.24-CFLAGS.patch 570 RMD160 e65704cfdedd20ba96544357ab89aeb26927e2af SHA1 bb6c670639fb2292e9ab65abbac5d1e0012847cf SHA256 24fc37fa6390340f08f4cf352a6fec34acf9d2bf0fc0f572a714466cc8ab4b68
AUX DirectFB-0.9.25.1-headers.patch 1739 RMD160 f2e710b7e55e21dbae1267a526d945978afab501 SHA1 3124c358490ea0ef1e227bc172c54df459498ed8 SHA256 83b1eeab6641a51ba49e9c120e5c9c157195f29305f302a8fd9cded9fa350b20
-AUX DirectFB-1.0.0-headers.patch 698 RMD160 abda64eded24e06125d53b07ee6b0ab39583139f SHA1 e5c4c5396e4a1dd97744cf31df3e1ea46633e8ba SHA256 40bcf37f11e79b23325fcea626246cb1d4b86ce31dde439cab322d69b9538fc8
AUX DirectFB-1.1.1-headers.patch 698 RMD160 abda64eded24e06125d53b07ee6b0ab39583139f SHA1 e5c4c5396e4a1dd97744cf31df3e1ea46633e8ba SHA256 40bcf37f11e79b23325fcea626246cb1d4b86ce31dde439cab322d69b9538fc8
AUX DirectFB-1.1.1-pkgconfig.patch 637 RMD160 b560f0cb45ab3e8938bce474f1331562ba3a96a1 SHA1 aa202a8452f48f1a8ce087201bcc26ef17c97faa SHA256 f824293e1ae8ed2e632ba0196cf760459006a1e110abac348476b3982a0db036
-DIST DirectFB-0.9.24.tar.gz 1938861 RMD160 262b300cc00b3385f15532004aa332253d525522 SHA1 95fbde03792d21c2ac4247108b09a861ce6532dc SHA256 d2717cbd1a85a48eba9522491bbe2c74579a91af2a938dea601ef2a8c28b7f9f
DIST DirectFB-0.9.25.1.tar.gz 2064010 RMD160 558e3eabc41635c054314d8a4c8365d648ec588d SHA1 40654da2fde2fd5539f5a0c5cdac50e1a8a52bb4 SHA256 aa1e9710ca18633ffcb74a0383fdfa39aba63e873ec9fa2ba4b7589ed2e5c56b
-DIST DirectFB-1.0.0.tar.gz 2432000 RMD160 43e8b73f2a751e8dcb240e6b6c4c34055c5337c0 SHA1 8ac354cabd9c279e8bd3cf352daddf1b19f2007f SHA256 125941749103c08a5263f2ace01aac1533420d2ff6741d2bdde79689e5d02a05
DIST DirectFB-1.1.1.tar.gz 2614203 RMD160 08553be77c24f3f9accbe8d2304530b42bbc2e58 SHA1 93d0ea5ca4b10291ca55d1eb6fecc544966eadad SHA256 f12ec5f0864d85268a8d67e4919cb7f3d7f0e06ed6cc278c952f6c342673d931
-EBUILD DirectFB-0.9.24.ebuild 3820 RMD160 5487a7f235ea1e6fad0b0b4247fbda96a9c0ef32 SHA1 3bebdb41fa316ef9b552dd4d22a201412c293144 SHA256 2284d2013feac6b06a37e41f1ac4a35a53c0f98795c3b1b9240b8dffe9d4c0d9
EBUILD DirectFB-0.9.25.1.ebuild 4121 RMD160 b81bea1c36281ec56279db08fe57c9d93de137fd SHA1 dbb0e079f23e693d94e081ad7b21beaaaf4d19eb SHA256 fc42241cdd512c47f496cef63df70c78e40dc09e2562c388eb5afdd7caf83d74
-EBUILD DirectFB-1.0.0.ebuild 3841 RMD160 a9d8a856027efb2fdd13bd6d34d5b7ca1186d3ff SHA1 d2fa759dd1817474e88a3618f6e207c537bdd220 SHA256 30c51a8afd8b9b29273f94aa1688beafe47aeaad11e3a643f06361d938f32379
EBUILD DirectFB-1.1.1.ebuild 4735 RMD160 5a4dcaf3569c038edb9c792be1d5162318801b3b SHA1 d6d9de2f480ede684a796266e9d104eca530f10b SHA256 41ede7d7671c745c22239c8de5c7ec9cca05a25875a1cf4ae326e754aa825d05
MISC ChangeLog 10661 RMD160 2c18c470cdfa574a52df84e6ed0490ea5350d789 SHA1 53e92db754b107ad57df063990f23ddc4ae0e491 SHA256 9e8fd8d6f4fce2270e94f3f11c8118c6eeb4d977c58910d6c53c1f2bed2eaf76
MISC metadata.xml 946 RMD160 777ebf08757a4edd565f7bd223842eea95bfb8ed SHA1 bce4580dc619e70662cf503cf71d91ad26b9ae64 SHA256 4851e050a8193f7bf60c757d1b7307709ef0ad6b40a5feae964cca0caf445232
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.9 (GNU/Linux)
+Version: GnuPG v2.0.9 (GNU/Linux)
-iEYEARECAAYFAkiZTIoACgkQOeoy/oIi7uxe+ACgglAAIuzpSoVZBP7nsyIGMW/M
-grAAoNV30ZyywyLU/pMfIw5p0VKzHQbH
-=0tzK
+iEYEARECAAYFAkim6r8ACgkQ67wieSYcaxcMJQCg4hIw32wd1BZPex+BlBmG88Lo
+ORIAoOKvMSq4dF7Ivee7DUBv90RoKwQx
+=tUQy
-----END PGP SIGNATURE-----
diff --git a/dev-libs/DirectFB/files/DirectFB-1.0.0-headers.patch b/dev-libs/DirectFB/files/DirectFB-1.0.0-headers.patch
deleted file mode 100644
index df9ef99353d3..000000000000
--- a/dev-libs/DirectFB/files/DirectFB-1.0.0-headers.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Don't rely on the kernel to tell us what the cpu target is ... we'll just
-use the default values all the time instead.
-
-http://bugs.gentoo.org/152614
-
---- lib/direct/ppcasm_memcpy_cachable.S
-+++ lib/direct/ppcasm_memcpy_cachable.S
-@@ -34,8 +34,6 @@
-
- #define __ASSEMBLY__
-
--#include <linux/config.h>
--
- #if defined(CONFIG_8xx) || defined(CONFIG_403GCX)
- #define L1_CACHE_LINE_SIZE 16
- #define LG_L1_CACHE_LINE_SIZE 4
-
-Don't pollute the namespace with define hacks, just use the real deal.
-
---- include/dfb_types.h
-+++ include/dfb_types.h
-@@ -60,6 +60,8 @@
-
- #endif
-
-+#include <asm/types.h>
-+#define DIRECTFB_NO_CRUFT
- #ifndef DIRECTFB_NO_CRUFT
- #define __u8 u8
- #define __u16 u16