summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-28 23:48:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-28 23:48:30 +0000
commit6c5e5adf6b0abda6be6ad09ce8eed721a011af1e (patch)
tree6494cc4f29644168c3177b42e18d377f3a08a19b /dev-lang/tk
parentcan't support for gcc3 (diff)
downloadhistorical-6c5e5adf6b0abda6be6ad09ce8eed721a011af1e.tar.gz
historical-6c5e5adf6b0abda6be6ad09ce8eed721a011af1e.tar.bz2
historical-6c5e5adf6b0abda6be6ad09ce8eed721a011af1e.zip
fix0rs to sed expression
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog8
-rw-r--r--dev-lang/tk/files/digest-tk-8.3.4-r13
-rw-r--r--dev-lang/tk/tk-8.3.4-r1.ebuild70
3 files changed, 80 insertions, 1 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index 3087266152ff..dc96b0aa1c88 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tk
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.12 2003/03/20 21:08:05 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.13 2003/03/28 23:48:30 seemant Exp $
+
+*tk-8.3.4-r1 (28 Mar 2003)
+
+ 28 Mar 2003; Seemant Kulleen <seemant@gentoo.org> tk-8.3.4-r1.ebuild:
+ fixed sed expression, hopefully closes bug #18300 by Marc 'huz' REYNES
+ <marc.reynes@tuxfamily.org>
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-lang/tk/files/digest-tk-8.3.4-r1 b/dev-lang/tk/files/digest-tk-8.3.4-r1
new file mode 100644
index 000000000000..6167cc36f783
--- /dev/null
+++ b/dev-lang/tk/files/digest-tk-8.3.4-r1
@@ -0,0 +1,3 @@
+MD5 3e8db8239fe4e68f5107a7a1d4f2f85b /files/remove-control-v.diff 400
+MD5 59cc221c18b9a3de55f8aaa53a5f405b /tk-8.3.4-r1.ebuild 1986
+MD5 02311d8f90734c4f5eaa62e9b36fe535 tk8.3.4.tar.gz 2589635
diff --git a/dev-lang/tk/tk-8.3.4-r1.ebuild b/dev-lang/tk/tk-8.3.4-r1.ebuild
new file mode 100644
index 000000000000..3790e0854bb2
--- /dev/null
+++ b/dev-lang/tk/tk-8.3.4-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.4-r1.ebuild,v 1.1 2003/03/28 23:48:30 seemant Exp $
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_3/${PN}${PV}.tar.gz"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+DESCRIPTION="Tk Widget Set"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ppc sparc alpha hppa"
+
+DEPEND=">=sys-apps/sed-4.0.5
+ >=sys-apps/portage-2.0.47-r10
+ virtual/x11
+ =dev-lang/tcl-${PV}*"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/library
+ epatch ${FILESDIR}/remove-control-v.diff
+}
+
+# hyper-optimizations untested...
+#
+src_compile() {
+ cd ${S}/unix
+ econf \
+ --with-tcl=/usr/lib \
+ --enable-threads || die
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ sed -i \
+ -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${S}/unix,\1/usr/lib," \
+ -e "s,^\(TK_SRC_DIR='\)${S}',\1/usr/lib/tk${v1}/include'," \
+ -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${S}/unix,\1/usr/lib," \
+ -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${S}/unix,\1/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tk${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tk${v1}/include/unix
+ dodir /usr/lib/tk${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tk${v1}/include/generic
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tk.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkDecls.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym /usr/lib/libtk${v1}.a /usr/lib/libtk.a
+ dosym /usr/lib/libtk${v1}.so /usr/lib/libtk.so
+ dosym /usr/lib/libtkstub${v1}.a /usr/lib/libtkstub.a
+
+ ln -sf wish${v1} ${D}/usr/bin/wish
+
+ cd ${S}
+ dodoc README changes license.terms
+}