summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-04-21 22:24:47 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-04-21 22:24:47 +0000
commit5f77a735cec6a3daeaf5fd4b87bda3127267f122 (patch)
tree386f97647c2880ae7160f7b0ca95477ee873fec3 /dev-lang/parrot
parentVersion bump. (diff)
downloadhistorical-5f77a735cec6a3daeaf5fd4b87bda3127267f122.tar.gz
historical-5f77a735cec6a3daeaf5fd4b87bda3127267f122.tar.bz2
historical-5f77a735cec6a3daeaf5fd4b87bda3127267f122.zip
bug 82444
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog9
-rw-r--r--dev-lang/parrot/Manifest16
-rw-r--r--dev-lang/parrot/files/digest-parrot-0.1.21
-rw-r--r--dev-lang/parrot/parrot-0.1.2.ebuild54
4 files changed, 76 insertions, 4 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index 3c79f6ae26be..efa2f710c381 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/parrot
-# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.3 2004/12/27 13:10:55 mcummings Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.4 2005/04/21 22:24:47 mcummings Exp $
+
+*parrot-0.1.2 (21 Apr 2005)
+
+ 21 Apr 2005; Michael Cummings <mcummings@gentoo.org> +parrot-0.1.2.ebuild:
+ Bug 82444, ebuild courtesy Adrian Lambeck <adrian@basicsedv.de>
27 Dec 2004; Michael Cummings <mcummings@gentoo.org> parrot-0.1.1.ebuild:
An "I'm amazed it even worked" typo in the SRC_URI - S instead of P
diff --git a/dev-lang/parrot/Manifest b/dev-lang/parrot/Manifest
index 2ca2b64eeae0..df884457db6f 100644
--- a/dev-lang/parrot/Manifest
+++ b/dev-lang/parrot/Manifest
@@ -1,4 +1,16 @@
-MD5 9099d6820fee37d5d83b23555ec0be98 ChangeLog 736
-MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 c945d06f74e84a7106d0ccf283b5d7db parrot-0.1.1.ebuild 1147
+MD5 99f9e39d8d5567d65528366add2dcf91 ChangeLog 909
+MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+MD5 57f33d542e753d7679e9b883ce818a20 parrot-0.1.2.ebuild 1540
+MD5 33b986910cc59316976efc38da8ab47c files/digest-parrot-0.1.2 65
MD5 75fbd20b4daec7e1b315a172ad60c64f files/digest-parrot-0.1.1 65
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCaCgJtG5z4I8BtQoRAkzwAJ97JhX4thdCNe6wWx9XI0Eg3itz2gCePAuP
+DzwHiiNRj/+JA5DrxbEf1Es=
+=BMzZ
+-----END PGP SIGNATURE-----
diff --git a/dev-lang/parrot/files/digest-parrot-0.1.2 b/dev-lang/parrot/files/digest-parrot-0.1.2
new file mode 100644
index 000000000000..c91533e3fc1c
--- /dev/null
+++ b/dev-lang/parrot/files/digest-parrot-0.1.2
@@ -0,0 +1 @@
+MD5 e1fb2322b661832caa08a08918c4bb9b parrot-0.1.2.tar.gz 9036672
diff --git a/dev-lang/parrot/parrot-0.1.2.ebuild b/dev-lang/parrot/parrot-0.1.2.ebuild
new file mode 100644
index 000000000000..2294b696755b
--- /dev/null
+++ b/dev-lang/parrot/parrot-0.1.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-0.1.2.ebuild,v 1.1 2005/04/21 22:24:47 mcummings Exp $
+
+inherit base eutils
+
+DESCRIPTION="The virtual machine that perl6 relies on."
+HOMEPAGE="http://www.parrotcode.org/"
+SRC_URI="mirror://cpan/authors/id/L/LT/LTOETSCH/${S}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64"
+IUSE="test"
+
+#this ebuild has been tested with the given perl
+#if we trust the README then 5.6 should also be ok.
+DEPEND=">=dev-lang/perl-5.8.5-r2
+ >=dev-libs/icu-2.6"
+
+src_compile() {
+ #This configure defines the DESTDIR for make.
+ perl Configure.pl --prefix=${D}|| die "Perl ./Configure.pl failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ #The prefix was set by Configure.pl - see src_compile().
+ make install BUILDPREFIX=${D} PREFIX=/usr/lib/${P} || die
+ dodir /usr/bin
+ dosym /usr/lib/${P}/bin/parrot /usr/bin
+
+ #copy some special files escpecially mod_parrot-0.1
+ #maybe this should depend on a USE-Flag i.e. apache
+
+ #install libparrot.a into /usr/lib/
+ dolib.a blib/lib/*.a
+ dosym /usr/lib/${P}/bin/parrot /usr/lib/${P}/parrot
+
+ insinto /usr/lib/${P}
+ doins config_lib.pasm
+ dodir /usr/lib/${P}/include
+ dodir /usr/lib/${P}/include/parrot
+ insinto /usr/lib/${P}/include/parrot/
+ doins ${S}/include/parrot/*.h
+
+ dodir /usr/share/doc/${P}
+ dodoc README RESPONSIBLE_PARTIES ABI_CHANGES ChangeLog CREDITS DEVELOPING
+}
+
+src_test() {
+ emake test || die "test failed"
+}
+