summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-04-25 01:57:00 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-04-25 01:57:00 +0000
commit61c8710eede28b34b511055d40879149af4e9d7e (patch)
tree2d3a6db24fe4781b7286d59f9f488f0503888ed7 /dev-lang/lua
parentPatched Ebuild (diff)
downloadhistorical-61c8710eede28b34b511055d40879149af4e9d7e.tar.gz
historical-61c8710eede28b34b511055d40879149af4e9d7e.tar.bz2
historical-61c8710eede28b34b511055d40879149af4e9d7e.zip
New package
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/ChangeLog13
-rw-r--r--dev-lang/lua/files/digest-lua-4.01
-rw-r--r--dev-lang/lua/files/lua-4.0-config.patch26
-rw-r--r--dev-lang/lua/lua-4.0.ebuild29
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
new file mode 100644
index 000000000000..ef284ae99cf0
--- /dev/null
+++ b/dev-lang/lua/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-lang/lua
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.1 2002/04/25 01:57:00 rphillips Exp $
+
+*lua-4.0 (23 Apr 2002)
+
+ 23 Apr 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/dev-lang/lua/files/digest-lua-4.0 b/dev-lang/lua/files/digest-lua-4.0
new file mode 100644
index 000000000000..2e97aeda7653
--- /dev/null
+++ b/dev-lang/lua/files/digest-lua-4.0
@@ -0,0 +1 @@
+MD5 be11522d46d33a931868c03694aaeeef lua.tar.gz 157102
diff --git a/dev-lang/lua/files/lua-4.0-config.patch b/dev-lang/lua/files/lua-4.0-config.patch
new file mode 100644
index 000000000000..5eae5e20ea78
--- /dev/null
+++ b/dev-lang/lua/files/lua-4.0-config.patch
@@ -0,0 +1,26 @@
+--- config.orig 2002-04-24 18:51:28.000000000 -0700
++++ config 2002-04-24 18:51:48.000000000 -0700
+@@ -72,17 +72,17 @@
+ # ------------------------------------------------------------------ install
+
+ # Locations for "make install". You may need to be root do "make install".
+-INSTALL_ROOT= /usr/local
++INSTALL_ROOT= /usr
+ INSTALL_BIN= $(INSTALL_ROOT)/bin
+ INSTALL_INC= $(INSTALL_ROOT)/include
+ INSTALL_LIB= $(INSTALL_ROOT)/lib
+-INSTALL_MAN= $(INSTALL_ROOT)/man/man1
++INSTALL_MAN= /usr/share/man/man1
+
+ # You might prefer to use "install" if you have it.
+-INSTALL_EXEC= cp
+-INSTALL_DATA= cp
+-#INSTALL_EXEC= install -m 0755
+-#INSTALL_DATA= install -m 0644
++#INSTALL_EXEC= cp
++#INSTALL_DATA= cp
++INSTALL_EXEC= install -m 0755
++INSTALL_DATA= install -m 0644
+
+ # == END OF USER SETTINGS. DO NOT CHANGE ANYTHING BELOW THIS LINE =============
+
diff --git a/dev-lang/lua/lua-4.0.ebuild b/dev-lang/lua/lua-4.0.ebuild
new file mode 100644
index 000000000000..4a330465761e
--- /dev/null
+++ b/dev-lang/lua/lua-4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Larry Cow <larrycow@free.fr>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-4.0.ebuild,v 1.1 2002/04/25 01:57:00 rphillips Exp $
+
+P="lua"
+S=${WORKDIR}/${P}
+DESCRIPTION="A powerful light-weight programming language designed for extending applications."
+SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
+HOMEPAGE="http://www.lua.org/"
+
+DEPEND="virtual/glibc"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ patch < ${FILESDIR}/lua-4.0-config.patch
+
+ emake || die
+ make so || die
+}
+
+src_install () {
+ make \
+ INSTALL_BIN=${D}/usr/bin \
+ INSTALL_MAN=${D}/usr/share/man/man1 \
+ INSTALL_INC=${D}/usr/include \
+ INSTALL_LIB=${D}/usr/lib \
+ install || die
+}