summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlistair Bush <ali_bush@gentoo.org>2010-12-21 07:40:35 +0000
committerAlistair Bush <ali_bush@gentoo.org>2010-12-21 07:40:35 +0000
commitd6e2895230e40c5b348ca7f1eebd0a72bb7c9a73 (patch)
treebd04d65ba213597e3938777de45a83155f8b3089 /dev-java
parentVersion Bump (diff)
downloadhistorical-d6e2895230e40c5b348ca7f1eebd0a72bb7c9a73.tar.gz
historical-d6e2895230e40c5b348ca7f1eebd0a72bb7c9a73.tar.bz2
historical-d6e2895230e40c5b348ca7f1eebd0a72bb7c9a73.zip
Version Bump.
Package-Manager: portage-2.1.9.25/cvs/Linux x86_64
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/ant-eclipse-ecj/ChangeLog8
-rw-r--r--dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild49
-rw-r--r--dev-java/ant-eclipse-ecj/files/ecj-3.67
-rw-r--r--dev-java/eclipse-ecj/ChangeLog7
-rw-r--r--dev-java/eclipse-ecj/eclipse-ecj-3.6.ebuild103
5 files changed, 172 insertions, 2 deletions
diff --git a/dev-java/ant-eclipse-ecj/ChangeLog b/dev-java/ant-eclipse-ecj/ChangeLog
index 7ffaea7cfab7..5093ab1a1237 100644
--- a/dev-java/ant-eclipse-ecj/ChangeLog
+++ b/dev-java/ant-eclipse-ecj/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/ant-eclipse-ecj
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.22 2010/11/05 19:50:45 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ChangeLog,v 1.23 2010/12/21 07:39:29 ali_bush Exp $
+
+*ant-eclipse-ecj-3.6 (21 Dec 2010)
+
+ 21 Dec 2010; Alistair Bush <ali_bush@gentoo.org> +files/ecj-3.6,
+ +ant-eclipse-ecj-3.6.ebuild:
+ Version Bump.
05 Nov 2010; Mark Loeser <halcy0n@gentoo.org>
ant-eclipse-ecj-3.5.2.ebuild:
diff --git a/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild
new file mode 100644
index 000000000000..34197c13ceca
--- /dev/null
+++ b/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-eclipse-ecj/ant-eclipse-ecj-3.6.ebuild,v 1.1 2010/12/21 07:39:29 ali_bush Exp $
+
+inherit java-pkg-2
+
+DMF="R-${PV}-201006080911"
+S="${WORKDIR}"
+
+DESCRIPTION="Ant Compiler Adapter for Eclipse Java Compiler"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/${DMF/.0}/ecjsrc-${PV}.zip"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+SLOT="3.6"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4
+ ~dev-java/eclipse-ecj-${PV}
+ >=dev-java/ant-core-1.7"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.4"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p src/org/eclipse/jdt/{core,internal}
+ cp org/eclipse/jdt/core/JDTCompilerAdapter.java \
+ src/org/eclipse/jdt/core || die
+ cp -r org/eclipse/jdt/internal/antadapter \
+ src/org/eclipse/jdt/internal || die
+ rm -fr about* org
+}
+
+src_compile() {
+ cd src
+ java-pkg_filter-compiler jikes
+ ejavac -classpath "$(java-pkg_getjars ant-core,eclipse-ecj-${SLOT})" \
+ $(find org/ -name '*.java') || die "ejavac failed!"
+ find org/ -name '*.class' -o -name '*.properties' | \
+ xargs jar cf "${S}/${PN}.jar" || die "jar failed!"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ insinto /usr/share/java-config-2/compiler
+ newins "${FILESDIR}/compiler-settings-${SLOT}" ecj-${SLOT}
+}
diff --git a/dev-java/ant-eclipse-ecj/files/ecj-3.6 b/dev-java/ant-eclipse-ecj/files/ecj-3.6
new file mode 100644
index 000000000000..a15e7705d7a5
--- /dev/null
+++ b/dev-java/ant-eclipse-ecj/files/ecj-3.6
@@ -0,0 +1,7 @@
+JAVAC="/usr/bin/ecj-3.5"
+PACKAGE="=dev-java/ant-eclipse-ecj-3.5*"
+SUPPORTED_TARGET="1.1 1.2 1.3 1.4 1.5 1.6 1.7"
+SUPPORTED_SOURCE="1.3 1.4 1.5 1.6 1.7"
+ANT_BUILD_COMPILER="org.eclipse.jdt.core.JDTCompilerAdapter"
+ANT_BUILD_COMPILER_DEPS="eclipse-ecj-3.5,ant-eclipse-ecj-3.5"
+GENERATION="2"
diff --git a/dev-java/eclipse-ecj/ChangeLog b/dev-java/eclipse-ecj/ChangeLog
index 9806bd214a0b..b058893c6df8 100644
--- a/dev-java/eclipse-ecj/ChangeLog
+++ b/dev-java/eclipse-ecj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/eclipse-ecj
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/ChangeLog,v 1.70 2010/11/05 19:50:18 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/ChangeLog,v 1.71 2010/12/21 07:40:35 ali_bush Exp $
+
+*eclipse-ecj-3.6 (21 Dec 2010)
+
+ 21 Dec 2010; Alistair Bush <ali_bush@gentoo.org> +eclipse-ecj-3.6.ebuild:
+ Version Bump.
05 Nov 2010; Mark Loeser <halcy0n@gentoo.org> eclipse-ecj-3.5.2.ebuild:
Stable for ppc64; bug #316293
diff --git a/dev-java/eclipse-ecj/eclipse-ecj-3.6.ebuild b/dev-java/eclipse-ecj/eclipse-ecj-3.6.ebuild
new file mode 100644
index 000000000000..51a5ece58bfc
--- /dev/null
+++ b/dev-java/eclipse-ecj/eclipse-ecj-3.6.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/eclipse-ecj/eclipse-ecj-3.6.ebuild,v 1.1 2010/12/21 07:40:35 ali_bush Exp $
+
+EAPI=2
+
+inherit java-pkg-2
+
+MY_PN="ecj"
+DMF="R-${PV}-201006080911"
+S="${WORKDIR}"
+
+DESCRIPTION="Eclipse Compiler for Java"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/${DMF}/${MY_PN}src-${PV}.zip"
+
+IUSE="+ant userland_GNU"
+
+LICENSE="EPL-1.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="3.6"
+
+CDEPEND=">=app-admin/eselect-ecj-0.3"
+
+JAVA_PKG_WANT_SOURCE=1.4
+JAVA_PKG_WANT_TARGET=1.4
+
+DEPEND="${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.6
+ userland_GNU? ( sys-apps/findutils )"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.4"
+PDEPEND="ant? ( ~dev-java/ant-eclipse-ecj-${PV} )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # These have their own package.
+ rm -f org/eclipse/jdt/core/JDTCompilerAdapter.java || die
+ rm -fr org/eclipse/jdt/internal/antadapter || die
+
+ # upstream build.xml excludes this
+ rm META-INF/eclipse.inf
+}
+
+src_compile() {
+ local javac_opts javac java jar
+
+ javac_opts="$(java-pkg_javac-args) -encoding ISO-8859-1"
+ javac="$(java-config -c)"
+ java="$(java-config -J)"
+ jar="$(java-config -j)"
+
+ find org/ -path org/eclipse/jdt/internal/compiler/apt -prune -o \
+ -path org/eclipse/jdt/internal/compiler/tool -prune -o -name '*.java' \
+ -print > sources-1.4
+ find org/eclipse/jdt/internal/compiler/{apt,tool} -name '*.java' > sources-1.6
+
+ mkdir -p bootstrap || die
+ cp -pPR org bootstrap || die
+ cd "${S}/bootstrap" || die
+
+ einfo "bootstrapping ${MY_PN} with ${javac} ..."
+ ${javac} ${javac_opts} @../sources-1.4 || die
+ ${javac} -encoding ISO-8859-1 -source 1.6 -target 1.6 @../sources-1.6 || die
+
+ find org/ -name '*.class' -o -name '*.properties' -o -name '*.rsc' \
+ | xargs ${jar} cf ${MY_PN}.jar
+
+ cd "${S}" || die
+ einfo "building ${MY_PN} with bootstrapped ${MY_PN} ..."
+ ${java} -classpath bootstrap/${MY_PN}.jar \
+ org.eclipse.jdt.internal.compiler.batch.Main \
+ ${javac_opts} -nowarn @sources-1.4 || die
+ ${java} -classpath bootstrap/${MY_PN}.jar \
+ org.eclipse.jdt.internal.compiler.batch.Main \
+ -encoding ISO-8859-1 -source 1.6 -target 1.6 -nowarn @sources-1.6 || die
+
+ find org/ -name '*.class' -o -name '*.properties' -o -name '*.rsc' \
+ | xargs ${jar} cf ${MY_PN}.jar
+}
+
+src_install() {
+ java-pkg_dolauncher ${MY_PN}-${SLOT} --main \
+ org.eclipse.jdt.internal.compiler.batch.Main
+
+ # disable the class version verify, this has intentionally
+ # some classes with 1.6, but most is 1.4
+ JAVA_PKG_STRICT="" java-pkg_dojar ${MY_PN}.jar
+}
+
+pkg_postinst() {
+ einfo "To select between slots of ECJ..."
+ einfo " # eselect ecj"
+
+ eselect ecj update ecj-${SLOT}
+}
+
+pkg_postrm() {
+ eselect ecj update
+}