summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-05-18 19:43:11 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-05-18 19:43:11 +0000
commit38474c4c91e2dc69799b1c5da773f01b6fe0aee1 (patch)
tree7ed6349e560fc964325a03e55e802fc0e08ff934 /dev-java/oscache
parentMigrate to the jms virtual (diff)
downloadhistorical-38474c4c91e2dc69799b1c5da773f01b6fe0aee1.tar.gz
historical-38474c4c91e2dc69799b1c5da773f01b6fe0aee1.tar.bz2
historical-38474c4c91e2dc69799b1c5da773f01b6fe0aee1.zip
Migrate to the jms virtual.
Package-Manager: portage-2.2_rc28/cvs/Linux i686
Diffstat (limited to 'dev-java/oscache')
-rw-r--r--dev-java/oscache/ChangeLog10
-rw-r--r--dev-java/oscache/oscache-2.0.2-r3.ebuild71
2 files changed, 79 insertions, 2 deletions
diff --git a/dev-java/oscache/ChangeLog b/dev-java/oscache/ChangeLog
index 98429e8f61c0..c62a93009706 100644
--- a/dev-java/oscache/ChangeLog
+++ b/dev-java/oscache/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/oscache
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oscache/ChangeLog,v 1.8 2008/03/22 21:21:19 wltjr Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oscache/ChangeLog,v 1.9 2009/05/18 19:41:19 betelgeuse Exp $
+
+*oscache-2.0.2-r3 (18 May 2009)
+
+ 18 May 2009; Petteri Räty <betelgeuse@gentoo.org>
+ +oscache-2.0.2-r3.ebuild:
+ Migrate to the jms virtual.
*oscache-2.0.2-r2 (22 Mar 2008)
diff --git a/dev-java/oscache/oscache-2.0.2-r3.ebuild b/dev-java/oscache/oscache-2.0.2-r3.ebuild
new file mode 100644
index 000000000000..bd933c4b961f
--- /dev/null
+++ b/dev-java/oscache/oscache-2.0.2-r3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oscache/oscache-2.0.2-r3.ebuild,v 1.1 2009/05/18 19:41:19 betelgeuse Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc"
+
+inherit java-pkg-2
+
+DESCRIPTION="OSCache is a widely used, high performance J2EE caching framework."
+SRC_URI="https://oscache.dev.java.net/files/documents/629/2653/${P}-full.zip"
+HOMEPAGE="http://www.opensymphony.com/oscache/"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+COMMON_DEP="
+ dev-java/commons-collections
+ dev-java/commons-logging
+ java-virtuals/servlet-api:2.3
+ java-virtuals/jms
+ dev-java/jgroups"
+RDEPEND=">=virtual/jre-1.3
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.3
+ ${COMMON_DEP}
+ app-arch/unzip"
+IUSE=""
+
+S=${WORKDIR}
+
+java_prepare() {
+ find . -name "*.jar" -print -delete || die
+}
+
+src_compile() {
+ local build_dir="${S}"/build
+ local classpath="-classpath $(java-pkg_getjars commons-logging,commons-collections,servlet-api-2.3,jms,jgroups):${build_dir}:."
+ mkdir ${build_dir}
+
+ echo "Building core..."
+ cd "${S}"/src/core/java
+ ejavac ${classpath} -nowarn -d ${build_dir} $(find . -name "*.java") || die
+
+ echo "Building cluster support plugin..."
+ cd "${S}"/src/plugins/clustersupport/java
+ find . -name "*.java" -exec sed -i -e "s/org.javagroups/org.jgroups/g" {} \;
+ ejavac ${classpath} -nowarn -d ${build_dir} $(find . -name "*.java") || die
+
+ echo "Building disk persistence plugin..."
+ cd "${S}"/src/plugins/diskpersistence/java
+ ejavac ${classpath} -nowarn -d ${build_dir} `find . -name "*.java"` || die "compile failed"
+
+ if use doc ; then
+ echo "Building documentation..."
+ mkdir "${S}"/javadoc
+ cd ${build_dir}
+ local sourcepath="${S}/src/core/java:${S}/src/plugins/diskpersistence/java:${S}/src/plugins/clustersupport/java"
+ javadoc ${classpath} -sourcepath ${sourcepath} -d "${S}"/javadoc \
+ $(find com/opensymphony/oscache -type d | tr '/' '.') \
+ || die "failed to create javadoc"
+ fi
+
+ cd "${S}"
+ jar cf ${PN}.jar -C build . || die "jar failed"
+}
+
+src_install() {
+ java-pkg_dojar *.jar
+ dodoc readme.txt
+ use doc && java-pkg_dojavadoc javadoc
+}