summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Noël Rivasseau <elvanor@gentoo.org>2009-03-27 20:14:30 +0000
committerJean-Noël Rivasseau <elvanor@gentoo.org>2009-03-27 20:14:30 +0000
commit10ed1138cd31bfb6ea615bc0d565da1ac14c3ffc (patch)
tree13f14425d787f7f42298fea367dc30254a493387 /dev-java/commons-cli
parentFix obvious typo in comments. Thanks to zlin for noticing. (diff)
downloadhistorical-10ed1138cd31bfb6ea615bc0d565da1ac14c3ffc.tar.gz
historical-10ed1138cd31bfb6ea615bc0d565da1ac14c3ffc.tar.bz2
historical-10ed1138cd31bfb6ea615bc0d565da1ac14c3ffc.zip
Used EAPI2 for commons-cli and RESTRICT="test"
Package-Manager: portage-2.1.6.7/cvs/Linux i686
Diffstat (limited to 'dev-java/commons-cli')
-rw-r--r--dev-java/commons-cli/Manifest2
-rw-r--r--dev-java/commons-cli/commons-cli-1.2.ebuild13
2 files changed, 8 insertions, 7 deletions
diff --git a/dev-java/commons-cli/Manifest b/dev-java/commons-cli/Manifest
index 40953998d919..8ff315b067ab 100644
--- a/dev-java/commons-cli/Manifest
+++ b/dev-java/commons-cli/Manifest
@@ -6,6 +6,6 @@ DIST commons-cli-1.1-src.tar.gz 63320 RMD160 c778f9b084185e601662b554630465213b6
DIST commons-cli-1.2-src.tar.gz 68594 RMD160 b49ac30c33c49920d8317663c00eb55b7a78ec61 SHA1 0aa042a0e35d96afaffbfb6cdbdad3e16d67fd7c SHA256 b589cd675866aec12a068e0717f2bd52ead6128c43ba1612a8815db1df7f6e67
EBUILD commons-cli-1.0-r5.ebuild 1218 RMD160 277518b13c6c8a7bd91d304984fe30a85d6a1cec SHA1 e9d06ce3df1694b19537a8801d772bb9034b2068 SHA256 7f0b7337f6ac9782b44d333896a0b5c99bf63107109a515b9b3edd9451ebdb91
EBUILD commons-cli-1.1.ebuild 998 RMD160 2a3a27bb1e4042ad745381fe7dc9e00e2d260d6a SHA1 335c9ade8d8393afed22ad972fcef47116c2456d SHA256 d4c30e46658b3147ce9551cc6e7522e9961ecc8d7d9e66adbb56976371359212
-EBUILD commons-cli-1.2.ebuild 1447 RMD160 e76a23ab5080ebf46a7f4e93d0bae75d499bac97 SHA1 024603ecffa01169bf3c118a73b99e9a8fd2a060 SHA256 b844c94ee03eee55733b864a2f6b1f4edf2f890c2f45fabd76d1cc054d7f4771
+EBUILD commons-cli-1.2.ebuild 1436 RMD160 891da489cdb66a537196c20716792db426bc1c93 SHA1 e18d7b36a21d5ea09625c172ad70eb45e8daff71 SHA256 bea04980768c8251fb564c598e08a35dffe04b756c86b1d05d806c179d098ade
MISC ChangeLog 5817 RMD160 9fea2d4cd0c1b007d9c4bcebe0ba1ea3a7cb9490 SHA1 44c39cdc696e88210475e828f8e9740913044830 SHA256 6835f3bade8beb72bf21a368610d32061c2d2394a127e245192ea14e42970011
MISC metadata.xml 157 RMD160 ab0b3741457dee7531f59c4da0f0e9e8399af084 SHA1 c37a6b9922aef61b5b3387655bccb6e3b16e0e26 SHA256 295d02c5805b0257938eb80314b371daac94b8d6ea85629a902de7a824adc0c9
diff --git a/dev-java/commons-cli/commons-cli-1.2.ebuild b/dev-java/commons-cli/commons-cli-1.2.ebuild
index 6e1fa2b6a6c9..ed965440b5bf 100644
--- a/dev-java/commons-cli/commons-cli-1.2.ebuild
+++ b/dev-java/commons-cli/commons-cli-1.2.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.2.ebuild,v 1.1 2009/03/27 19:54:47 elvanor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-cli/commons-cli-1.2.ebuild,v 1.2 2009/03/27 20:14:30 elvanor Exp $
# Upstream switched to Maven as a build system. Current build.xml file was generated by running mvn ant:ant
# A bit of tweaking was required unfortunately
+EAPI="2"
JAVA_PKG_IUSE="doc source test"
inherit java-pkg-2 java-ant-2 eutils
@@ -19,6 +20,9 @@ SLOT="1"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
+# Tests currently fail, upstream bug: https://issues.apache.org/jira/browse/CLI-178
+RESTRICT="test"
+
RDEPEND=">=virtual/jre-1.4"
# Blocking junit for https://bugs.gentoo.org/show_bug.cgi?id=215659
DEPEND=">=virtual/jdk-1.4
@@ -42,10 +46,7 @@ src_install() {
use source && java-pkg_dosrc src/java/org
}
-# Tests currently fail, upstream bug: https://issues.apache.org/jira/browse/CLI-178
-
src_test() {
- #ANT_TASKS="ant-junit"
- #eant -Djunit.present="true" test
- echo "Tests currently disabled."
+ ANT_TASKS="ant-junit"
+ eant -Djunit.present="true" test
}