summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2006-08-13 16:40:34 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2006-08-13 16:40:34 +0000
commit450210c3c3dca409d18c2ce332a884e14e376fd3 (patch)
treef92c31fd660f503be3a5338c59e652340f2cf4e0 /dev-haskell/hmake/hmake-3.11.ebuild
parentunused (diff)
downloadhistorical-450210c3c3dca409d18c2ce332a884e14e376fd3.tar.gz
historical-450210c3c3dca409d18c2ce332a884e14e376fd3.tar.bz2
historical-450210c3c3dca409d18c2ce332a884e14e376fd3.zip
Changes to always use Gentoo installed GHC compiler. See bug #134379. Thanks to Mario Blazevi for reporting the bug.
Package-Manager: portage-2.1.1_pre5
Diffstat (limited to 'dev-haskell/hmake/hmake-3.11.ebuild')
-rw-r--r--dev-haskell/hmake/hmake-3.11.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-haskell/hmake/hmake-3.11.ebuild b/dev-haskell/hmake/hmake-3.11.ebuild
index 5b7b27e2809f..f4ab922a61d6 100644
--- a/dev-haskell/hmake/hmake-3.11.ebuild
+++ b/dev-haskell/hmake/hmake-3.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.11.ebuild,v 1.1 2006/05/12 15:53:10 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.11.ebuild,v 1.2 2006/08/13 16:40:34 kolmodin Exp $
-inherit base eutils fixheadtails
+inherit base eutils fixheadtails ghc-package
DESCRIPTION="a make tool for Haskell programs"
HOMEPAGE="http://www.haskell.org/hmake/"
@@ -41,7 +41,7 @@ src_compile() {
./configure \
--prefix=/usr \
--mandir=/usr/share/man/man1 \
- --buildwith=ghc \
+ --buildwith="$(ghc-getghc)" \
|| die "./configure failed"
# emake tested; parallel make does not work