summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-07-29 13:48:46 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-07-29 13:48:46 +0000
commit38c19e156333078c5bc5cbd37aea8ba1e2e02914 (patch)
treefc684de2f93650318461b4634872ddc22626ffdc /dev-haskell/hmake/hmake-3.11.ebuild
parentMoving net-www/mod_security to www-apache/mod_security (#81244). (diff)
downloadhistorical-38c19e156333078c5bc5cbd37aea8ba1e2e02914.tar.gz
historical-38c19e156333078c5bc5cbd37aea8ba1e2e02914.tar.bz2
historical-38c19e156333078c5bc5cbd37aea8ba1e2e02914.zip
New minor version and fix building with ghc-6.6.1.
Package-Manager: portage-2.1.2.9
Diffstat (limited to 'dev-haskell/hmake/hmake-3.11.ebuild')
-rw-r--r--dev-haskell/hmake/hmake-3.11.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-haskell/hmake/hmake-3.11.ebuild b/dev-haskell/hmake/hmake-3.11.ebuild
index 86ed57dcb08a..9bd4ad0f3776 100644
--- a/dev-haskell/hmake/hmake-3.11.ebuild
+++ b/dev-haskell/hmake/hmake-3.11.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.11.ebuild,v 1.9 2007/07/28 20:55:30 diox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.11.ebuild,v 1.10 2007/07/29 13:48:46 dcoutts Exp $
inherit base eutils fixheadtails ghc-package
-DESCRIPTION="a make tool for Haskell programs"
+DESCRIPTION="A make tool for Haskell programs"
HOMEPAGE="http://www.haskell.org/hmake/"
SRC_URI="http://www.haskell.org/hmake/${P}.tar.gz"
@@ -29,6 +29,13 @@ src_unpack() {
cd ${S}
epatch "${FILESDIR}/${P}-ghc66.patch"
+ # Fix the way hmake discovers the ghc version
+ sed -i -e '/echo __GLASGOW_HASKELL__/,+2 c \
+ touch ghcsym.hs; \
+ $1 -E -cpp -optP-dM ghcsym.hs -o ghcsym.out; \
+ grep __GLASGOW_HASKELL__ ghcsym.out | cut -d" " -f 3 > $2;' \
+ "${S}/script/confhc"
+
# fix all head/tail declarations
sed -i 's/tail -1/tail -n 1/' src/hmake/MkConfig.hs
# the line above prevents current fixheadtails.eclass from doing nonsense;