summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-14 01:36:26 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-14 01:36:26 +0000
commitdaa9d974124277c2e7d46d04882365c8450d238e (patch)
tree459ce32e52a5f426b05607de243f6561632573a9 /dev-haskell/cabal
parentUpdates for upward compatability with cabal-1.2 and ghc-6.8 (diff)
downloadhistorical-daa9d974124277c2e7d46d04882365c8450d238e.tar.gz
historical-daa9d974124277c2e7d46d04882365c8450d238e.tar.bz2
historical-daa9d974124277c2e7d46d04882365c8450d238e.zip
New major version.
Package-Manager: portage-2.1.3.19
Diffstat (limited to 'dev-haskell/cabal')
-rw-r--r--dev-haskell/cabal/ChangeLog7
-rw-r--r--dev-haskell/cabal/cabal-1.2.3.0.ebuild64
-rw-r--r--dev-haskell/cabal/files/digest-cabal-1.2.3.06
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-haskell/cabal/ChangeLog b/dev-haskell/cabal/ChangeLog
index 78da627a4099..193562b7824f 100644
--- a/dev-haskell/cabal/ChangeLog
+++ b/dev-haskell/cabal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/cabal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.36 2007/12/13 00:42:07 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.37 2007/12/14 01:36:25 dcoutts Exp $
+
+*cabal-1.2.3.0 (14 Dec 2007)
+
+ 14 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> +cabal-1.2.3.0.ebuild:
+ New major version.
12 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> cabal-1.1.4.ebuild,
cabal-1.1.6.1.ebuild, cabal-1.1.6.2.ebuild:
diff --git a/dev-haskell/cabal/cabal-1.2.3.0.ebuild b/dev-haskell/cabal/cabal-1.2.3.0.ebuild
new file mode 100644
index 000000000000..84deae398e0c
--- /dev/null
+++ b/dev-haskell/cabal/cabal-1.2.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.2.3.0.ebuild,v 1.1 2007/12/14 01:36:25 dcoutts Exp $
+
+CABAL_FEATURES="bootstrap profile lib"
+inherit base haskell-cabal
+
+# Resolve cyclic dep between filepath and Cabal by using a private copy of
+# filepath when building Cabal.
+FP_PN=filepath
+FP_PV=1.1.0.0
+FP_P=${FP_PN}-${FP_PV}
+
+DESCRIPTION="Haskell Common Architecture for Building Applications and Libraries"
+HOMEPAGE="http://haskell.org/cabal"
+SRC_URI="http://haskell.org/cabal/release/${P}/${P}.tar.gz
+ http://hackage.haskell.org/packages/archive/${FP_PN}/${FP_PV}/${FP_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.2"
+
+CABAL_CORE_LIB_GHC_PV="6.8.2"
+
+src_unpack() {
+ base_src_unpack
+
+ # We're using the private copy of filepath:
+ sed -i -e 's/Build-Depends: filepath//' \
+ -e '/Other-Modules:/a \
+ System.FilePath System.FilePath.Posix System.FilePath.Windows' \
+ "${S}/Cabal.cabal"
+ # Note: do not replace spaces with tabs on the line above, it'll break
+ # things. You'll just have to put up with the repoman warning.
+
+ echo " Hs-Source-Dirs: ., ../${FP_P}" >> "${S}/Cabal.cabal"
+}
+
+src_compile() {
+ if ! cabal-is-dummy-lib; then
+ einfo "Bootstrapping Cabal..."
+ $(ghc-getghc) -i -i. -i"${WORKDIR}/${FP_P}" -cpp --make Setup.lhs \
+ -o setup || die "compiling Setup.lhs failed"
+ cabal-configure
+ cabal-build
+ fi
+}
+
+src_install() {
+ cabal_src_install
+
+ # documentation (install directly)
+ if use doc; then
+ dohtml -r doc/users-guide
+ dohtml -r doc/API
+ dohtml -r doc/pkg-spec-html
+ dodoc doc/pkg-spec.pdf
+ fi
+ dodoc changelog README releaseNotes TODO
+}
+
diff --git a/dev-haskell/cabal/files/digest-cabal-1.2.3.0 b/dev-haskell/cabal/files/digest-cabal-1.2.3.0
new file mode 100644
index 000000000000..cc43ffd5e501
--- /dev/null
+++ b/dev-haskell/cabal/files/digest-cabal-1.2.3.0
@@ -0,0 +1,6 @@
+MD5 f261d28d497f79bbe8b9ed585df6f23c cabal-1.2.3.0.tar.gz 627016
+RMD160 ba50d5c58049314c0a81c54fbca3ea0d6308c29f cabal-1.2.3.0.tar.gz 627016
+SHA256 d837351674dca88574811626ca3205314b43dc3e26e7d6a5a64f37916287cea5 cabal-1.2.3.0.tar.gz 627016
+MD5 0cc3f09ebafa7bde0a3c9e01d5e7c09f filepath-1.1.0.0.tar.gz 7548
+RMD160 deecc7cedc1ef803d6bb289b52de8139aa475ff3 filepath-1.1.0.0.tar.gz 7548
+SHA256 3732be8c2f3d0ba63347b772a605614967c573416340ca6382cce0c7dccf92ee filepath-1.1.0.0.tar.gz 7548