summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 03:20:22 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 03:20:22 +0000
commit4ee4504a3a027888ce1e9077832124257366421f (patch)
treefc93fffb3a2990f2fbd919a7603381fcf54449da /dev-haskell/blaze-markup/blaze-markup-0.5.1.0.ebuild
parentBump monad-control to 0.3.1.3 (diff)
downloadhistorical-4ee4504a3a027888ce1e9077832124257366421f.tar.gz
historical-4ee4504a3a027888ce1e9077832124257366421f.tar.bz2
historical-4ee4504a3a027888ce1e9077832124257366421f.zip
Add blaze-markup
Package-Manager: portage-2.1.10.63/cvs/Linux x86_64
Diffstat (limited to 'dev-haskell/blaze-markup/blaze-markup-0.5.1.0.ebuild')
-rw-r--r--dev-haskell/blaze-markup/blaze-markup-0.5.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-haskell/blaze-markup/blaze-markup-0.5.1.0.ebuild b/dev-haskell/blaze-markup/blaze-markup-0.5.1.0.ebuild
new file mode 100644
index 000000000000..0b096232a479
--- /dev/null
+++ b/dev-haskell/blaze-markup/blaze-markup-0.5.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/blaze-markup/blaze-markup-0.5.1.0.ebuild,v 1.1 2012/06/02 03:20:22 gienah Exp $
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A blazingly fast markup combinator library for Haskell"
+HOMEPAGE="http://jaspervdj.be/blaze"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/blaze-builder-0.2[profile?]
+ <dev-haskell/blaze-builder-0.4[profile?]
+ >=dev-haskell/text-0.10[profile?]
+ <dev-haskell/text-0.12[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"
+
+src_prepare() {
+ sed -e 's@bytestring >= 0.9 && < 0.10@bytestring >= 0.9 \&\& < 0.11@g' \
+ -e 's@containers >= 0.3 && < 0.5@containers >= 0.3 \&\& < 0.6@' \
+ -i "${S}/${PN}.cabal" || die "Could not loosen dependencies"
+}