summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2013-09-28 13:10:14 +0000
committerAlfredo Tupone <tupone@gentoo.org>2013-09-28 13:10:14 +0000
commit1d9cd48c27ce94ca60bc87d86ff5555a91f8729a (patch)
tree58f5bd06374e92e9357740a22cee9880c19f6cd5 /dev-games/mercator/mercator-0.3.3.ebuild
parentVersion bump (diff)
downloadhistorical-1d9cd48c27ce94ca60bc87d86ff5555a91f8729a.tar.gz
historical-1d9cd48c27ce94ca60bc87d86ff5555a91f8729a.tar.bz2
historical-1d9cd48c27ce94ca60bc87d86ff5555a91f8729a.zip
Version bump to 0.3.3
Package-Manager: portage-2.2.1/cvs/Linux x86_64 Manifest-Sign-Key: 0x0145142D
Diffstat (limited to 'dev-games/mercator/mercator-0.3.3.ebuild')
-rw-r--r--dev-games/mercator/mercator-0.3.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-games/mercator/mercator-0.3.3.ebuild b/dev-games/mercator/mercator-0.3.3.ebuild
new file mode 100644
index 000000000000..da8715c34d9a
--- /dev/null
+++ b/dev-games/mercator/mercator-0.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/mercator/mercator-0.3.3.ebuild,v 1.1 2013/09/28 13:10:06 tupone Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="WorldForge library primarily aimed at terrain."
+HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/mercator"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+SLOT="0"
+
+RDEPEND=">=dev-games/wfmath-1"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_compile() {
+ default
+ use doc && emake docs
+}
+
+src_install() {
+ default
+ use doc && dohtml -r doc/html/*
+ prune_libtool_files
+}