summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-03-30 03:45:50 +0000
committerMike Frysinger <vapier@gentoo.org>2012-03-30 03:45:50 +0000
commit224d8438af4c1c1f257c7179c4dd2901245395b8 (patch)
tree9c68f6ff48e94e7825ea3f39350b059178148424 /dev-embedded
parentFix build failure against ghc-7.4 (reported by Christian Lask). (diff)
downloadhistorical-224d8438af4c1c1f257c7179c4dd2901245395b8.tar.gz
historical-224d8438af4c1c1f257c7179c4dd2901245395b8.tar.bz2
historical-224d8438af4c1c1f257c7179c4dd2901245395b8.zip
Convert to cmake as upstream dropped autotools #410117 by Matthias Nagl.
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/libftdi/ChangeLog8
-rw-r--r--dev-embedded/libftdi/libftdi-9999.1.0.ebuild35
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild32
3 files changed, 35 insertions, 40 deletions
diff --git a/dev-embedded/libftdi/ChangeLog b/dev-embedded/libftdi/ChangeLog
index 2acbef3ac0c2..e22f80e3ae9c 100644
--- a/dev-embedded/libftdi/ChangeLog
+++ b/dev-embedded/libftdi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-embedded/libftdi
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.58 2011/10/20 15:40:57 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/ChangeLog,v 1.59 2012/03/30 03:45:50 vapier Exp $
+
+ 30 Mar 2012; Mike Frysinger <vapier@gentoo.org> libftdi-9999.ebuild,
+ libftdi-9999.1.0.ebuild:
+ Convert to cmake as upstream dropped autotools #410117 by Matthias Nagl.
20 Oct 2011; Mike Frysinger <vapier@gentoo.org> libftdi-0.19.ebuild,
libftdi-9999.ebuild, libftdi-9999.1.0.ebuild:
diff --git a/dev-embedded/libftdi/libftdi-9999.1.0.ebuild b/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
index 6ba8212b7ee7..bf044e8abacb 100644
--- a/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.1.0.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.1.0.ebuild,v 1.5 2011/10/20 15:40:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.1.0.ebuild,v 1.6 2012/03/30 03:45:50 vapier Exp $
EAPI="2"
+inherit cmake-utils
+
if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="git://developer.intra2net.com/${PN}-${PV#9999.}"
inherit git-2 autotools
@@ -17,34 +19,27 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="0"
-IUSE="cxx doc examples python static-libs"
+IUSE="cxx doc examples python"
-RDEPEND="virtual/libusb:1
+RDEPEND="virtual/libusb:0
cxx? ( dev-libs/boost )
python? ( dev-lang/python )"
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-src_prepare() {
- if [[ ${PV} == 9999* ]] ; then
- mkdir -p m4
- eautoreconf
- fi
-}
-
src_configure() {
- econf \
- --with-async-mode \
- $(use_enable cxx libftdipp) \
- $(use_with doc docs) \
- $(use_with examples) \
- $(use_enable python python-binding) \
- $(use_enable static-libs static)
+ mycmakeargs=(
+ $(cmake-utils_use cxx FTDIPP)
+ $(cmake-utils_use doc DOCUMENTATION)
+ $(cmake-utils_use examples EXAMPLES)
+ $(cmake-utils_use python PYTHON_BINDINGS)
+ -DCMAKE_SKIP_BUILD_RPATH=ON
+ )
+ cmake-utils_src_configure
}
src_install() {
- emake DESTDIR="${D}" install || die
- use static-libs || find "${D}" -name '*.la' -delete
+ cmake-utils_src_install
dodoc ChangeLog README
if use doc ; then
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index 9ea9549634d0..1def79a3986b 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.ebuild,v 1.5 2011/10/20 15:40:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/libftdi/libftdi-9999.ebuild,v 1.6 2012/03/30 03:45:50 vapier Exp $
EAPI="2"
+inherit cmake-utils
+
if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
inherit git-2 autotools
@@ -17,7 +19,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="0"
-IUSE="cxx doc examples python static-libs"
+IUSE="cxx doc examples python"
RDEPEND="virtual/libusb:0
cxx? ( dev-libs/boost )
@@ -25,25 +27,19 @@ RDEPEND="virtual/libusb:0
DEPEND="${RDEPEND}
doc? ( app-doc/doxygen )"
-src_prepare() {
- if [[ ${PV} == 9999* ]] ; then
- mkdir -p m4
- eautoreconf
- fi
-}
-
src_configure() {
- econf \
- $(use_enable cxx libftdipp) \
- $(use_with doc docs) \
- $(use_with examples) \
- $(use_enable python python-binding) \
- $(use_enable static-libs static)
+ mycmakeargs=(
+ $(cmake-utils_use cxx FTDIPP)
+ $(cmake-utils_use doc DOCUMENTATION)
+ $(cmake-utils_use examples EXAMPLES)
+ $(cmake-utils_use python PYTHON_BINDINGS)
+ -DCMAKE_SKIP_BUILD_RPATH=ON
+ )
+ cmake-utils_src_configure
}
src_install() {
- emake DESTDIR="${D}" install || die
- use static-libs || find "${D}" -name '*.la' -delete
+ cmake-utils_src_install
dodoc ChangeLog README
if use doc ; then