summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-01-25 17:54:56 +0000
committerPacho Ramos <pacho@gentoo.org>2011-01-25 17:54:56 +0000
commita062f41e8c7a21507d351495f1e60cf0ffcdd97c (patch)
tree1c4fe164a459282578bc7d2dc17c6bbaa002590b /dev-dotnet/xsp/xsp-2.8.2.ebuild
parentStable for HPPA (bug #352654). (diff)
downloadhistorical-a062f41e8c7a21507d351495f1e60cf0ffcdd97c.tar.gz
historical-a062f41e8c7a21507d351495f1e60cf0ffcdd97c.tar.bz2
historical-a062f41e8c7a21507d351495f1e60cf0ffcdd97c.zip
Version bump, remove old testing and 9999 version since it's not really maintained downstream.
Package-Manager: portage-2.1.9.35/cvs/Linux x86_64
Diffstat (limited to 'dev-dotnet/xsp/xsp-2.8.2.ebuild')
-rw-r--r--dev-dotnet/xsp/xsp-2.8.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-dotnet/xsp/xsp-2.8.2.ebuild b/dev-dotnet/xsp/xsp-2.8.2.ebuild
new file mode 100644
index 000000000000..da561653d7e4
--- /dev/null
+++ b/dev-dotnet/xsp/xsp-2.8.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/xsp/xsp-2.8.2.ebuild,v 1.1 2011/01/25 17:54:56 pacho Exp $
+
+EAPI=2
+
+inherit go-mono mono
+
+PATCHDIR="${FILESDIR}/2.2/"
+
+DESCRIPTION="XSP is a small web server that can host ASP.NET pages"
+HOMEPAGE="http://www.mono-project.com/ASP.NET"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE=""
+
+RDEPEND="dev-db/sqlite:3"
+DEPEND="${RDEPEND}"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+pkg_preinst() {
+ enewgroup aspnet
+ # Give aspnet home dir of /tmp since it must create ~/.wapi
+ enewuser aspnet -1 -1 /tmp aspnet
+}
+
+src_install() {
+ mv_command="cp -ar" go-mono_src_install
+ newinitd "${PATCHDIR}"/xsp.initd xsp || die
+ newinitd "${PATCHDIR}"/mod-mono-server.initd mod-mono-server || die
+ newconfd "${PATCHDIR}"/xsp.confd xsp || die
+ newconfd "${PATCHDIR}"/mod-mono-server.confd mod-mono-server || die
+
+ keepdir /var/run/aspnet
+}
+
+pkg_postinst() {
+ chown aspnet:aspnet /var/run/aspnet
+}