summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-29 21:23:42 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-29 21:23:42 +0000
commitd1a141ebd245264a6dabea547e02dde8f08d6a44 (patch)
treed114bbcf93ae016c74e871b0c6a99a3483a06908 /dev-dotnet/mono-fuse/mono-fuse-0.4.1.ebuild
parentInitial commit, see bug #83877. Thanks to everybody for contributing to this ... (diff)
downloadhistorical-d1a141ebd245264a6dabea547e02dde8f08d6a44.tar.gz
historical-d1a141ebd245264a6dabea547e02dde8f08d6a44.tar.bz2
historical-d1a141ebd245264a6dabea547e02dde8f08d6a44.zip
dev-dotnet/mono-fuse: added examples use flag, version bump -> 0.4.1
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'dev-dotnet/mono-fuse/mono-fuse-0.4.1.ebuild')
-rw-r--r--dev-dotnet/mono-fuse/mono-fuse-0.4.1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-dotnet/mono-fuse/mono-fuse-0.4.1.ebuild b/dev-dotnet/mono-fuse/mono-fuse-0.4.1.ebuild
new file mode 100644
index 000000000000..00a0bb01c3f0
--- /dev/null
+++ b/dev-dotnet/mono-fuse/mono-fuse-0.4.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/mono-fuse/mono-fuse-0.4.1.ebuild,v 1.1 2007/06/29 21:23:42 jurek Exp $
+
+inherit autotools mono
+
+DESCRIPTION="C# binding for the FUSE library"
+HOMEPAGE="http://www.jprl.com/Projects/mono-fuse/"
+SRC_URI="http://www.jprl.com/Projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="examples"
+
+DEPEND=">=dev-lang/mono-1.1.13
+ >=dev-util/monodoc-1.1.13
+ >=sys-fs/fuse-2.5.2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i -e 's#^AC_CHECK_LIB(MonoPosixHelper.*$##' \
+ configure.in || die "sed failed"
+
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_compile()
+{
+ econf || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install()
+{
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc ChangeLog README COPYING
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+
+pkg_postinst()
+{
+ elog "Ensure that you have the fuse module loaded"
+ elog "before you start using mono-fuse"
+}