summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-11-27 01:27:18 +0000
committerPeter Johanson <latexer@gentoo.org>2005-11-27 01:27:18 +0000
commit171b0ece0f0cd66ec6278e634335bd5bb0dd9eb0 (patch)
treea2533d68a6770ae6a44d2d1ca4823d93e83ea178 /dev-dotnet/db4o/db4o-5.0.ebuild
parentMultilib fix. (diff)
downloadhistorical-171b0ece0f0cd66ec6278e634335bd5bb0dd9eb0.tar.gz
historical-171b0ece0f0cd66ec6278e634335bd5bb0dd9eb0.tar.bz2
historical-171b0ece0f0cd66ec6278e634335bd5bb0dd9eb0.zip
Bump.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'dev-dotnet/db4o/db4o-5.0.ebuild')
-rw-r--r--dev-dotnet/db4o/db4o-5.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-dotnet/db4o/db4o-5.0.ebuild b/dev-dotnet/db4o/db4o-5.0.ebuild
new file mode 100644
index 000000000000..058cb70ec0cd
--- /dev/null
+++ b/dev-dotnet/db4o/db4o-5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/db4o/db4o-5.0.ebuild,v 1.1 2005/11/27 01:27:18 latexer Exp $
+
+inherit mono multilib eutils
+
+DESCRIPTION="Object database for .NET"
+HOMEPAGE="http://www.db4o.com/"
+SRC_URI="http://www.db4o.com/downloads/${P}-mono.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-lang/mono"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-makefile-filelist.diff
+}
+
+src_compile() {
+ emake -j1 buildcore || die "emake failed"
+}
+
+src_install() {
+ dohtml -a html,gif,js,css -r ${S}/doc/api
+
+ # For now we don't install into the GAC, following upstream's RPM packaging.
+ insinto /usr/$(get_libdir)/db4o
+ doins ${S}/bin/db4o.dll*
+}