summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2006-08-21 15:26:32 +0000
committerRenat Lumpau <rl03@gentoo.org>2006-08-21 15:26:32 +0000
commitf69be632962cd033db41d6d583adf1b2b5c8fec9 (patch)
treec72c26e6a84327bcb68f1e967aa144de94b41bc0 /dev-db
parentadd support for FreeBSD kqueue (diff)
downloadhistorical-f69be632962cd033db41d6d583adf1b2b5c8fec9.tar.gz
historical-f69be632962cd033db41d6d583adf1b2b5c8fec9.tar.bz2
historical-f69be632962cd033db41d6d583adf1b2b5c8fec9.zip
Version bump, bug #144340.
Package-Manager: portage-2.1.1_pre2-r6
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/ChangeLog8
-rw-r--r--dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.2.23
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.8.2.2.ebuild87
3 files changed, 97 insertions, 1 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index c16bf27b857c..ca9d9bb8ae4b 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.196 2006/08/03 03:47:06 rl03 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.197 2006/08/21 15:26:32 rl03 Exp $
+
+*phpmyadmin-2.8.2.2 (21 Aug 2006)
+
+ 21 Aug 2006; Renat Lumpau <rl03@gentoo.org> -phpmyadmin-2.8.2.1.ebuild,
+ +phpmyadmin-2.8.2.2.ebuild:
+ Version bump, bug #144340.
*phpmyadmin-2.8.2.1 (03 Aug 2006)
diff --git a/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.2.2 b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.2.2
new file mode 100644
index 000000000000..f2eaab7a3718
--- /dev/null
+++ b/dev-db/phpmyadmin/files/digest-phpmyadmin-2.8.2.2
@@ -0,0 +1,3 @@
+MD5 51b0dea853b4af7c5b97cb5e190f8ddd phpMyAdmin-2.8.2.2.tar.bz2 2014113
+RMD160 e8fb18a9eabdb09fb95481a66931a04b10c0c6c3 phpMyAdmin-2.8.2.2.tar.bz2 2014113
+SHA256 d1adb191c0b9c078c1faa98a5bec0ec634ecd351f8b86fea66dc42aa159972ee phpMyAdmin-2.8.2.2.tar.bz2 2014113
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.8.2.2.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.8.2.2.ebuild
new file mode 100644
index 000000000000..dc736fb2c2b7
--- /dev/null
+++ b/dev-db/phpmyadmin/phpmyadmin-2.8.2.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.8.2.2.ebuild,v 1.1 2006/08/21 15:26:32 rl03 Exp $
+
+inherit eutils webapp depend.php
+
+MY_PV=${PV/_/-}
+MY_P=phpMyAdmin-${MY_PV}
+DESCRIPTION="Web-based administration for MySQL database in PHP"
+HOMEPAGE="http://www.phpmyadmin.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND=">=dev-db/mysql-3.23.32 <dev-db/mysql-5.1
+ sys-apps/findutils"
+S=${WORKDIR}/${MY_P}
+
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+
+ if ! PHPCHECKNODIE="yes" require_php_with_use pcre session unicode \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ; then
+ eerror
+ eerror "${PHP_PKG} needs to be re-installed with all of the following"
+ eerror "USE flags enabled:"
+ eerror
+ eerror "pcre session unicode"
+ eerror
+ eerror "as well as any of the following USE flags enabled:"
+ eerror
+ eerror "mysql or mysqli if using dev-lang/php-5"
+ eerror "mysql if using dev-lang/php-4"
+ eerror
+ die "Re-install ${PHP_PKG}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/config.default.php-2.8.0.patch
+
+ # Remove .cvs* files and CVS directories
+ find ${S} -name .cvs\* -or \( -type d -name CVS -prune \) | xargs rm -rf
+}
+
+src_compile() {
+ einfo "Setting random user/password details for the controluser"
+
+ local pmapass="${RANDOM}${RANDOM}${RANDOM}${RANDOM}"
+ sed -e "s/@pmapass@/${pmapass}/g" -i libraries/config.default.php
+ sed -e "s/@pmapass@/${pmapass}/g" \
+ ${FILESDIR}/mysql-setup.sql.in-2.5.6 > ${T}/mysql-setup.sql
+}
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog"
+
+ # install the SQL scripts available to us
+ #
+ # unfortunately, we do not have scripts to upgrade from older versions
+ # these are things we need to add at a later date
+
+ webapp_sqlscript mysql ${T}/mysql-setup.sql
+
+ dodoc ${docs}
+ dohtml Documentation.html
+
+ # Copy the app's main files
+
+ einfo "Installing main files"
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/libraries/config.default.php
+ webapp_serverowned ${MY_HTDOCSDIR}/libraries/config.default.php
+
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en-2.8.0.txt
+ webapp_hook_script ${FILESDIR}/reconfig-2.8
+ webapp_src_install
+ # bug #88831, make sure the create script is world-readable.
+ fperms 0600 ${MY_SQLSCRIPTSDIR}/mysql/${PVR}_create.sql
+}