summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-08-26 09:20:59 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-08-26 09:20:59 +0000
commit587e75776b7ba26bbb9247b373127d2d82236c34 (patch)
tree3d3a1e6acc5c0962579a68425326aa28c8c4657f /dev-db
parentUnmasked PostgreSQL 7.2.2 (diff)
downloadhistorical-587e75776b7ba26bbb9247b373127d2d82236c34.tar.gz
historical-587e75776b7ba26bbb9247b373127d2d82236c34.tar.bz2
historical-587e75776b7ba26bbb9247b373127d2d82236c34.zip
Cleanups
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog6
-rw-r--r--dev-db/postgresql/postgresql-7.2.2.ebuild14
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index d76a53aa2a2c..585203e1528a 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.25 2002/08/26 08:05:39 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.26 2002/08/26 09:20:59 aliz Exp $
*postgresql-7.2.2 (26 Aug 2002)
26 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> postgresql-7.2.2.ebuild:
+ Cleaned up ebuild. Removed tarballs of documentation and manpages from
+ docdir.
+
+ 26 Aug 2002; Daniel Ahlberg <aliz@gentoo.org> postgresql-7.2.2.ebuild:
Security update.
* postgresql-7.2.1-r2 (31 Jul 2002)
diff --git a/dev-db/postgresql/postgresql-7.2.2.ebuild b/dev-db/postgresql/postgresql-7.2.2.ebuild
index af0cbd2f2632..2d19c7a2fba3 100644
--- a/dev-db/postgresql/postgresql-7.2.2.ebuild
+++ b/dev-db/postgresql/postgresql-7.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.2.ebuild,v 1.1 2002/08/26 08:05:39 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.2.2.ebuild,v 1.2 2002/08/26 09:20:59 aliz Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
@@ -45,11 +45,9 @@ pkg_setup() {
}
src_unpack() {
-
- unpack postgresql-${PV}.tar.gz
+ unpack ${A}
cd ${S}
-
# we know that a shared libperl is present, the default perl
# config is however set to the static libperl.a
# just remove the check
@@ -58,7 +56,6 @@ src_unpack() {
}
src_compile() {
-
local myconf
use tcltk && myconf="--with-tcl"
use python && myconf="$myconf --with-python"
@@ -81,7 +78,6 @@ src_compile() {
$myconf || die
make || die
-
}
pkg_preinst() {
@@ -132,6 +128,10 @@ src_install () {
exeinto /etc/init.d/
doexe ${FILESDIR}/${PV}/${PN}
+ # remove unnecessary files
+ rm ${D}/usr/share/doc/${P}/postgres.tar.gz
+ rm ${D}/usr/share/doc/${P}/man.tar.gz
+
einfo ">>> Execute the following command"
einfo ">>> ebuild /var/db/pkg/dev-db/${P}/${P}.ebuild config"
einfo ">>> to setup the initial database environment."
@@ -139,7 +139,6 @@ src_install () {
pkg_config() {
-
einfo ">>> Creating data directory ..."
mkdir -p /var/lib/postgresql/data
chown -Rf postgres.postgres /var/lib/postgresql
@@ -152,5 +151,4 @@ pkg_config() {
else
sudo -u postgres /usr/bin/initdb --pgdata /var/lib/postgresql/data
fi
-
}