summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-03-20 19:19:43 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-03-20 19:19:43 +0000
commit9b7aff06e5a4da60479be1df10bbb785ade54cbe (patch)
treede4fe7307a49275f47770ce5ad56e62c159ae4b7 /dev-db/firebird
parentnew gcc 3.0 compatible bison (diff)
downloadhistorical-9b7aff06e5a4da60479be1df10bbb785ade54cbe.tar.gz
historical-9b7aff06e5a4da60479be1df10bbb785ade54cbe.tar.bz2
historical-9b7aff06e5a4da60479be1df10bbb785ade54cbe.zip
Initial firebird package.
Diffstat (limited to 'dev-db/firebird')
-rw-r--r--dev-db/firebird/ChangeLog10
-rw-r--r--dev-db/firebird/files/digest-firebird-1.02
-rw-r--r--dev-db/firebird/firebird-1.0.ebuild49
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-db/firebird/ChangeLog b/dev-db/firebird/ChangeLog
new file mode 100644
index 000000000000..39a9614cf1e9
--- /dev/null
+++ b/dev-db/firebird/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lang/sather
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.1 2002/03/20 19:19:43 gbevin Exp $
+
+*firebird-1.0 (20 Mar 2002)
+
+ 20 Mar 2002; G.Bevin <gbevin@gentoo.org> firebird-1.0.ebuild
+ files/firebird-1.0:
+
+ Initial package for the firebird database.
diff --git a/dev-db/firebird/files/digest-firebird-1.0 b/dev-db/firebird/files/digest-firebird-1.0
new file mode 100644
index 000000000000..12dfb208bcd3
--- /dev/null
+++ b/dev-db/firebird/files/digest-firebird-1.0
@@ -0,0 +1,2 @@
+MD5 53bfebb4a269eb0f3c508587a843ddf8 Firebird-1.0.0.796.src.tar.gz 6760598
+MD5 281f10057da7e255a49e296bbc3d9c70 FirebirdCS-1.0.0.796-0.tar.gz 2642252
diff --git a/dev-db/firebird/firebird-1.0.ebuild b/dev-db/firebird/firebird-1.0.ebuild
new file mode 100644
index 000000000000..d0cb41035a1e
--- /dev/null
+++ b/dev-db/firebird/firebird-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Geert Bevin <gbevin@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.0.ebuild,v 1.1 2002/03/20 19:19:43 gbevin Exp $
+
+S=${WORKDIR}/firebird-1.0.0.796
+
+DESCRIPTION="Firebird is a relational database offering many ANSI SQL-92 features that runs on Linux, Windows, and a variety of Unix platforms. Firebird offers excellent concurrency, high performance, and powerful language support for stored procedures and triggers. It has been used in production systems, under a variety of names since 1981."
+SRC_URI="http://prdownloads.sourceforge.net/firebird/FirebirdCS-1.0.0.796-0.tar.gz
+ http://prdownloads.sourceforge.net/firebird/Firebird-1.0.0.796.src.tar.gz"
+
+HOMEPAGE="http://firebird.sourceforge.net/"
+
+DEPEND="sys-apps/bash
+ app-arch/zip
+ >=sys-devel/gcc-2.95.3-r5"
+
+src_unpack() {
+ unpack FirebirdCS-1.0.0.796-0.tar.gz
+ cd ${WORKDIR}
+ unpack Firebird-1.0.0.796.src.tar.gz
+ cd ${WORKDIR}/FirebirdCS-1.0.0.796-0
+ tar xzf buildroot.tar.gz
+
+ cd ${S}
+ cp builds/original/build_kit builds/original/build_kit_orig
+ sed "s#LD_LIBRARY_PATH=\$CURDIR/jrd:\$CURDIR/interbase/lib#LD_LIBRARY_PATH=\$CURDIR/jrd:\$CURDIR/interbase/lib:\$INTERBASE/lib#" \
+ builds/original/build_kit_orig > builds/original/build_kit
+}
+
+src_compile() {
+ export INTERBASE="${WORKDIR}/FirebirdCS-1.0.0.796-0/opt/interbase/"
+ export LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$INTERBASE/lib"
+ export FIREBIRD_64_BIT_IO="1"
+ export NOPROMPT_SETUP="1"
+ ./Configure.sh PROD || die
+ cd ${S}/interbase/lib
+ ln -s gds.so libgds.so
+ cd ${S}
+ source Configure_SetupEnv.sh
+ make LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$INTERBASE/lib" firebird || die
+ make classicpackages || die
+}
+
+src_install () {
+ dodoc README
+ cd ${D}
+ tar xzpf ${S}/FirebirdCS-1.0.0.796-0.64IO/buildroot.tar.gz
+}