summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-27 18:50:52 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-27 18:50:52 +0000
commitffc313977daf8aee1d1ea61439f6d18c64da8069 (patch)
tree0f8bd706d08c1c5971fa319d288cad245600dc23 /dev-cpp/luabind/luabind-0.9.1.ebuild
parentremove libmikmod and alsaequal with abi_x86_32 and depend on their multilib m... (diff)
downloadhistorical-ffc313977daf8aee1d1ea61439f6d18c64da8069.tar.gz
historical-ffc313977daf8aee1d1ea61439f6d18c64da8069.tar.bz2
historical-ffc313977daf8aee1d1ea61439f6d18c64da8069.zip
fix build with dev-util/boost-build-1.49.0 wrt #475014
Package-Manager: portage-2.2.0_alpha185/cvs/Linux x86_64 Manifest-Sign-Key: 0xE73C35B3
Diffstat (limited to 'dev-cpp/luabind/luabind-0.9.1.ebuild')
-rw-r--r--dev-cpp/luabind/luabind-0.9.1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-cpp/luabind/luabind-0.9.1.ebuild b/dev-cpp/luabind/luabind-0.9.1.ebuild
index 7e5b1e9a1809..cbfa2f5b6732 100644
--- a/dev-cpp/luabind/luabind-0.9.1.ebuild
+++ b/dev-cpp/luabind/luabind-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/luabind-0.9.1.ebuild,v 1.3 2013/05/04 10:38:34 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/luabind/luabind-0.9.1.ebuild,v 1.4 2013/06/27 18:50:48 hasufell Exp $
# NOTE: cross compiling is probably broken
@@ -24,11 +24,18 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-boost.patch
+
+ # backwardscomapt with old boost-build-1.49.0
+ if [[ -e $(which bjam-1_49 2>/dev/null) ]] ; then
+ my_bjam_bin=bjam-1_49
+ else
+ my_bjam_bin=bjam
+ fi
}
src_compile() {
# linkflags get appended, so they actually do nothing
- bjam release \
+ ${my_bjam_bin} release \
-d+2 \
--prefix="${D}/usr/" \
--libdir="${D}/usr/$(get_libdir)" \
@@ -38,7 +45,7 @@ src_compile() {
}
src_install() {
- bjam release \
+ ${my_bjam_bin} release \
-d+2 \
--prefix="${D}/usr/" \
--libdir="${D}/usr/$(get_libdir)" \