summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2014-12-27 16:26:27 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2014-12-27 16:26:27 +0000
commitb8ee7f44e54ecc39fc64c14a2c22991cb5bd1dfe (patch)
treec4c794e2abb34ce7d75b7bf756fa63e00353f4c5 /dev-cpp/libcmis/libcmis-9999.ebuild
parentAdd missing dependency for eautoreconf, bug #533682. (diff)
downloadhistorical-b8ee7f44e54ecc39fc64c14a2c22991cb5bd1dfe.tar.gz
historical-b8ee7f44e54ecc39fc64c14a2c22991cb5bd1dfe.tar.bz2
historical-b8ee7f44e54ecc39fc64c14a2c22991cb5bd1dfe.zip
Version bump by Andreas Sturmlechner, bug 533140
Package-Manager: portage-2.2.15/cvs/Linux x86_64 Manifest-Sign-Key: 0x84AD142F
Diffstat (limited to 'dev-cpp/libcmis/libcmis-9999.ebuild')
-rw-r--r--dev-cpp/libcmis/libcmis-9999.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-cpp/libcmis/libcmis-9999.ebuild b/dev-cpp/libcmis/libcmis-9999.ebuild
index 871840d15668..9f62536421df 100644
--- a/dev-cpp/libcmis/libcmis-9999.ebuild
+++ b/dev-cpp/libcmis/libcmis-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.12 2013/08/09 08:51:25 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libcmis/libcmis-9999.ebuild,v 1.13 2014/12/27 16:26:20 dilfridge Exp $
EAPI=5
-EGIT_REPO_URI="git://gitorious.org/libcmis/libcmis.git"
-[[ ${PV} == 9999 ]] && SCM_ECLASS="git-2"
+EGIT_REPO_URI="git://git.code.sf.net/p/libcmis/code"
+[[ ${PV} == 9999 ]] && SCM_ECLASS="git-r3"
inherit eutils alternatives autotools ${SCM_ECLASS}
unset SCM_ECLASS
@@ -14,7 +14,7 @@ HOMEPAGE="https://sourceforge.net/projects/libcmis/"
[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="|| ( GPL-2 LGPL-2 MPL-1.1 )"
-SLOT="0.4"
+SLOT="0.5"
# Don't move KEYWORDS on the previous line or ekeyword won't work # 399061
[[ ${PV} == 9999 ]] || \
@@ -34,7 +34,10 @@ DEPEND="${RDEPEND}
app-text/docbook2X
dev-libs/libxslt
)
- test? ( dev-util/cppunit )
+ test? (
+ dev-util/cppcheck
+ dev-util/cppunit
+ )
"
src_prepare() {
@@ -49,7 +52,6 @@ src_configure() {
$(use_with man) \
$(use_enable static-libs static) \
$(use_enable test tests) \
- --disable-long-tests \
--enable-client
}