summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2003-11-20 03:33:42 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2003-11-20 03:33:42 +0000
commit081c07feb30e622d4415acd296fa26059c65a835 (patch)
tree0023ed190c541c97691148e0499189f93b63681a /app-vim
parentinitial version (diff)
downloadhistorical-081c07feb30e622d4415acd296fa26059c65a835.tar.gz
historical-081c07feb30e622d4415acd296fa26059c65a835.tar.bz2
historical-081c07feb30e622d4415acd296fa26059c65a835.zip
initial version
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimcommander/Manifest4
-rw-r--r--app-vim/vimcommander/files/digest-vimcommander-1.521
-rw-r--r--app-vim/vimcommander/metadata.xml9
-rw-r--r--app-vim/vimcommander/vimcommander-1.52.ebuild30
4 files changed, 43 insertions, 1 deletions
diff --git a/app-vim/vimcommander/Manifest b/app-vim/vimcommander/Manifest
index eee334544020..f2c4df3e64d8 100644
--- a/app-vim/vimcommander/Manifest
+++ b/app-vim/vimcommander/Manifest
@@ -1,2 +1,4 @@
-MD5 16faaec746396227f2350b461d564fce vimcommander-1.52.ebuild 943
+MD5 1da72174c81895f2d8568af2a54c3d71 vimcommander-1.52.ebuild 1064
+MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
+MD5 b110b95535b83a6c2650537ddd262eda ChangeLog 370
MD5 9331dceeec76a6e442a160e310679f07 files/digest-vimcommander-1.52 68
diff --git a/app-vim/vimcommander/files/digest-vimcommander-1.52 b/app-vim/vimcommander/files/digest-vimcommander-1.52
new file mode 100644
index 000000000000..823050606ecf
--- /dev/null
+++ b/app-vim/vimcommander/files/digest-vimcommander-1.52
@@ -0,0 +1 @@
+MD5 d582af0e1ce3e3ba6ac81b4733f2f07d vimcommander-1.52.tar.bz2 8585
diff --git a/app-vim/vimcommander/metadata.xml b/app-vim/vimcommander/metadata.xml
new file mode 100644
index 000000000000..3a147a175714
--- /dev/null
+++ b/app-vim/vimcommander/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+<maintainer>
+ <email>ciaranm@gentoo.org</email>
+ <name>Ciaran McCreesh</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-vim/vimcommander/vimcommander-1.52.ebuild b/app-vim/vimcommander/vimcommander-1.52.ebuild
new file mode 100644
index 000000000000..460f31def1e8
--- /dev/null
+++ b/app-vim/vimcommander/vimcommander-1.52.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/vimcommander/vimcommander-1.52.ebuild,v 1.1 2003/11/20 03:33:37 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Total Commander style file explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=808"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~sparc ~x86"
+
+function src_unpack() {
+ unpack ${A}
+ mkdir ${S}/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic documentation install' trick. This
+ # causes problems for us during the unmerge. Fortunately, sed can fix
+ # this for us.
+ sed -e '1,/^=== START_DOC$/d' \
+ -e '/^=== END_DOC/,$d' \
+ -e "s/#version#/v${PV}/" \
+ ${S}/plugin/vimcommander.vim > ${S}/doc/vimcommander.txt \
+ || die "help extraction failed"
+
+ echo -ne "\n\n vim:tw=78:ts=8:ft=help:norl:" >> ${S}/doc/vimcommander.txt
+
+ sed -i -e 's/" \(let b:vimcommander_install_doc=\)1/\10/' \
+ ${S}/plugin/vimcommander.vim \
+ || die "help extract disable failed"
+}