summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2011-06-25 07:43:34 +0000
committerSerkan Kaba <serkan@gentoo.org>2011-06-25 07:43:34 +0000
commit059e0558dce2a96291c17dfea5e56e92d59e6bff (patch)
tree2d9c793c6ce54fd62856a1f8a301d06abb6ae9d4 /app-text/zpspell
parentFix firefox dep for rename from mozilla-firefox. (diff)
downloadhistorical-059e0558dce2a96291c17dfea5e56e92d59e6bff.tar.gz
historical-059e0558dce2a96291c17dfea5e56e92d59e6bff.tar.bz2
historical-059e0558dce2a96291c17dfea5e56e92d59e6bff.zip
Add Pardus patch to fix bug #369651 and fix dependency wrt bug #372477.
Package-Manager: portage-2.2.0_alpha37/cvs/Linux x86_64
Diffstat (limited to 'app-text/zpspell')
-rw-r--r--app-text/zpspell/ChangeLog8
-rw-r--r--app-text/zpspell/files/add-gobject-linkage-11566.diff11
-rw-r--r--app-text/zpspell/zpspell-0.4.3.ebuild12
3 files changed, 26 insertions, 5 deletions
diff --git a/app-text/zpspell/ChangeLog b/app-text/zpspell/ChangeLog
index 6f645eadc3f7..4e3da47d2b8c 100644
--- a/app-text/zpspell/ChangeLog
+++ b/app-text/zpspell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/zpspell
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/zpspell/ChangeLog,v 1.3 2009/05/07 21:04:41 serkan Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/zpspell/ChangeLog,v 1.4 2011/06/25 07:43:34 serkan Exp $
+
+ 25 Jun 2011; Serkan Kaba <serkan@gentoo.org> zpspell-0.4.3.ebuild,
+ +files/add-gobject-linkage-11566.diff:
+ Add Pardus patch to fix bug #369651 and fix dependency wrt bug #372477.
*zpspell-0.4.3 (07 May 2009)
diff --git a/app-text/zpspell/files/add-gobject-linkage-11566.diff b/app-text/zpspell/files/add-gobject-linkage-11566.diff
new file mode 100644
index 000000000000..250fb90ebca9
--- /dev/null
+++ b/app-text/zpspell/files/add-gobject-linkage-11566.diff
@@ -0,0 +1,11 @@
+Index: zpspell-0.4.3/CMakeLists.txt
+===================================================================
+--- zpspell-0.4.3.orig/CMakeLists.txt
++++ zpspell-0.4.3/CMakeLists.txt
+@@ -101,5 +101,5 @@ include_directories(${DBUS_INCLUDE_DIR})
+ include_directories(${GLIB2_INCLUDE_DIR})
+ include_directories(${GLIB_CONFIG_DIR})
+
+-target_link_libraries(zpspell glib-2.0 dbus-glib-1)
++target_link_libraries(zpspell glib-2.0 dbus-glib-1 gobject-2.0)
+
diff --git a/app-text/zpspell/zpspell-0.4.3.ebuild b/app-text/zpspell/zpspell-0.4.3.ebuild
index 9cebda38731e..e2bd408ec343 100644
--- a/app-text/zpspell/zpspell-0.4.3.ebuild
+++ b/app-text/zpspell/zpspell-0.4.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/zpspell/zpspell-0.4.3.ebuild,v 1.1 2009/05/07 21:04:41 serkan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/zpspell/zpspell-0.4.3.ebuild,v 1.2 2011/06/25 07:43:34 serkan Exp $
inherit cmake-utils
@@ -13,7 +13,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="app-text/zemberek-server"
+DEPEND="dev-libs/dbus-glib"
+RDEPEND="${DEPEND}
+ app-text/zemberek-server"
+
+src_prepare() {
+ epatch "${FILESDIR}"/add-gobject-linkage-11566.diff
+}
src_install() {
cmake-utils_src_install