summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-08-10 17:24:25 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-08-10 17:24:25 +0000
commite1c305da3cfd45d6a5a397eb35dff9ec288d0b6b (patch)
treeb108c54221ca8421b48191b036a231113f6878c7 /app-text/pdftk/pdftk-2.02.ebuild
parentAdd blockers on emul-libs so that it is stacked for baselibs r10 (diff)
downloadhistorical-e1c305da3cfd45d6a5a397eb35dff9ec288d0b6b.tar.gz
historical-e1c305da3cfd45d6a5a397eb35dff9ec288d0b6b.tar.bz2
historical-e1c305da3cfd45d6a5a397eb35dff9ec288d0b6b.zip
Version bump to 2.02. Fixes bug #450080, reported by Adam Randall, 7v5w7go9ub0o and Jeroen Roovers; applied patch by Ondrej Grover with small fixes to make it work with 2.02 instead of 2.01 as well as to not turn warnings into errors to avoid breakage without purpose.
Package-Manager: portage-2.1.13.7/cvs/Linux x86_64 Manifest-Sign-Key: 0x6D34E57D
Diffstat (limited to 'app-text/pdftk/pdftk-2.02.ebuild')
-rw-r--r--app-text/pdftk/pdftk-2.02.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/pdftk/pdftk-2.02.ebuild b/app-text/pdftk/pdftk-2.02.ebuild
new file mode 100644
index 000000000000..75361b465c1a
--- /dev/null
+++ b/app-text/pdftk/pdftk-2.02.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdftk/pdftk-2.02.ebuild,v 1.1 2013/08/10 17:24:20 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="A tool for manipulating PDF documents"
+HOMEPAGE="http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/"
+SRC_URI="http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/${P}-src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux"
+
+DEPEND="sys-devel/gcc[gcj]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}-dist/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-flags.patch
+}
+
+src_compile() {
+ # Settings by java-config break compilation by gcj.
+ unset CLASSPATH
+ unset JAVA_HOME
+
+ # Parallel make fails; confirmed, still not fixed in version 2.02.
+ emake -j1 -f "${S}"/Makefile.Debian || die "Compilation failed."
+}
+
+src_install() {
+ dobin pdftk
+ doman ../pdftk.1
+ dohtml ../pdftk.1.html
+}