summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-02-21 15:25:51 +0000
committerMamoru Komachi <usata@gentoo.org>2004-02-21 15:25:51 +0000
commit832a23118c93779651c9b37a8eb4dbfe8c1be217 (patch)
tree4c60b48580e961b75ec87abd1fa56ddbed81a746 /app-text/pdf2html/pdf2html-1.4.ebuild
parentmarked stable on x86. (diff)
downloadhistorical-832a23118c93779651c9b37a8eb4dbfe8c1be217.tar.gz
historical-832a23118c93779651c9b37a8eb4dbfe8c1be217.tar.bz2
historical-832a23118c93779651c9b37a8eb4dbfe8c1be217.zip
Initial import. Ebuild submitted by Victor Iggy <lamer0@lamer0.com>, closing bug #15980
Diffstat (limited to 'app-text/pdf2html/pdf2html-1.4.ebuild')
-rw-r--r--app-text/pdf2html/pdf2html-1.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/pdf2html/pdf2html-1.4.ebuild b/app-text/pdf2html/pdf2html-1.4.ebuild
new file mode 100644
index 000000000000..c57a5c522064
--- /dev/null
+++ b/app-text/pdf2html/pdf2html-1.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdf2html/pdf2html-1.4.ebuild,v 1.1 2004/02/21 15:25:51 usata Exp $
+
+SLOT="0"
+
+DESCRIPTION="Converts pdf files to html files"
+SRC_URI="ftp://atrey.karlin.mff.cuni.cz/pub/local/clock/pdf2html/${P}.tgz"
+HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/pdf2html/"
+
+KEYWORDS="~x86 -alpha"
+LICENSE="GPL-2"
+DEPEND=">=media-libs/libpng-1.2.5
+ >=app-text/ghostscript-7.05.5
+ >=sys-libs/zlib-1.1.4
+ >=media-gfx/imagemagick-5.4.9"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "Compile has failed"
+ echo "cp /usr/share/${P}/*.png ." >> pdf2html
+}
+
+src_install() {
+ dobin pbm2png pbm2eps9 pdf2html ps2eps9 || die "install failed"
+
+ insinto /usr/share/${P}
+ doins *.png *.html
+
+ dodoc CHANGELOG INSTALL README VERSION || die "install failed"
+}