summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-04-28 22:41:33 +0000
committerTravis Tilley <lv@gentoo.org>2004-04-28 22:41:33 +0000
commit071712571081b3364dac2744a9fef3f948ee7721 (patch)
tree17b6b5680ac1a7a1306863d3abbc46bbca92bc93 /app-text/ghostscript
parentarm KEYWORD (diff)
downloadhistorical-071712571081b3364dac2744a9fef3f948ee7721.tar.gz
historical-071712571081b3364dac2744a9fef3f948ee7721.tar.bz2
historical-071712571081b3364dac2744a9fef3f948ee7721.zip
replace -O3 with -O2 if compiling with gcc 3.4
Diffstat (limited to 'app-text/ghostscript')
-rw-r--r--app-text/ghostscript/ChangeLog6
-rw-r--r--app-text/ghostscript/Manifest6
-rw-r--r--app-text/ghostscript/ghostscript-7.07.1-r1.ebuild11
-rw-r--r--app-text/ghostscript/ghostscript-7.07.1-r2.ebuild11
4 files changed, 26 insertions, 8 deletions
diff --git a/app-text/ghostscript/ChangeLog b/app-text/ghostscript/ChangeLog
index 5a566aaeac44..4c2006b6456f 100644
--- a/app-text/ghostscript/ChangeLog
+++ b/app-text/ghostscript/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/ghostscript
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ChangeLog,v 1.48 2004/04/28 10:57:47 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ChangeLog,v 1.49 2004/04/28 22:41:33 lv Exp $
+
+ 28 Apr 2004; Travis Tilley <lv@gentoo.org> ghostscript-7.07.1-r1.ebuild,
+ ghostscript-7.07.1-r2.ebuild:
+ replace -O3 with -O2 if compiling with gcc 3.4
28 Apr 2004; Heinrich Wendel <lanius@gentoo.org>
ghostscript-7.07.1-r2.ebuild:
diff --git a/app-text/ghostscript/Manifest b/app-text/ghostscript/Manifest
index 03a3f55ac866..9e02ff2dbe3c 100644
--- a/app-text/ghostscript/Manifest
+++ b/app-text/ghostscript/Manifest
@@ -1,6 +1,6 @@
-MD5 c918f0a2177a5f25017a5e7b48d64059 ghostscript-7.07.1-r2.ebuild 3008
-MD5 a2ab549a395db6256c7cfcd165f27f7c ghostscript-7.07.1-r1.ebuild 2903
-MD5 09ae0eaa4fabf065afa31f7b8d34fe6c ChangeLog 8487
+MD5 b180bf0913036824932a4a8db6f2c9af ghostscript-7.07.1-r2.ebuild 3194
+MD5 d87ad985f87e22290b9a4ff6cd04a909 ghostscript-7.07.1-r1.ebuild 3087
+MD5 ac8665882d6f472b89304ab110a0a12a ChangeLog 8640
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 5f1b04ca58928a339b749703e067e2ba files/gs7.05.6-kochi-substitute.patch 3774
MD5 acda8ddfde1efeaf451cb28a67dcc773 files/gs7.07.1-krgb.patch.gz 5569
diff --git a/app-text/ghostscript/ghostscript-7.07.1-r1.ebuild b/app-text/ghostscript/ghostscript-7.07.1-r1.ebuild
index 0b2a7cc79809..9aab325656b2 100644
--- a/app-text/ghostscript/ghostscript-7.07.1-r1.ebuild
+++ b/app-text/ghostscript/ghostscript-7.07.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.07.1-r1.ebuild,v 1.5 2004/04/26 16:25:27 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.07.1-r1.ebuild,v 1.6 2004/04/28 22:41:33 lv Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="ESP Ghostscript -- an enhanced version of GNU Ghostscript with better printer support"
HOMEPAGE="http://www.cups.org/ghostscript.php"
@@ -69,6 +69,13 @@ src_compile() {
use cups && myconf="${myconf} --enable-cups" \
|| myconf="${myconf} --disable-cups"
+ # -O3 will make ghostscript fail when compiling with gcc 3.4
+ if [ "`gcc-major-version`" -eq "3" ] && [ "`gcc-minor-version`" -eq "4" ]
+ then
+ strip-flags
+ replace-flags -O? -O2
+ fi
+
econf ${myconf} || die "econf failed"
make || die "make failed"
diff --git a/app-text/ghostscript/ghostscript-7.07.1-r2.ebuild b/app-text/ghostscript/ghostscript-7.07.1-r2.ebuild
index d899e72f489a..cce2f3f9d18a 100644
--- a/app-text/ghostscript/ghostscript-7.07.1-r2.ebuild
+++ b/app-text/ghostscript/ghostscript-7.07.1-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.07.1-r2.ebuild,v 1.3 2004/04/28 10:57:47 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript/ghostscript-7.07.1-r2.ebuild,v 1.4 2004/04/28 22:41:33 lv Exp $
-inherit eutils
+inherit eutils gcc
DESCRIPTION="ESP Ghostscript -- an enhanced version of GNU Ghostscript with better printer support"
HOMEPAGE="http://www.cups.org/ghostscript.php"
@@ -73,6 +73,13 @@ src_compile() {
use cups && myconf="${myconf} --enable-cups" \
|| myconf="${myconf} --disable-cups"
+ # -O3 will make ghostscript fail when compiling with gcc 3.4
+ if [ "`gcc-major-version`" -eq "3" ] && [ "`gcc-minor-version`" -eq "4" ]
+ then
+ strip-flags
+ replace-flags -O? -O2
+ fi
+
econf ${myconf} || die "econf failed"
make || die "make failed"