summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-08 19:26:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-08 19:26:12 +0000
commit4004d39e599c4b47c04b8c3e26a23e1df056e07a (patch)
treec527dc49a57815231c05e715de673dfb23178f47 /app-text/duali
parentStable for HPPA (bug #308201). (diff)
downloadhistorical-4004d39e599c4b47c04b8c3e26a23e1df056e07a.tar.gz
historical-4004d39e599c4b47c04b8c3e26a23e1df056e07a.tar.bz2
historical-4004d39e599c4b47c04b8c3e26a23e1df056e07a.zip
Set SUPPORT_PYTHON_ABIS (bug #312099).
Package-Manager: portage-HEAD/cvs/Linux x86_64
Diffstat (limited to 'app-text/duali')
-rw-r--r--app-text/duali/ChangeLog8
-rw-r--r--app-text/duali/duali-0.2.0.ebuild38
2 files changed, 33 insertions, 13 deletions
diff --git a/app-text/duali/ChangeLog b/app-text/duali/ChangeLog
index c772b4cfa777..fb4e19f91046 100644
--- a/app-text/duali/ChangeLog
+++ b/app-text/duali/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/duali
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/duali/ChangeLog,v 1.13 2007/01/30 01:03:46 caster Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/duali/ChangeLog,v 1.14 2010/04/08 19:26:12 arfrever Exp $
+
+ 08 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ duali-0.2.0.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #312099).
30 Jan 2007; Vlastimil Babka <caster@gentoo.org> ChangeLog:
Fix manifest.
diff --git a/app-text/duali/duali-0.2.0.ebuild b/app-text/duali/duali-0.2.0.ebuild
index 165e9b572769..ccf97d9d9c4c 100644
--- a/app-text/duali/duali-0.2.0.ebuild
+++ b/app-text/duali/duali-0.2.0.ebuild
@@ -1,32 +1,48 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/duali/duali-0.2.0.ebuild,v 1.1 2007/01/22 20:04:01 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/duali/duali-0.2.0.ebuild,v 1.2 2010/04/08 19:26:12 arfrever Exp $
-inherit distutils
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
-IUSE=""
+inherit python
DESCRIPTION="Arabic dictionary based on the DICT protocol"
HOMEPAGE="http://www.arabeyes.org/project.php?proj=Duali"
SRC_URI="mirror://sourceforge/arabeyes/${P}.tar.bz2"
-SLOT="0"
LICENSE="as-is"
-KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~sparc ~alpha ~hppa ~mips"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
-DEPEND="dev-lang/python"
+DEPEND=""
PDEPEND="app-dicts/duali-data"
+RESTRICT_PYTHON_ABIS="3.*"
src_install() {
- into /usr
dobin duali dict2db trans2arabic arabic2trans
+ python_convert_shebangs -r 2 "${ED}usr/bin"
+
insinto /etc
doins duali.conf
+
doman doc/man/*
- distutils_python_version
- insinto /usr/lib/python${PYVER}/site-packages/pyduali
- doins pyduali/*.py
+ installation() {
+ insinto $(python_get_sitedir)/pyduali
+ doins pyduali/*.py
+ }
+ python_execute_function installation
dodoc README ChangeLog INSTALL MANIFEST
}
+
+pkg_postinst() {
+ python_mod_optimize pyduali
+}
+
+pkg_postrm() {
+ python_mod_cleanup pyduali
+}