summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-29 08:38:39 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-29 08:38:39 +0000
commit901c44755acb2f51a111879209c86a68c8078e9a (patch)
treeec7feb110b629f440fc6f64ab2dc0c40eba2fcc1 /app-text/dictd/dictd-1.12.1.ebuild
parentBump (diff)
downloadhistorical-901c44755acb2f51a111879209c86a68c8078e9a.tar.gz
historical-901c44755acb2f51a111879209c86a68c8078e9a.tar.bz2
historical-901c44755acb2f51a111879209c86a68c8078e9a.zip
Bump
Package-Manager: portage-2.2.0_alpha161/cvs/Linux x86_64
Diffstat (limited to 'app-text/dictd/dictd-1.12.1.ebuild')
-rw-r--r--app-text/dictd/dictd-1.12.1.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/app-text/dictd/dictd-1.12.1.ebuild b/app-text/dictd/dictd-1.12.1.ebuild
new file mode 100644
index 000000000000..4b75e297d7d6
--- /dev/null
+++ b/app-text/dictd/dictd-1.12.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dictd/dictd-1.12.1.ebuild,v 1.1 2013/01/29 08:38:29 patrick Exp $
+
+EAPI="4"
+
+inherit eutils user
+
+DESCRIPTION="Dictionary Client/Server for the DICT protocol"
+HOMEPAGE="http://www.dict.org/ http://sourceforge.net/projects/dict/"
+SRC_URI="mirror://sourceforge/dict/${P}.tar.gz"
+
+SLOT="0"
+# We install rfc so - ISOC-rfc
+LICENSE="GPL-2 ISOC-rfc"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="dbi judy minimal"
+
+# <gawk-3.1.6 makes tests fail.
+RDEPEND="sys-apps/coreutils
+ sys-libs/zlib
+ dev-libs/libmaa
+ dbi? ( dev-db/libdbi )
+ judy? ( dev-libs/judy )
+ >=sys-apps/coreutils-6.10"
+DEPEND="${RDEPEND}
+ >=sys-apps/gawk-3.1.6
+ virtual/yacc"
+
+pkg_setup() {
+ enewgroup dictd # used in src_test()
+ enewuser dictd -1 -1 -1 dictd
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/dictd-1.10.11-colorit-nopp-fix.patch
+ epatch "${FILESDIR}"/dictd-1.12.0-build.patch
+
+ [[ ${CHOST} == *-darwin* ]] && \
+ sed -i -e 's:libtool:glibtool:g' Makefile.in
+}
+
+src_configure() {
+ econf \
+ $(use_with dbi plugin-dbi) \
+ $(use_with judy plugin-judy) \
+ --sysconfdir="${EPREFIX}"/etc/dict
+}
+
+src_compile() {
+ if use minimal; then
+ emake dictfmt dictzip dictzip
+ else
+ emake
+ fi
+}
+
+src_test() {
+ use minimal && return 0 # All tests are for dictd which we don't build...
+ if [[ ${EUID} -eq 0 ]]; then
+ # If dictd is run as root user (-userpriv) it drops its privileges to
+ # dictd user and group. Give dictd group write access to test directory.
+ chown :dictd "${WORKDIR}" "${S}/test"
+ chmod 770 "${WORKDIR}" "${S}/test"
+ fi
+ emake test
+}
+
+src_install() {
+ if use minimal; then
+ emake DESTDIR="${D}" install.dictzip install.dict install.dictfmt
+ else
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{dicf.ms,rfc.ms,rfc.sh,rfc2229.txt}
+ dodoc doc/{security.doc,toc.ms}
+
+ # conf files. For dict.conf see below.
+ insinto /etc/dict
+ for f in dictd.conf site.info colorit.conf; do
+ doins "${FILESDIR}/1.10.11/${f}"
+ done
+
+ # startups for dictd
+ newinitd "${FILESDIR}/1.10.11/dictd.initd" dictd
+ newconfd "${FILESDIR}/1.10.11/dictd.confd" dictd
+ fi
+
+ insinto /etc/dict
+ doins "${FILESDIR}/1.10.11/dict.conf"
+ # Install docs
+ dodoc README TODO ChangeLog ANNOUNCE NEWS
+}
+
+pkg_postinst() {
+ echo
+ elog "To start and use ${PN} you need to emerge at least one dictionary from"
+ elog "the app-dicts category with the package name starting with 'dictd-'."
+ elog "To install all available dictionaries, emerge app-dicts/dictd-dicts."
+ elog "${PN} will NOT start without at least one dictionary."
+ echo
+}