summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-19 23:09:34 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-19 23:09:34 +0000
commit22f40540e794a407e7ec26a12077f59059691a39 (patch)
tree8ea12d339dc13976784f4c30a607d6f8bedb7fce /app-text/a2ps
parent*** empty log message *** (diff)
downloadhistorical-22f40540e794a407e7ec26a12077f59059691a39.tar.gz
historical-22f40540e794a407e7ec26a12077f59059691a39.tar.bz2
historical-22f40540e794a407e7ec26a12077f59059691a39.zip
*** empty log message ***
Diffstat (limited to 'app-text/a2ps')
-rw-r--r--app-text/a2ps/a2ps-4.13b-r3.ebuild51
-rw-r--r--app-text/a2ps/files/digest-a2ps-4.13b-r31
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/a2ps/a2ps-4.13b-r3.ebuild b/app-text/a2ps/a2ps-4.13b-r3.ebuild
new file mode 100644
index 000000000000..ea3fd7ed580b
--- /dev/null
+++ b/app-text/a2ps/a2ps-4.13b-r3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/a2ps/a2ps-4.13b-r3.ebuild,v 1.1 2001/03/19 23:09:34 achim Exp $
+
+P=a2ps-4.13b
+A=${P}.tar.gz
+S=${WORKDIR}/a2ps-4.13
+DESCRIPTION="a2ps is an Any to PostScript filter"
+SRC_URI="ftp://ftp.enst.fr/pub/unix/a2ps/"${A}
+HOMEPAGE="http://www-inf.enst.fr/~demaille/a2ps"
+
+DEPEND="virtual/glibc
+ nls? ( sys-devel/gettext )
+ >=app-text/ghostscript-6.23
+ >=app-text/psutils-1.17
+ >=app-text/tetex-1.0.7"
+
+
+src_compile() {
+
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/a2ps \
+ --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-static \
+ ${myconf}
+
+ try make
+}
+
+src_install() {
+
+ dodir /usr/share/emacs/site-lisp
+
+ try make prefix=${D}/usr sysconfdir=${D}/etc/a2ps \
+ mandir=${D}/usr/share/man infodir=${D}/usr/share/info \
+ lispdir=${D}/usr/share/emacs/site-lisp install
+
+ dodoc ANNOUNCE AUTHORS ChangeLog COPYING FAQ NEWS README THANKS TODO
+
+}
+
+
+
+
+
diff --git a/app-text/a2ps/files/digest-a2ps-4.13b-r3 b/app-text/a2ps/files/digest-a2ps-4.13b-r3
new file mode 100644
index 000000000000..ec015c86df8e
--- /dev/null
+++ b/app-text/a2ps/files/digest-a2ps-4.13b-r3
@@ -0,0 +1 @@
+MD5 0c8e0c31b08c14f7a7198ce967eb3281 a2ps-4.13b.tar.gz