summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-28 13:49:09 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-28 13:49:09 +0000
commita8db1ac8643ea6c381e437a6c3a971676f9b75d2 (patch)
treedce018a3079cb2484c0a7a04f0b85120071e6cc8 /app-shells
parentmaking some dep changes based on bug #58640 (diff)
downloadhistorical-a8db1ac8643ea6c381e437a6c3a971676f9b75d2.tar.gz
historical-a8db1ac8643ea6c381e437a6c3a971676f9b75d2.tar.bz2
historical-a8db1ac8643ea6c381e437a6c3a971676f9b75d2.zip
Bump to version 3.0. All patches from files/ have been either integrated into gentoo patch or dropped appropriately
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog8
-rw-r--r--app-shells/bash/Manifest20
-rw-r--r--app-shells/bash/bash-3.0.ebuild117
-rw-r--r--app-shells/bash/files/digest-bash-3.02
4 files changed, 132 insertions, 15 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index 8c1b6597a36a..b44db3dac61b 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/bash
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.38 2004/07/22 02:30:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.39 2004/07/28 13:49:09 agriffis Exp $
+
+*bash-3.0 (28 Jul 2004)
+
+ 28 Jul 2004; <agriffis@gentoo.org> +bash-3.0.ebuild:
+ Bump to version 3.0. All patches from files/ have been either integrated into
+ gentoo patch or dropped appropriately
*bash-2.05b-r10 (21 Jul 2004)
diff --git a/app-shells/bash/Manifest b/app-shells/bash/Manifest
index b0e295fdfaf0..8b4f53602c70 100644
--- a/app-shells/bash/Manifest
+++ b/app-shells/bash/Manifest
@@ -1,22 +1,14 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 93fe500b526104ddc6b228eb66d3d40f ChangeLog 7924
+MD5 34485244e461175fd29dc3739cc86450 bash-3.0.ebuild 3165
+MD5 59d22d8b43b008b4eefaa51c7a2693b8 ChangeLog 8125
+MD5 9b26b6899167a29ee4e9c1ad0d39b5a1 bash-2.05b-r9.ebuild 2909
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
MD5 6a2f5ace1a2dd30b1bee55eba1509027 bash-2.05b-r10.ebuild 3041
-MD5 9b26b6899167a29ee4e9c1ad0d39b5a1 bash-2.05b-r9.ebuild 2909
+MD5 30a9ff1b688e79f59376a47d882f3419 files/digest-bash-3.0 128
MD5 edf95b873162f4548435c379e4998b4e files/bash-2.05b-empty-herestring.patch 836
MD5 90ba92c981c1d26e45d88ecd23a1fbf5 files/bash-2.05b-multibyte-locale.patch 1897
+MD5 4383b25cd54b24b9f459e338f06d096c files/bash-2.05b-parallel-build.patch 459
MD5 3b905c7c9341c9009bd68f14c047815e files/bash-2.05b-rbash.patch 804
MD5 582fb9ed0ca44627978ce6836a5000dc files/config-top.h.diff 487
-MD5 4383b25cd54b24b9f459e338f06d096c files/bash-2.05b-parallel-build.patch 459
-MD5 92f8f2d44177d92edd757366dbd261dc files/bashrc 761
MD5 1894aaae72806c410d851d046d13dd32 files/digest-bash-2.05b-r9 461
+MD5 92f8f2d44177d92edd757366dbd261dc files/bashrc 761
MD5 1894aaae72806c410d851d046d13dd32 files/digest-bash-2.05b-r10 461
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.9.8 (GNU/Linux)
-
-iD8DBQFBAbywHTu7gpaalycRAr9rAJ9iaXCm/7S8XucPXdFVfvFWWlmt0gCeIn8l
-dRgrnwvOKzRlV9FxqfIGYmI=
-=jVtj
------END PGP SIGNATURE-----
diff --git a/app-shells/bash/bash-3.0.ebuild b/app-shells/bash/bash-3.0.ebuild
new file mode 100644
index 000000000000..f1c01fcf61f0
--- /dev/null
+++ b/app-shells/bash/bash-3.0.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0.ebuild,v 1.1 2004/07/28 13:49:09 agriffis Exp $
+
+inherit eutils flag-o-matic gnuconfig
+
+# Official patches
+#PLEVEL="x002 x003 x004 x005 x006 x007"
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+SRC_URI="mirror://gnu/bash/${P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+# ${PLEVEL//x/mirror://gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="nls build uclibc"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+
+ # Remove autoconf dependency
+ sed -i -e "/&& autoconf/d" Makefile.in
+
+ # Readline is slow with multibyte locale, bug #19762
+ # (No longer applies to bash-3.0)
+ #epatch ${FILESDIR}/${P}-multibyte-locale.patch
+
+ # Segfault on empty herestring
+ # (Fixed in bash-3.0 with STRLEN instead of strlen)
+ #epatch ${FILESDIR}/${P}-empty-herestring.patch
+
+ # Fix broken rbash functionality
+ # (Fixed in bash-3.0)
+ #epatch ${FILESDIR}/${P}-rbash.patch
+
+ # Fix parallel make, bug #41002.
+ # (Added to bash-3.0-gentoo.diff.bz2)
+ #epatch ${FILESDIR}/${P}-parallel-build.patch
+
+ # Enable SSH_SOURCE_BASHRC (#24762)
+ echo '#define SSH_SOURCE_BASHRC' >> config-top.h
+
+ # Enable system-wide bashrc (#26952)
+ echo '#define SYS_BASHRC "/etc/bash/bashrc"' >> config-top.h
+
+ # Force pgrp synchronization
+ # (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653)
+ #
+ # The session will hang cases where you 'su' (not 'su -') and
+ # then run a piped command in emacs.
+ # This problem seem to happen due to scheduler changes kernel
+ # side - although reproduceble with later 2.4 kernels, it is
+ # especially easy with 2.6 kernels.
+ echo '#define PGRP_PIPE 1' >> config-bot.h
+
+ gnuconfig_update
+}
+
+src_compile() {
+ filter-flags -malign-double
+
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to use with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --disable-profiling \
+ --with-curses \
+ --without-gnu-malloc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+ dosym bash /bin/rbash
+
+ use uclibc && rm -f ${D}/usr/bin/bashbug ${D}/usr/share/man*/bashbug*
+
+ insinto /etc/bash
+ doins ${FILESDIR}/bashrc
+
+ if use build; then
+ rm -rf ${D}/usr
+ else
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K
+ dodoc doc/FAQ doc/INTRO
+
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
+ fi
+}
diff --git a/app-shells/bash/files/digest-bash-3.0 b/app-shells/bash/files/digest-bash-3.0
new file mode 100644
index 000000000000..b3fb57628169
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-3.0
@@ -0,0 +1,2 @@
+MD5 26c4d642e29b3533d8d754995bc277b3 bash-3.0.tar.gz 2418293
+MD5 220cdd45dc060fd41c2bd7c46e8a9064 bash-3.0-gentoo.diff.bz2 2423