summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-19 15:57:12 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-19 15:57:12 +0000
commit54b229fe4482e32afac9411987e58face24c68b0 (patch)
treee746f8d26bf883eda21e34ae8108395b3b2fd431 /app-shells/dash
parentMarked ppc stable for bug #179092. (diff)
downloadhistorical-54b229fe4482e32afac9411987e58face24c68b0.tar.gz
historical-54b229fe4482e32afac9411987e58face24c68b0.tar.bz2
historical-54b229fe4482e32afac9411987e58face24c68b0.zip
libedit and static USE flags now work together
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'app-shells/dash')
-rw-r--r--app-shells/dash/Manifest8
-rw-r--r--app-shells/dash/dash-0.5.3.7-r1.ebuild16
2 files changed, 9 insertions, 15 deletions
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
index d3676f22de77..1f83c2722508 100644
--- a/app-shells/dash/Manifest
+++ b/app-shells/dash/Manifest
@@ -29,10 +29,10 @@ EBUILD dash-0.5.3.3.ebuild 1099 RMD160 8bb384391ceeb2d7fbaa80b2dc8e7c855d669d7e
MD5 a65294aad870440d0f30eb87b11f27e7 dash-0.5.3.3.ebuild 1099
RMD160 8bb384391ceeb2d7fbaa80b2dc8e7c855d669d7e dash-0.5.3.3.ebuild 1099
SHA256 127bc18ab2e3cd02dac31013f7dd82efc79bb0f85b63d35387d6b88356f9a93a dash-0.5.3.3.ebuild 1099
-EBUILD dash-0.5.3.7-r1.ebuild 1854 RMD160 ca7579d5a51a45c7bad75bca090373b22860a06d SHA1 cbd934b4f031ced8ad291337db4d01f43c46e3cd SHA256 1efd2376c36192c6f47adae13b616f49d73330b0c48d0877d63d12258a9fc7ab
-MD5 88a0cc72fea3ef6b333cb366ce7a06d0 dash-0.5.3.7-r1.ebuild 1854
-RMD160 ca7579d5a51a45c7bad75bca090373b22860a06d dash-0.5.3.7-r1.ebuild 1854
-SHA256 1efd2376c36192c6f47adae13b616f49d73330b0c48d0877d63d12258a9fc7ab dash-0.5.3.7-r1.ebuild 1854
+EBUILD dash-0.5.3.7-r1.ebuild 1744 RMD160 d58f1888d3fccc2125c21b6314ebee0bb6a01bfb SHA1 d7d0f4e6fc8d2ed11a11afbbd6be20d047060a24 SHA256 84a80924db9db22722d6a340e7aff244a44c5dbdcd4144753e319af0dd153736
+MD5 25cd19853f112f3afe302a9197d677a7 dash-0.5.3.7-r1.ebuild 1744
+RMD160 d58f1888d3fccc2125c21b6314ebee0bb6a01bfb dash-0.5.3.7-r1.ebuild 1744
+SHA256 84a80924db9db22722d6a340e7aff244a44c5dbdcd4144753e319af0dd153736 dash-0.5.3.7-r1.ebuild 1744
EBUILD dash-0.5.3.7.ebuild 1230 RMD160 d9d973b11b38ddbeb29cdb463c82c33a0e8f6534 SHA1 dc3a4fd8fac81d846d323da9896ec86c65d772cf SHA256 a5ae13b2005b90bfd0ab6271ec1142b1073c7b21b434b4732df06a99005145e0
MD5 b9f21e4963bafc797dc3bd18f3845fc7 dash-0.5.3.7.ebuild 1230
RMD160 d9d973b11b38ddbeb29cdb463c82c33a0e8f6534 dash-0.5.3.7.ebuild 1230
diff --git a/app-shells/dash/dash-0.5.3.7-r1.ebuild b/app-shells/dash/dash-0.5.3.7-r1.ebuild
index 052f790278a6..d1b7a56a1e9b 100644
--- a/app-shells/dash/dash-0.5.3.7-r1.ebuild
+++ b/app-shells/dash/dash-0.5.3.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7-r1.ebuild,v 1.2 2007/05/19 13:42:58 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.3.7-r1.ebuild,v 1.3 2007/05/19 15:57:12 uberlord Exp $
inherit autotools eutils flag-o-matic toolchain-funcs
@@ -24,13 +24,6 @@ DEPEND="libedit? ( dev-libs/libedit )"
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use static && use libedit ; then
- eerror "You cannot build dash with both static and libedit USE flags"
- die "You cannot build dash with both static and libedit USE flags"
- fi
-}
-
src_unpack() {
unpack ${A}
@@ -44,7 +37,9 @@ src_unpack() {
# Always statically link libedit in to ensure we always boot if it changes
# which it has done in the past.
- sed -i -e 's/-ledit/-lncurses -Wl,-Bstatic -ledit -Wl,-Bdynamic/g' configure.ac || die
+ local s="s/-ledit/-Wl,-Bstatic -ledit -Wl,-Bdynamic -lcurses/g"
+ use static && s="s/-ledit/-ledit -lcurses/g"
+ sed -i -e "${s}" configure.ac || die "Failed to sed configure.ac"
# May as well, as the debian patches force this anyway
eautoreconf
@@ -53,12 +48,11 @@ src_unpack() {
src_compile() {
local myconf=
- use libedit && myconf="${myconf} --with-libedit"
use static && append-ldflags -static
+ use libedit && myconf="${myconf} --with-libedit"
export CC="$(tc-getCC)"
econf ${myconf} || die "econf failed"
-
emake CFLAGS="${CFLAGS}" || die "emake failed"
}