summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-08-16 19:25:30 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-08-16 19:25:30 +0000
commitf3587c0c8283784d1f0aff88c86a6bd67871c937 (patch)
tree1e1dff3d32cb1d62e959a124c8dd2d7393076bcb /app-sci/xcircuit
parentversion bump (diff)
downloadhistorical-f3587c0c8283784d1f0aff88c86a6bd67871c937.tar.gz
historical-f3587c0c8283784d1f0aff88c86a6bd67871c937.tar.bz2
historical-f3587c0c8283784d1f0aff88c86a6bd67871c937.zip
added filtering of CFLAGS (O3 -> O2)
Diffstat (limited to 'app-sci/xcircuit')
-rw-r--r--app-sci/xcircuit/ChangeLog7
-rw-r--r--app-sci/xcircuit/xcircuit-2.5.4.ebuild11
2 files changed, 14 insertions, 4 deletions
diff --git a/app-sci/xcircuit/ChangeLog b/app-sci/xcircuit/ChangeLog
index cc69dc3e68d7..e7fd416a270a 100644
--- a/app-sci/xcircuit/ChangeLog
+++ b/app-sci/xcircuit/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/ChangeLog,v 1.2 2002/07/25 16:18:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/ChangeLog,v 1.3 2002/08/16 19:25:30 george Exp $
*xcircuit-2.5.4 (5 Apr 2003)
+ 16 Aug 2002; George Shapovalov <george@gentoo.org> xcircuit-2.5.4.ebuild :
+
+ due to report by Marius Bernklev <mariube@sex.ifi.uio.no> added code
+ to replace -O3 -> -O2 in C[XX]FLAGS
+
25 Jul 2002; Daniel Ahlberg <aliz@gentoo.org> xcircuit-2.5.4.ebuild :
Added LICENSE, KEYWORDS, SLOT.
diff --git a/app-sci/xcircuit/xcircuit-2.5.4.ebuild b/app-sci/xcircuit/xcircuit-2.5.4.ebuild
index 8fbc15ed92de..0a039cd2f629 100644
--- a/app-sci/xcircuit/xcircuit-2.5.4.ebuild
+++ b/app-sci/xcircuit/xcircuit-2.5.4.ebuild
@@ -1,14 +1,15 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/xcircuit-2.5.4.ebuild,v 1.3 2002/07/25 16:18:19 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xcircuit/xcircuit-2.5.4.ebuild,v 1.4 2002/08/16 19:25:30 george Exp $
+
+inherit flag-o-matic
S=${WORKDIR}/${P}
DESCRIPTION="Circuit drawing and schematic capture program."
-
SRC_URI="http://bach.ece.jhu.edu/~tim/programs/xcircuit/archive/${P}.tar.bz2"
-
HOMEPAGE="http://bach.ece.jhu.edu/~tim/programs/xcircuit/xcircuit.html"
+
KEYWORDS="x86"
SLOT="0"
LICENSE="GPL-2"
@@ -16,6 +17,10 @@ LICENSE="GPL-2"
DEPEND="virtual/x11
dev-lang/python
app-text/ghostscript"
+RDEPEND="${DEPEND}"
+
+#looks like -O3 causes problems at times
+replace-flags -O3 -O2
src_compile() {