summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-05-08 02:04:28 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-05-08 02:04:28 +0000
commit08745294b86c08e02d6d156499dfcc2d8d90f958 (patch)
tree8a4764d50ac7816be97ec4570b2a4ee1471b76a2 /app-sci/octave
parentMerging in changes from default-1.0. (diff)
downloadhistorical-08745294b86c08e02d6d156499dfcc2d8d90f958.tar.gz
historical-08745294b86c08e02d6d156499dfcc2d8d90f958.tar.bz2
historical-08745294b86c08e02d6d156499dfcc2d8d90f958.zip
moved app-misc/{babel,netcdf} and dev-lang/{iverilog,octave} into app-sci
Diffstat (limited to 'app-sci/octave')
-rw-r--r--app-sci/octave/ChangeLog11
-rw-r--r--app-sci/octave/files/digest-octave-2.0.161
-rw-r--r--app-sci/octave/octave-2.0.16.ebuild46
3 files changed, 58 insertions, 0 deletions
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
new file mode 100644
index 000000000000..13646e247423
--- /dev/null
+++ b/app-sci/octave/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.1 2002/05/08 02:04:28 george Exp $
+
+*octave-2.0.16 (19 Feb 2002)
+
+ 19 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog, octave-2.0.16.ebuild :
+
+ Initial commit. GNU Octave is a high-level language, primarily intended
+ for numerical computations. It is mostly compatible with Matlab.
+
diff --git a/app-sci/octave/files/digest-octave-2.0.16 b/app-sci/octave/files/digest-octave-2.0.16
new file mode 100644
index 000000000000..e4495104242d
--- /dev/null
+++ b/app-sci/octave/files/digest-octave-2.0.16
@@ -0,0 +1 @@
+MD5 439e8e70706c875149836146d1ccebe0 octave-2.0.16.tar.bz2 3009214
diff --git a/app-sci/octave/octave-2.0.16.ebuild b/app-sci/octave/octave-2.0.16.ebuild
new file mode 100644
index 000000000000..8f768c2e40a7
--- /dev/null
+++ b/app-sci/octave/octave-2.0.16.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tod@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.0.16.ebuild,v 1.1 2002/05/08 02:04:28 george Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations."
+
+SRC_URI="ftp://ftp.octave.org/pub/octave/${P}.tar.bz2"
+
+HOMEPAGE="http://www.octave.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1"
+
+PROVIDE="dev-lang/octave"
+
+src_compile() {
+
+ local myconf="--enable-shared --enable-dl --enable-lite-kernel"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc BUGS COPYING ChangeLog* INSTALL* NEWS* PROJECTS README* ROADMAP \
+ SENDING-PATCHES THANKS
+
+}