summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-06-09 21:53:18 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-06-09 21:53:18 +0000
commitbe73c9eef3096be7b68d9d6f6e10c7da86f48caf (patch)
tree087f02fb06b1ba1a7e96b9b1665ef0ea5af5c594 /app-sci/octave-forge
parentnew package - an add-on package for GNU octave (a MATLAB clone) (diff)
downloadhistorical-be73c9eef3096be7b68d9d6f6e10c7da86f48caf.tar.gz
historical-be73c9eef3096be7b68d9d6f6e10c7da86f48caf.tar.bz2
historical-be73c9eef3096be7b68d9d6f6e10c7da86f48caf.zip
new package - an add-on package for GNU octave (a MATLAB clone)
Diffstat (limited to 'app-sci/octave-forge')
-rw-r--r--app-sci/octave-forge/Manifest3
-rw-r--r--app-sci/octave-forge/files/digest-octave-forge-2003.02.221
-rw-r--r--app-sci/octave-forge/octave-forge-2003.02.22.ebuild54
3 files changed, 57 insertions, 1 deletions
diff --git a/app-sci/octave-forge/Manifest b/app-sci/octave-forge/Manifest
index 9be19ed3c7c0..e723aa5f1006 100644
--- a/app-sci/octave-forge/Manifest
+++ b/app-sci/octave-forge/Manifest
@@ -1,2 +1,3 @@
-MD5 95f09fb904e81031605ed6a8a500368d octave-forge-2003.02.22.ebuild 1801
+MD5 cff81894fc3968f2d3e79d20a8b93f57 octave-forge-2003.02.22.ebuild 1915
+MD5 18d8ca09df07403569039bcfb4e5c029 ChangeLog 620
MD5 df51218baee555e6ec187aa95115aa01 files/digest-octave-forge-2003.02.22 76
diff --git a/app-sci/octave-forge/files/digest-octave-forge-2003.02.22 b/app-sci/octave-forge/files/digest-octave-forge-2003.02.22
new file mode 100644
index 000000000000..98d2c50a4f27
--- /dev/null
+++ b/app-sci/octave-forge/files/digest-octave-forge-2003.02.22
@@ -0,0 +1 @@
+MD5 cb82a3da24197369cc4bf4be66b42600 octave-forge-2003.02.22.tar.gz 2306124
diff --git a/app-sci/octave-forge/octave-forge-2003.02.22.ebuild b/app-sci/octave-forge/octave-forge-2003.02.22.ebuild
new file mode 100644
index 000000000000..75cfecd34731
--- /dev/null
+++ b/app-sci/octave-forge/octave-forge-2003.02.22.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave-forge/octave-forge-2003.02.22.ebuild,v 1.1 2003/06/09 21:53:15 george Exp $
+
+DESCRIPTION="A collection of custom scripts, functions and extensions for GNU Octave"
+HOMEPAGE="http://octave.sourceforge.net/"
+SRC_URI="mirror://sourceforge/octave/${P}.tar.gz"
+
+LICENSE="as-is"
+# I have only tested this library on x86
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="ginac qhull"
+
+DEPEND=">=app-sci/octave-2.1.44
+ sys-libs/libtermcap-compat
+ ginac? ( app-sci/ginac )
+ qhull? ( >=media-libs/qhull-3.1-r1 )"
+
+
+src_compile() {
+ econf || die "econf failed"
+
+ # The MPATH, OPATH, and XPATH variables need to be changed, or they will
+ # cause Portage access violations. They cannot be easily set just using
+ # arguments passed to ./configure (at least, they can not easily be set
+ # correctly)
+ echo -en "Modifying paths..."
+ sed -i "s|^\(MPATH = \)|\1${D}|" Makeconf || die "failed to modify MPATH"
+ sed -i "s|^\(OPATH = \)|\1${D}|" Makeconf || die "failed to modify OPATH"
+ sed -i "s|^\(XPATH = \)|\1${D}|" Makeconf || die "failed to modify XPATH"
+ echo -e "done.\n"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ # strip the fudged install paths
+ sed -i "s|${D}||g" ${D}/usr/bin/mex || die "sed failed"
+
+ dodoc AUTHORS COPYING* ChangeLog INDEX RELEASE-NOTES TODO
+}
+
+pkg_postinst() {
+ einfo "If you do not have GiNaC and Qhull installed, octave-forge did not"
+ einfo "compile itself with support for the geometry and symbolic math"
+ einfo "extensions. If you would like these features, please emerge ginac"
+ einfo "and/or qhull and then re-emerge octave-forge. Alternately, you can"
+ einfo "specify USE='ginac qhull' and re-emerge octave-forge; in that case"
+ einfo "the ebuild will automatically install the additional packages."
+}
+