summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-01-21 23:06:04 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-01-21 23:06:04 +0000
commit556b1d49829f9d3310a3fed8349dae7e107e235b (patch)
tree0ebb8205e4327295fe77ccecba6d7c2d1a37f256 /app-sci/coq
parentInitial commit. Added norealanalysis use flag to use.local.desc (diff)
downloadhistorical-556b1d49829f9d3310a3fed8349dae7e107e235b.tar.gz
historical-556b1d49829f9d3310a3fed8349dae7e107e235b.tar.bz2
historical-556b1d49829f9d3310a3fed8349dae7e107e235b.zip
Initial commit. Added norealanalysis use flag to use.local.desc
Diffstat (limited to 'app-sci/coq')
-rw-r--r--app-sci/coq/Manifest4
-rw-r--r--app-sci/coq/coq-7.4.ebuild39
-rw-r--r--app-sci/coq/files/digest-coq-7.41
-rw-r--r--app-sci/coq/files/ocaml-3.07.patch10
-rw-r--r--app-sci/coq/metadata.xml9
5 files changed, 62 insertions, 1 deletions
diff --git a/app-sci/coq/Manifest b/app-sci/coq/Manifest
index 77fd97302209..fae5485ace80 100644
--- a/app-sci/coq/Manifest
+++ b/app-sci/coq/Manifest
@@ -1,3 +1,5 @@
-MD5 7a800e0e86a2ddfb190813abb900b64e coq-7.4.ebuild 745
+MD5 5b3bd95c81c08df116223beb9ca0de4f coq-7.4.ebuild 976
+MD5 5af6b26df9264817e5b6a292c1436417 metadata.xml 238
+MD5 8ea318dfb8fa73049a3d5b26257daba7 ChangeLog 467
MD5 d3f33f3602d82ea691f91b062dbf236b files/digest-coq-7.4 60
MD5 393c3085f82f205122b4e66c94232ff7 files/ocaml-3.07.patch 333
diff --git a/app-sci/coq/coq-7.4.ebuild b/app-sci/coq/coq-7.4.ebuild
new file mode 100644
index 000000000000..57fb792f0829
--- /dev/null
+++ b/app-sci/coq/coq-7.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/coq/coq-7.4.ebuild,v 1.1 2004/01/21 23:05:55 mattam Exp $
+
+IUSE="norealanalysis"
+
+DESCRIPTION="Coq is a proof assistant written in O'Caml"
+HOMEPAGE="http://coq.inria.fr/"
+SRC_URI="ftp://ftp.inria.fr/INRIA/${PN}/V${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=dev-lang/ocaml-3.06"
+
+src_compile() {
+ local myconf="--prefix /usr \
+ --bindir /usr/bin \
+ --libdir /usr/lib/coq \
+ --mandir /usr/man \
+ --emacslib /usr/share/emacs/site-lisp"
+
+ use norealanalysis && myconf="$myconf --reals"
+ use norealanalysis || myconf="$myconf --reals all"
+
+ has_version ">=dev-lang/ocaml-3.07" && epatch ${FILESDIR}/ocaml-3.07.patch
+
+ echo $myconf
+
+ ./configure $myconf || die
+
+ emake world || die
+}
+
+src_install() {
+ make COQINSTALLPREFIX=${D} install || die
+ dodoc README CREDITS CHANGES LICENSE
+}
diff --git a/app-sci/coq/files/digest-coq-7.4 b/app-sci/coq/files/digest-coq-7.4
new file mode 100644
index 000000000000..ab1d3353a4d9
--- /dev/null
+++ b/app-sci/coq/files/digest-coq-7.4
@@ -0,0 +1 @@
+MD5 13ac61f150823e54ad84a9096e2dd646 coq-7.4.tar.gz 1537547
diff --git a/app-sci/coq/files/ocaml-3.07.patch b/app-sci/coq/files/ocaml-3.07.patch
new file mode 100644
index 000000000000..707c51039b8a
--- /dev/null
+++ b/app-sci/coq/files/ocaml-3.07.patch
@@ -0,0 +1,10 @@
+--- /root/tmp/coq-7.4/parsing/pcoq.ml4 2002-12-15 13:10:18.000000000 +0100
++++ parsing/pcoq.ml4 2003-10-16 13:00:15.000000000 +0200
+@@ -108,6 +108,7 @@
+ type parsable = G.parsable
+ let parsable = G.parsable
+ let tokens = G.tokens
++ let glexer = G.glexer
+ module Entry = G.Entry
+ module Unsafe = G.Unsafe
+
diff --git a/app-sci/coq/metadata.xml b/app-sci/coq/metadata.xml
new file mode 100644
index 000000000000..75191cd37a28
--- /dev/null
+++ b/app-sci/coq/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <herd>ml</herd>
+ <maintainer>
+ <email>mattam@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>