summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-02 21:55:55 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-02 21:55:55 +0000
commitc80b0e8ca169b64fbbf43ad3ac8f7a405b3b9c51 (patch)
tree53893723169ca32c163ef9a94be7ea50b9076637 /app-pda/malsync
parentinitial package (diff)
downloadhistorical-c80b0e8ca169b64fbbf43ad3ac8f7a405b3b9c51.tar.gz
historical-c80b0e8ca169b64fbbf43ad3ac8f7a405b3b9c51.tar.bz2
historical-c80b0e8ca169b64fbbf43ad3ac8f7a405b3b9c51.zip
initial package
Diffstat (limited to 'app-pda/malsync')
-rw-r--r--app-pda/malsync/Manifest6
-rw-r--r--app-pda/malsync/files/Makefile-pilot-link.diff25
-rw-r--r--app-pda/malsync/files/digest-malsync-2.2.01
-rw-r--r--app-pda/malsync/malsync-2.2.0.ebuild32
4 files changed, 62 insertions, 2 deletions
diff --git a/app-pda/malsync/Manifest b/app-pda/malsync/Manifest
index 4fcff135229d..c7fd78482d8a 100644
--- a/app-pda/malsync/Manifest
+++ b/app-pda/malsync/Manifest
@@ -1,2 +1,4 @@
-MD5 9d1bbde7ffe4b4e712f1cba48aa78b6a malsync-2.2.0.ebuild 772
-MD5 df28420b372ebc79d5a54141875d0339 files/digest-malsync-2.2.0 139
+MD5 6d43c258d4d770da64622cc0ef0f27db ChangeLog 443
+MD5 4ed118e361f5e1f11ca307c097648102 malsync-2.2.0.ebuild 706
+MD5 79de07eaf8aef5d2365c2b808a2c41f1 files/Makefile-pilot-link.diff 766
+MD5 b15026dbb7b12d3419c2fd6e9c9845c1 files/digest-malsync-2.2.0 69
diff --git a/app-pda/malsync/files/Makefile-pilot-link.diff b/app-pda/malsync/files/Makefile-pilot-link.diff
new file mode 100644
index 000000000000..845ecb9616a7
--- /dev/null
+++ b/app-pda/malsync/files/Makefile-pilot-link.diff
@@ -0,0 +1,25 @@
+diff -urN malsync.orig/Makefile malsync/Makefile
+--- malsync.orig/Makefile 2003-05-30 19:42:14.000000000 -0400
++++ malsync/Makefile 2003-08-01 16:29:24.000000000 -0400
+@@ -15,10 +15,10 @@
+ endif
+
+ TREETOP = .
+-PILOT_LINK_DIR = $(TREETOP)/pilot-link-0.11.7
++PILOT_LINK_DIR = /usr/include/libpisock
+
+ CFLAGS = -Wall -g -DMALSYNC -I$(TREETOP)/mal/common \
+- -I$(TREETOP)/mal/client/common -I$(PILOT_LINK_DIR)/include \
++ -I$(TREETOP)/mal/client/common -I$(PILOT_LINK_DIR) \
+ -I$(TREETOP)/mal/client/unix
+
+ ifeq ($(PLAT),Darwin)
+@@ -73,7 +73,7 @@
+
+ $(TARGET): $(OBJS)
+ $(CC) $(DYNLINK) $(CFLAGS) -o $@ $(OBJS) \
+- ${PILOT_LINK_DIR}/libpisock/.libs/libpisock.a $(LINKLIBS)
++ /usr/lib/libpisock.a $(LINKLIBS)
+ clean:
+ rm -f $(OBJS) $(TARGET)
+
diff --git a/app-pda/malsync/files/digest-malsync-2.2.0 b/app-pda/malsync/files/digest-malsync-2.2.0
new file mode 100644
index 000000000000..2568629046f2
--- /dev/null
+++ b/app-pda/malsync/files/digest-malsync-2.2.0
@@ -0,0 +1 @@
+MD5 d1c41526b91bb38c21a4ced01d26328c malsync_2.2.0.src.tar.gz 173851
diff --git a/app-pda/malsync/malsync-2.2.0.ebuild b/app-pda/malsync/malsync-2.2.0.ebuild
new file mode 100644
index 000000000000..5ea45707ee87
--- /dev/null
+++ b/app-pda/malsync/malsync-2.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/malsync/malsync-2.2.0.ebuild,v 1.1 2003/09/02 21:55:49 liquidx Exp $
+
+MY_P=${P/-/_}
+
+DESCRIPTION="A command line tool that allows Palm Pilots to synchronize to the AvantGo.com server"
+HOMEPAGE="http://www.tomw.org/malsync/"
+SRC_URI="http://www.tomw.org/malsync/${MY_P}.src.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-1.0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=app-pda/pilot-link-0.11.7"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/Makefile-pilot-link.diff
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin malsync
+ dodoc Doc/*
+}