summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2010-09-25 20:43:32 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2010-09-25 20:43:32 +0000
commit7d167030c2cc9cc5511fcdc2c6629373ec9231a6 (patch)
tree64c35c1840d74e9defc878d09eab4f1eb9b3fadd /app-office
parentRe-added the database management application of koffice (diff)
downloadhistorical-7d167030c2cc9cc5511fcdc2c6629373ec9231a6.tar.gz
historical-7d167030c2cc9cc5511fcdc2c6629373ec9231a6.tar.bz2
historical-7d167030c2cc9cc5511fcdc2c6629373ec9231a6.zip
Version bump
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'app-office')
-rw-r--r--app-office/kplato/ChangeLog8
-rw-r--r--app-office/kplato/kplato-2.2.2.ebuild40
-rw-r--r--app-office/kpresenter/ChangeLog8
-rw-r--r--app-office/kpresenter/kpresenter-2.2.2.ebuild35
-rw-r--r--app-office/krita/ChangeLog8
-rw-r--r--app-office/krita/krita-2.2.2.ebuild55
-rw-r--r--app-office/kspread/ChangeLog8
-rw-r--r--app-office/kspread/kspread-2.2.2.ebuild47
-rw-r--r--app-office/kword/ChangeLog8
-rw-r--r--app-office/kword/kword-2.2.2.ebuild49
10 files changed, 261 insertions, 5 deletions
diff --git a/app-office/kplato/ChangeLog b/app-office/kplato/ChangeLog
index 9503e95d16aa..e56324e6067e 100644
--- a/app-office/kplato/ChangeLog
+++ b/app-office/kplato/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kplato
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/ChangeLog,v 1.76 2010/03/31 21:47:28 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/ChangeLog,v 1.77 2010/09/25 20:36:55 dilfridge Exp $
+
+*kplato-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kplato-2.2.2.ebuild:
+ Version bump
*kplato-2.1.2 (31 Mar 2010)
diff --git a/app-office/kplato/kplato-2.2.2.ebuild b/app-office/kplato/kplato-2.2.2.ebuild
new file mode 100644
index 000000000000..847476a4eeae
--- /dev/null
+++ b/app-office/kplato/kplato-2.2.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kplato/kplato-2.2.2.ebuild,v 1.1 2010/09/25 20:36:55 dilfridge Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KPlato is a project management application."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="~app-office/kchart-${PV}:${SLOT}[reports]"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libs/"
+KMEXTRA="
+ filters/${KMMODULE}/
+ kdgantt/
+"
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with python PythonLibs)
+ -DBUILD_kplato=ON
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}
diff --git a/app-office/kpresenter/ChangeLog b/app-office/kpresenter/ChangeLog
index d078fc45f018..c8928284c9c9 100644
--- a/app-office/kpresenter/ChangeLog
+++ b/app-office/kpresenter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kpresenter
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kpresenter/ChangeLog,v 1.99 2010/03/31 21:46:43 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kpresenter/ChangeLog,v 1.100 2010/09/25 20:38:59 dilfridge Exp $
+
+*kpresenter-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kpresenter-2.2.2.ebuild:
+ Version bump
*kpresenter-2.1.2 (31 Mar 2010)
diff --git a/app-office/kpresenter/kpresenter-2.2.2.ebuild b/app-office/kpresenter/kpresenter-2.2.2.ebuild
new file mode 100644
index 000000000000..c1593a5932bd
--- /dev/null
+++ b/app-office/kpresenter/kpresenter-2.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kpresenter/kpresenter-2.2.2.ebuild,v 1.1 2010/09/25 20:38:59 dilfridge Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice presentation program."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.35.0"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ filters/libmsooxml/
+ libs/
+"
+KMEXTRA="
+ filters/${KMMODULE}/
+ filters/libmso/
+"
+
+KMLOADLIBS="koffice-libs"
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}
diff --git a/app-office/krita/ChangeLog b/app-office/krita/ChangeLog
index ccf2d0412c11..27030f91d878 100644
--- a/app-office/krita/ChangeLog
+++ b/app-office/krita/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/krita
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/krita/ChangeLog,v 1.116 2010/05/15 16:50:18 reavertm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/krita/ChangeLog,v 1.117 2010/09/25 20:41:13 dilfridge Exp $
+
+*krita-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +krita-2.2.2.ebuild:
+ Version bump
15 May 2010; Maciej Mrozowski <reavertm@gentoo.org> krita-2.1.0.ebuild,
krita-2.1.1.ebuild, krita-2.1.2.ebuild:
diff --git a/app-office/krita/krita-2.2.2.ebuild b/app-office/krita/krita-2.2.2.ebuild
new file mode 100644
index 000000000000..2167253237a7
--- /dev/null
+++ b/app-office/krita/krita-2.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/krita/krita-2.2.2.ebuild,v 1.1 2010/09/25 20:41:13 dilfridge Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KOffice image manipulation program."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gmm +kdcraw openexr +pdf +tiff"
+
+DEPEND="
+ >=app-office/koffice-libs-${PV}:${SLOT}[openexr=]
+ >=dev-cpp/eigen-2.0.3:2
+ >=media-libs/qimageblitz-0.0.4
+ >=media-gfx/exiv2-0.16
+ gmm? ( sci-mathematics/gmm )
+ kdcraw? ( >=kde-base/libkdcraw-${KDE_MINIMAL} )
+ opengl? ( media-libs/glew )
+ pdf? ( >=app-text/poppler-0.12.3-r3[qt4] )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libs/"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_Eigen2=ON
+ -DWITH_Exiv2=ON
+ -DWITH_JPEG=ON
+ $(cmake-utils_use_with openexr OpenEXR)
+ $(cmake-utils_use_with gmm)
+ $(cmake-utils_use_with tiff)
+ $(cmake-utils_use_with kdcraw)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with opengl GLEW)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}
diff --git a/app-office/kspread/ChangeLog b/app-office/kspread/ChangeLog
index ccf310c83f88..18a644b30a65 100644
--- a/app-office/kspread/ChangeLog
+++ b/app-office/kspread/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kspread
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/ChangeLog,v 1.115 2010/03/31 21:49:51 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/ChangeLog,v 1.116 2010/09/25 20:33:05 dilfridge Exp $
+
+*kspread-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kspread-2.2.2.ebuild:
+ Version bump
*kspread-2.1.2 (31 Mar 2010)
diff --git a/app-office/kspread/kspread-2.2.2.ebuild b/app-office/kspread/kspread-2.2.2.ebuild
new file mode 100644
index 000000000000..dfb028768812
--- /dev/null
+++ b/app-office/kspread/kspread-2.2.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kspread/kspread-2.2.2.ebuild,v 1.1 2010/09/25 20:33:05 dilfridge Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice spreadsheet application."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+solver"
+
+DEPEND="
+ dev-cpp/eigen:2
+ solver? ( sci-libs/gsl )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ kchart/
+ interfaces/
+ libs/
+ filters/
+ plugins/
+"
+KMEXTRA="filters/${KMMODULE}/"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_Eigen2=ON
+ $(cmake-utils_use_with solver GSL)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}
diff --git a/app-office/kword/ChangeLog b/app-office/kword/ChangeLog
index 7c7221b61e30..a2ad977a6de3 100644
--- a/app-office/kword/ChangeLog
+++ b/app-office/kword/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/kword
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.147 2010/06/23 18:05:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/ChangeLog,v 1.148 2010/09/25 20:43:32 dilfridge Exp $
+
+*kword-2.2.2 (25 Sep 2010)
+
+ 25 Sep 2010; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kword-2.2.2.ebuild:
+ Version bump
23 Jun 2010; Markos Chandras <hwoarang@gentoo.org> kword-2.1.2.ebuild,
+files/kword-2.1.2-gcc45.patch:
diff --git a/app-office/kword/kword-2.2.2.ebuild b/app-office/kword/kword-2.2.2.ebuild
new file mode 100644
index 000000000000..6c5fc07149cd
--- /dev/null
+++ b/app-office/kword/kword-2.2.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/kword/kword-2.2.2.ebuild,v 1.1 2010/09/25 20:43:32 dilfridge Exp $
+
+EAPI="2"
+
+KMNAME="koffice"
+KMMODULE="${PN}"
+inherit kde4-meta
+
+DESCRIPTION="KOffice word processor."
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="wpd"
+
+DEPEND="
+ wpd? ( app-text/libwpd )
+"
+RDEPEND="${DEPEND}
+ !app-text/wv2
+"
+
+KMEXTRA="filters/${KMMODULE}/
+ filters/libmso/
+"
+
+KMEXTRACTONLY="
+ filters/
+ kspread/
+ libs/
+ plugins/
+"
+
+KMLOADLIBS="koffice-libs"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with wpd)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # this is already installed by koffice-data
+ rm -f "${D}/usr/include/config-opengl.h"
+}