summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-08-27 16:25:11 +0000
committerMarinus Schraal <foser@gentoo.org>2003-08-27 16:25:11 +0000
commit09ed91aa624a70be4b3158d10fbd6a2543b337aa (patch)
tree14cdbfc046cd7d0b8b183e43bd3c825e1b076e76 /app-office/abiword
parentnew dev version (diff)
downloadhistorical-09ed91aa624a70be4b3158d10fbd6a2543b337aa.tar.gz
historical-09ed91aa624a70be4b3158d10fbd6a2543b337aa.tar.bz2
historical-09ed91aa624a70be4b3158d10fbd6a2543b337aa.zip
new dev version
Diffstat (limited to 'app-office/abiword')
-rw-r--r--app-office/abiword/Manifest5
-rw-r--r--app-office/abiword/abiword-1.99.5.ebuild (renamed from app-office/abiword/abiword-1.99.3.ebuild)20
-rw-r--r--app-office/abiword/files/digest-abiword-1.99.32
-rw-r--r--app-office/abiword/files/digest-abiword-1.99.52
4 files changed, 17 insertions, 12 deletions
diff --git a/app-office/abiword/Manifest b/app-office/abiword/Manifest
index 950b6b6b4da5..9a992ad361f0 100644
--- a/app-office/abiword/Manifest
+++ b/app-office/abiword/Manifest
@@ -1,8 +1,8 @@
MD5 144371398dbe030e96f2e320cf8470c2 abiword-1.0.6-r1.ebuild 1930
-MD5 d487aadd5df02bcaac50d6dfb8f7ff3d abiword-1.99.5.ebuild 2749
+MD5 b78dcdc09b106f342cc5acb6f481a8ec abiword-1.99.5.ebuild 2421
MD5 1abe03d14ed3a4064bb061324361cab9 abiword-1.0.2-r1.ebuild 4687
MD5 fb253d2410ebab0b96d9939aac12c071 abiword-1.99.4-r2.ebuild 2619
-MD5 2bc42fdb6d52510bee09c92c03dea9cd ChangeLog 7884
+MD5 d3549987c8a7ac59e9cc1a79d6aa1705 ChangeLog 7884
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 d57b12387f05b71dd4e52f258a6e6e91 files/abiword-1.99.4-ots_buildfix.patch 416
MD5 475c8ca576317154869d2a10bbc4bf14 files/digest-abiword-1.99.5 144
@@ -10,7 +10,6 @@ MD5 9568c6ef14fe052d3d9f42747bda1aa2 files/digest-abiword-1.99.4-r2 144
MD5 4ab387fa04b0102a395a4b654f0714df files/abiword-1.1.4-wv_configure_fooling.patch 1575
MD5 31616e14907aefda2489036cc3d1db3d files/AbiWord.desktop 901
MD5 1ebcd22c6249c06e631c13491113d8ef files/AbiWord2.desktop 166
-MD5 2b9d4f094142556d7827af935a8fb64b files/abiword-1.99.5-cast_fix.patch 733
MD5 e6d9565092f5a6c2243401eccf1ca5a1 files/abiword-1.0.3-aspell.patch 812
MD5 7e39e4fdc4561d314daedcd78dce7ce3 files/digest-abiword-1.0.2-r1 67
MD5 55d85bca7cd645ef338336da3d6e6a7e files/digest-abiword-1.0.6-r1 67
diff --git a/app-office/abiword/abiword-1.99.3.ebuild b/app-office/abiword/abiword-1.99.5.ebuild
index 9c757e0d2e4b..3f17fe6f99c7 100644
--- a/app-office/abiword/abiword-1.99.3.ebuild
+++ b/app-office/abiword/abiword-1.99.5.ebuild
@@ -1,19 +1,20 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.99.3.ebuild,v 1.1 2003/07/28 17:57:40 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/abiword/abiword-1.99.5.ebuild,v 1.1 2003/08/27 16:25:02 foser Exp $
inherit eutils debug
IUSE="spell jpeg xml2 gnome"
S=${WORKDIR}/${P}/abi
-S_P=${WORKDIR}/${PN}-plugins-${PV}
+# REMIND : usually -${PV} needs to be added
+S_P=${WORKDIR}/${PN}-plugins
DESCRIPTION="Fully featured yet light and fast cross platform word processor"
HOMEPAGE="http://www.abisource.com"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2
- mirror://sourceforge/${PN}/${PN}-plugins-${PV}.tar.gz"
+ mirror://sourceforge/${PN}/${PN}-plugins-${PV}.tar.bz2"
KEYWORDS="~x86 ~sparc ~alpha ~ppc"
LICENSE="GPL-2"
@@ -36,24 +37,29 @@ RDEPEND="virtual/x11
>=gnome-extra/gal-1.99 )"
DEPEND="${RDEPEND}
+ sys-devel/automake
dev-util/pkgconfig"
# >=dev-libs/libole2-0.2.4-r1
# perl? ( >=dev-lang/perl-5.6 )
# perl seems broken
-# FIXME : do 'real' use switching, add gucharmap support
-# switches do not work by the looks of it
-
src_compile() {
-
./autogen.sh
+ # this is a hack since I don't want to go hack in the gnome-vfs headerfiles.
+ # The issue is about gnome-vfs containing "long long" which makes gcc 3.3.1 balk
+ cp configure configure.old
+ cat configure.old |sed s:-pedantic::g >configure
+ rm -f configure.old
+
econf \
`use_enable gnome` \
`use_with xml2 libxml2` \
`use_enable spell enchant` \
--enable-bidi \
+ --without-ImageMagick \
+ --disable-scripting \
--with-sys-wv || die
emake all-recursive || die
diff --git a/app-office/abiword/files/digest-abiword-1.99.3 b/app-office/abiword/files/digest-abiword-1.99.3
deleted file mode 100644
index 2ebedeb5bb58..000000000000
--- a/app-office/abiword/files/digest-abiword-1.99.3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 b5637c9bc95ae77aafdac24249787264 abiword-1.99.3.tar.bz2 14417825
-MD5 59c8b607a55a4b5329d4fbf116ef8ea2 abiword-plugins-1.99.3.tar.gz 1274469
diff --git a/app-office/abiword/files/digest-abiword-1.99.5 b/app-office/abiword/files/digest-abiword-1.99.5
new file mode 100644
index 000000000000..740a1a42c24c
--- /dev/null
+++ b/app-office/abiword/files/digest-abiword-1.99.5
@@ -0,0 +1,2 @@
+MD5 4b6fac4f358c0e83ffdd190260d9b6c4 abiword-1.99.5.tar.bz2 20331738
+MD5 c755a123187a60d4f9a1c17efae8e616 abiword-plugins-1.99.5.tar.bz2 671062